none
Difference between a program requesting elevated permissions via UAC and using -Verb RunAs RRS feed

  • Question

  • So, here is the problem.

    We are trying to diagnose some issues with our GoToAssist subscription.  Citrix wants us to run a log-retrieval program on the remote pc, but running the program requires admin privalages via the UAC.  When the UAC comes up, the remote screen goes black (As designed) waiting for the local user to enter the Admin user name and password, which we don't want to give out.

    I tried a Powershell script which successfully runs any .exe as Admin.  But this does not get us the information we need.  The log-retrieval program appears to be grabbing logs from the Admin user account, not the currently logged in account.  When I run the retrieval normally and give it elevated permissions, it seems to work fine.

    So, what is the difference between UAC elevating and RunAS Admin, and how can I get around it?

    John

    Wednesday, August 17, 2016 4:02 PM