none
Appdata/Roaming Folder redirection - trying to revert - not taking affect.

    Question

  • I am trying to turn off the redirection of our Appdata/Roaming directory. 

    I have the policy set  under policies/windows settings/folder redirection/appdata(roaming) to basic, to redirect back to the local path, to migrate the files back, and policy removal is set to redirect the folder back.  - This does not appear to work even thought I can confirm the policy applied via GPRESULT

    If I log in as a new user, the policy is set correctly and the new users appdata/roaming is stored locally. However, for any existing user, it does not actually set the flag or move the files back. My only workaround has been to delete the profile and rebuild. 

    Has anyone seen this before? Any thoughts?

    The desktops are Win7 x64 and the domain controllers are 2008 R2. 

    Friday, February 19, 2016 7:42 PM

Answers

  • Hi Brain,

    I have tested for Appdata/roaming redirection and succeed by these actions below.

    1. Set Target folder location from Create a folder for each user under the root path to Redirect to the local userprofile location
    2. Logon and run gpupdate /force, then type Y to logoff
    3. Delete the GPO and logon
    4. It is done, you could check by running gpupdate /force, there is no message about folder redirection and require logoff.

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 22, 2016 6:24 AM
    Moderator

All replies

  • I don't think the roaming profile data will get migrated to local path automatically. Please refer the similar thread below:

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/25f2d9ba-881b-430c-bb72-03a124254dc3/changed-folder-redirection-gpo-but-setting-will-not-take-affect?forum=winserverGP


    Regards, MC Manikandan

    Saturday, February 20, 2016 1:25 PM
  • Hi Brain,

    I have tested for Appdata/roaming redirection and succeed by these actions below.

    1. Set Target folder location from Create a folder for each user under the root path to Redirect to the local userprofile location
    2. Logon and run gpupdate /force, then type Y to logoff
    3. Delete the GPO and logon
    4. It is done, you could check by running gpupdate /force, there is no message about folder redirection and require logoff.

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 22, 2016 6:24 AM
    Moderator
  • Delete the GPO?  What about all the other settings in the GPO?
    Thursday, June 7, 2018 5:49 PM