locked
Exchange 2003-2010 OWA logon RRS feed

  • Question

  • I have user mailboxes on 2003 and a few on 2010 (testing phase). My mailbox on 2010 can send and receive emails no problem. But when I go to https://webmail.domain.com I get the OWA 2010 login screen but when I try to login nothing happens - just freezes.

    When a user who has a mailbox on 2003 goes to the same link and is presented with the 2010 OWA logon scrren and logs in they are then redirected to their OWA mailboxon Exchange 2003.

    I'm not sure but this may be because the legacy hostname is redirecting requests to 2003 and since it doesnt find my mailbox there it doesnt do anything. Is there anyway to have it check locally first on 2010 before redirecting?

    Thanks.

    • Edited by open24hrs Tuesday, September 27, 2011 9:31 PM
    Tuesday, September 27, 2011 9:17 PM

Answers

  • This is what fixed the problem.

     

    Set-OwaVirtualDirectory -identity "Owa (Default Web Site)" -LogonAndErrorLanguage 1033
    Set-OwaVirtualDirectory -identity "Owa (Default Web Site)" -DefaultClientLanguage 1033

    • Marked as answer by open24hrs Thursday, October 6, 2011 8:41 PM
    Thursday, October 6, 2011 8:41 PM

All replies

  • Hi,

    Are you publishing OWA direct to the Exchange 2010 CAS, or are you publishing via TMG?

    Have you set your internal and external URLs correctly on the Exchange 2010 CAS Server OWA Virtual Directory?

    Dave

    Wednesday, September 28, 2011 2:45 AM
  • If you get The OWA login screen while connecting to https://webmail.domain.com ,you must have configured some redirection in IIS. The default URL is https://webmail.domain.com/owa so I would suggest that you revert the configured setting and test OWA login again.
    Martina Miskovic - http://www.nic2012.com/
    Wednesday, September 28, 2011 4:19 AM
  • I'm not sure what you mean by TMG. How I have it set up where mail should be going through 2010 and then to the mailboxes on 2003. All mail is flowing fine (OWA, active synch, RPC\HTTP, MAPI, etc).

    Yes, there is redirection on OWA, I set that up in IIS on 2010 so when someone types in https://webmail.domain.com they are auttomatically redirected to https://webmail.domain.com/owa - they then receive the 2010 OWA logon and then when they login they are redirected to their 2003 OWA inbox.

    The problem is that when users login to https://webmail.domain.com that have mailboxes on the 2010 server they are presented with the 2010 OWA login screen and when they try to login - nothing happens, the 2010 OWA login screen remain, just freezes sort of, doesnt know what to do.

    How can I make it where OWA knows that their mailbox is already on 2010 and doesnt need redirection?

    Thanks.

    Wednesday, September 28, 2011 1:51 PM
  • Hi,
    If redirection is not configured properly OWA will/can break.
    Since I don´t know how you have configed it, I would recommend to check out Brian Desmonds blogpost about how to configure it. There are also a lot a good comments that I can recommend you to read.

    Redirecting OWA URLs in Exchange 2010
    http://briandesmond.com/blog/redirecting-owa-urls-in-exchange-2010/


    I have tested Brians configuration with EX03 in the org and it worked for me.
    Martina Miskovic - http://www.nic2012.com/
    • Proposed as answer by Dave Baird - NZ Wednesday, September 28, 2011 7:24 PM
    Wednesday, September 28, 2011 4:55 PM
  • Hi,

    TMG = Threat Management Gateway. It's the successor to ISA.

    Agree with Martina - there is not enough configuration information here, so you'd probably be best to follow the link suggested above and (potentially) start again.

    Dave


    Wednesday, September 28, 2011 7:23 PM
  • Thanks Martina, I'll take a look at that link. What information should I provide you with though, please let me know?

    I have Exchange 2003 and am transitioning to 2010. Both servers are up and running fine. All email is flowing fine. 99% of the user mailboxes are on Exchange 2003 and I have a few test mailboxes on Exchange 2010.

    Email flows in through Exchange 2010 and is being proxied/redirected to Exchange 2003. The only problem I have is what is described above:

    When users login to https://webmail.domain.com that have mailboxes on the 2010 server they are presented with the 2010 OWA login screen and when they try to login - nothing happens.

    I know it's probably something simple as a URL or some type of editing. Thanks!

    Wednesday, September 28, 2011 9:57 PM
  • I have already configured the legacy hostname with my 2003 Exchange infrastructure and installed all the digital certificates etc, so that link you provided was already something I did a while ago.

    Redirection is working fine for users with mailboxes on 2003, it's just the 2010 user mailboxes that cannot be accessed when using the https://webmail.domain.com

    Thanks.

    Thursday, September 29, 2011 2:17 AM
  • I have user mailboxes on 2003 and a few on 2010 (testing phase). My mailbox on 2010 can send and receive emails no problem. But when I go to https://webmail.domain.com I get the OWA 2010 login screen but when I try to login nothing happens - just freezes.

    When a user who has a mailbox on 2003 goes to the same link and is presented with the 2010 OWA logon scrren and logs in they are then redirected to their OWA mailboxon Exchange 2003.

    I'm not sure but this may be because the legacy hostname is redirecting requests to 2003 and since it doesnt find my mailbox there it doesnt do anything. Is there anyway to have it check locally first on 2010 before redirecting?

      

    Thanks.


    Hi,

     

    For the coexistence of Exchange 2003 and Exchange 2010, it is recommended to put Exchange 2010 in the internet face, and then configure the following necessary:

     

    1.    The legacy.domain.com record on your DNS server both internally and externally for Exchange 2003 server access;

    2.    Setup the Exchange2003URL property and point it to legacy.domain.com; so that the Exchange 2010 server can redirect to Exchange server;

    3.    Enable FBA on both Exchange 2010 and Exchange 2003;

    4.    Install the same certificate for both server.

    5.    If there is firewall like TMG, open the network port for OWA access.

     

    For more information, please refer to “Upgrading Outlook Web App to Exchange 2010” at http://blogs.technet.com/b/exchange/archive/2009/12/02/3408921.aspx.


    Fiona
    • Proposed as answer by Fiona_Liao Thursday, September 29, 2011 9:25 AM
    Thursday, September 29, 2011 9:25 AM
  • Hi Fiona,thanks for the response.

    Please see below.

    For the coexistence of Exchange 2003 and Exchange 2010, it is recommended to put Exchange 2010 in the internet face, and then configure the following necessary:

     

    Done 1.    The legacy.domain.com record on your DNS server both internally and externally for Exchange 2003 server access;

     Done 2.    Setup the Exchange2003URL property and point it to legacy.domain.com; so that the Exchange 2010 server can redirect to Exchange server;

    Done 3.    Enable FBA on both Exchange 2010 and Exchange 2003;

    Done 4.    Install the same certificate for both server.

    No TMG 5.    If there is firewall like TMG, open the network port for OWA access.

     

    This is the problem that I still need help with:

     

    I noticed on my firewall that I still had the primary mail.domainname.com pointing to the Exchange 2003 server and when I pointed it to the 2010 Exchange server I was able to receive email from RPC\HTTTP, my mailbox is on 2010 - but then when I went to https://webmail.domain.com it didnt work.

    So this is the status:

    • Currently mail.domainname.com is pointing to Exchange 2003 Server in firewall
    • active sync is working for mailboxes on 2003 and 2010
    • OWA works internally and externally for 2003 mailbox users only
    • OWA doesnt work at all for 2010 users although they are presented with the 2010 logon screen
    • Exchange 2010 mailbox users cannot use RPC\HTTP, but when I switch mail.domain.com to the 2010 Exchange server in the firewall then they can (had to switch it back to 2003 Exchange server).

      I know it's just a little tweaking and I'll have it, thanks for all your help!!!

     

     

    Thursday, September 29, 2011 7:45 PM
  • Hi,

    Yes you are correct, it is tweaking issue.

    Why not point to Exchagne 2010 server on your firewall? the Exchange 2010 server handle the client requests and performs the redirection if the mailbox is resided in Exchange 2003 server. It is described in detailed in the blog I posted. I'd suggest you read it again. And also refer to

    Understanding Upgrade from Exchange 2003 to Exchange 2010
     
    Regarding the URL  https://webmail.domain.com, I assume you would like to access simplify the Outlook Web App URL, for example, a request to https://webmail.domain.com is directed to https://webmail.domain.com/owa.  Is that correct? if yes, please follow the instruction in http://technet.microsoft.com/en-us/library/aa998359.aspx.
     

     


    Fiona
    • Proposed as answer by Fiona_Liao Friday, September 30, 2011 1:40 AM
    Friday, September 30, 2011 1:39 AM
  • "Why not point to Exchagne 2010 server on your firewall? the Exchange 2010 server handle the client requests and performs the redirection if the mailbox is resided in Exchange 2003 server. It is described in detailed in the blog I posted. "

    because:

    "I noticed on my firewall that I still had the primary mail.domainname.com pointing to the Exchange 2003 server and when I pointed it to the 2010 Exchange server I was able to receive email from RPC\HTTTP, my mailbox is on 2010 - but then when I went to https://webmail.domain.com it didnt work."

    I need help in recognizing why it doesnt work when I point it to the 2010 server.

    Anyone? Thanks!!!

    Tuesday, October 4, 2011 6:23 PM
  • OK. I would suggest you verify the following:

     

    1. Application log and the IIS log on CAS server when the issue occurs; the ISA log on the firewall. It will help us research.
    2. Ttry to login in CAS server via https://localhost/owa to see if this works. It helps to isolate the fault from firewall.
    3. Verify the permission configuration on /OWA virtual directory. see http://blogs.technet.com/b/exchange/archive/2010/09/23/3411146.aspx.
    4. Verify if there is any redirect configuration on /owa and the default web site.

    hope it is helpful.


    Fiona

    • Edited by Fiona_Liao Wednesday, October 5, 2011 8:11 AM
    Wednesday, October 5, 2011 8:09 AM
  • any udpate?
    Fiona
    Thursday, October 6, 2011 8:06 AM
  • Hi Fiona,

    Application log has no errors for 2010 users trying to login. Logging in from the CAS server doesnt work either. There is redirection on the /owa directory. For the /owa virtual directory and the default website I have redirect requests to this destination: https://webmail.domain.com/owa

    Thursday, October 6, 2011 8:04 PM
  • This is what fixed the problem.

     

    Set-OwaVirtualDirectory -identity "Owa (Default Web Site)" -LogonAndErrorLanguage 1033
    Set-OwaVirtualDirectory -identity "Owa (Default Web Site)" -DefaultClientLanguage 1033

    • Marked as answer by open24hrs Thursday, October 6, 2011 8:41 PM
    Thursday, October 6, 2011 8:41 PM