Setup of PXE boot for SCCM 2012 RRS feed

  • Question

  • I have setup SCCM Server on a test network with IP I have also setup a DC which is running AD, DNS and DHCP and its IP is

    On what server do I install WDS and how do I configure WDS/DHCP to point SCCM 2012 to enable PXE boot

    Monday, July 16, 2012 3:54 AM


All replies

  • WDS is needed on the server that will be hosting your Distribution Point.

    Once you have the DP, you need to enable PXE support on it. Before you enable PXE support on the DP you install WDS.

    Have a look here for more detailed information: http://technet.microsoft.com/en-us/library/gg712266.aspx

    Monday, July 16, 2012 6:53 AM
  • You should install WDS on the SCCM server. You do not need to set additional options on the DHCP server if it's not on the same server as the WDS role :) Important thing is that WDS and DHCP is on the same subnet, otherwise you will need to setup an IP helper. But I assume that these two are on the same subnet?

    Blog: www.danielclasson.com/blog | LinkedIn: Daniel Classon | Twitter: @danielclasson

    Monday, July 16, 2012 8:40 AM
  • Contrary to Configuration Manager 2007, With 2012 you don't need to preinstall WDS. Just enable PXE on DP and WDS will be installed automatically. http://myitforum.com/myitforumwp/2011/11/08/configmgr-2012-no-need-to-manually-install-wds/

    About the location, avoid the DC, PXE server can be your ConfigMgr box, that works well, just you need to create 66/67 options in DHCP and look at iphelper to be sure that the switch/router does not block the traffic.

    Bechir Gharbi | My blog: @myITforum.com | Twitter: @Bechir_Gharbi | Linkedin: Bechir Gharbi | Time zone: GMT + 1

    Monday, July 16, 2012 1:29 PM
  • ok thanks for that.

    Now I am getting 

    PXE-T04: Access violation

    PXE-E36: Error reveived from TFTP server

    PXE-M0F: exiting intel PXE ROM

    I have setup option 66 in DHCP but option 67 " boot file name" i am having problems finding it.

    Cheers Michael

    Tuesday, July 17, 2012 12:41 AM
  • That error can be related to a wrong boot file name or to IPHelper settings. The option 67 should include SMSBoot\x86\wdsnbp.com otherwise if you use an non Microsoft dhcp like Linux so that will be \\SMSBoot\\x86\\wdsnbp.com

    Take a look at this link [it is for CM07 and it's applicable for CM 2012] http://support.microsoft.com/kb/2024414

    Bechir Gharbi | My blog: @myITforum.com | Twitter: @Bechir_Gharbi | Linkedin: Bechir Gharbi | Time zone: GMT + 1

    Tuesday, July 17, 2012 6:56 AM
  • Hi Bechir and all of helpers, Can i understand that just enable one DP for PXE support wil make it PXE point and then responds to PXE requests? I mean no further configuration on DHCP or any other network infrastructure devices? I see also that i need to enable one option else on the boot image to get it distibuted to PXE enabled DP. Please help and thank you in advance.
    Saturday, December 21, 2013 2:02 PM
  • If the client is in the same subnet as the PXE enabled DP no further network configuration is necessary. If it isn't you have to configure

    1. IP Helper on your switch/router to direct the request to the PXE enabled DP (preferred)


    2. Add DHCP Scope option to direct the request to the PXE enabled DP

    See how to do it here


    Gerry Hampson | Blog: www.gerryhampsoncm.blogspot.ie | LinkedIn: Gerry Hampson | Twitter: @gerryhampson

    • Edited by Gerry HampsonMVP Saturday, December 21, 2013 2:35 PM
    • Proposed as answer by Jammizi Thursday, February 13, 2014 3:17 AM
    Saturday, December 21, 2013 2:35 PM
  • @Daniel,

    DHCP servers are not on the same subnet. I might need to configure IP helper. A reference would help.


    Thursday, February 13, 2014 3:17 AM