none
VM creation failure with Python SDK on Azure public cloud RRS feed

  • Question

  • Hi,

    I have tried provisioning a VM in Azure Public Cloud using Azure python SDK with the action create_virtual_machine_deployment on the ServiceManagementService class in the SDK. The cloud service is getting created and is visible in the portal. However the deployment and the VM is not getting created. But the HTTP response is 202 with a request id being returned.

    Debug the response object within PyCharm editor shows the result contents as below:
    [('content-length', '0'), ('x-ms-servedbyregion', 'ussouth3'), ('x-ms-request-id', '230b407e00061c6cac679465c3d39082'), ('server', '1.0.6198.266 (rd_rdfe_stable.150918-1411) Microsoft-HTTPAPI/2.0'), ('cache-control', 'no-cache'), ('date', 'Thu, 08 Oct 2015 14:30:05 GMT')]

    I tried looking at the audit logs but could not find the corresponding HTTP request that was being submitted from the python SDK code. I am not able to find out the log entries on the server for the request that I had submitted. 
    So how do I trouble shoot this issue? Any pointers will be greatly appreciated.

    Thanks in advance.

    Thursday, October 8, 2015 3:11 PM