HIDESHELL=YES Causes "Dirty Environment Found" message when Windows boots for the first time


  • I have read several posts on this topic like where the Dirty Environment Found message appears, but the circumstances are a bit different in my case. 

    I have a new MDT 2012 Update 1 task sequence with a newly captured Windows 7 SP1 x86 image captured with MDT 2012 Update 1.

    If I run the task sequence with no HIDESHELL specified in CustomSettings.ini, it runs to completion with no issues.  If I set HIDESHELL=YES in CustomSettings.ini, then the StateRestore phase starts with booting to Windows 7, auto-logging in and then the task sequence continues.  At the same time, I get the Dirty Environment Found message and if I leave it alone, the task sequences completes with no errors, just with the Dirty Environment FOund message on top.

    This only happens when HIDESHELL=YES is specified in CustomSettings.ini.

    Tuesday, September 04, 2012 6:56 PM

All replies

  • A little more digging on this reveals that it is actually being caused by the Citrix On-Line Plug-In 12.1 installer.  I can change where I get the Dirty Environment prompt by moving the application install in the task sequence.   My command line is:

    CitrixOnlinePluginFull12.1.exe /noreboot /silent ENABLE_DYNAMIC_CLIENT_NAME=Yes ENABLE_SSON=Yes SERVER_LOCATION=

    When the install begins, two command windows open and disappear very quickly and then the Durty Environment FOund prompt appears.

    There is no reboot that occurs, but omething is launching another instance of LiteTouch.wsf, which sees that LTIDirty is TRUE and prompts while the task sequence continues in the background.

    Wednesday, September 05, 2012 3:12 PM
  • Hi eschloss, Were you able to resolve it? I have exactly the same issue as yours. Need your help to make this annoying message go away.


    Monday, December 10, 2012 1:25 PM
  • I did not resolve the issue.  I ended up taking HIDESHELL=YES out of my Custom Settings and adding a run command line step after each reboot to run taskkill.exe /IM explorer.exe /F to kill explorer amd aachieve essentially the same goal.
    • Proposed as answer by anuragyadav Tuesday, December 11, 2012 9:57 AM
    Monday, December 10, 2012 1:34 PM
  • Thankyou! I think, i will also kill the explorer instead of using HideShell=Yes. However, I will investigate whenever i find more time and provide update.


    Monday, December 10, 2012 2:00 PM
  • Citrix Receiver always has issues.

    In my case, figured out that Citrix kind of likes the interactive desktop when being installed. If you hide the shell which is basically - pausing the explorer UI, it fails to proceed.

    You have couple of options:

    1. Don't use HideShell
    2. Put Citrix Receiver part of the Image (I would not really do this one)
    3. In my case, just to make sure no one from the Desktop Support or End User plays around with anything during installation - I added a wallpaper for the administrator - "DO NOT TOUCH - INSTALLATION IN PROGRESS".

    Regards, Vik Singh "If this thread answered your question, please click on "Mark as Answer"

    Tuesday, December 11, 2012 8:25 AM
  • Thanks Vikram, I tested with killing explorer with taskkill and it works great. So, for now, I am going to use HideShell=No and kill the explorer.


    • Proposed as answer by Ashutosh1971 Friday, March 15, 2013 12:37 PM
    Tuesday, December 11, 2012 9:58 AM
  • can you explain where you used this command in your task sequence. If you can provide a screenshot of what it looks like i your task sequence would be helpful also. I'm getting the same error. I have already removed the hideshell from my custom.ini settings but still getting the error.  any help would be greatly apreciated.
    Saturday, April 18, 2015 9:24 PM
  • I just created a run command step in the task sequence each after each turn me it may reboot that runs the task taskkill.exe /im explorer.exe /f and that kills the explorer process instead of MDT hiding the shell. Ultimately I believe this is caused by the app install relaunching explorer to launch itself after installing.
    Saturday, April 18, 2015 9:33 PM
  • I don't think I fully understand where you are inputting this command.can you provide a screenshot of where you have this command running in your task sequence . or can you provide exactly where in the sequence task you added this command? In my task sequence there's only one place I see where its states to restart so I will test entering the command there and see how it goes.

    By the way are you experiencing issues with your task sequence hanging at first boot where it appears to pause and not continue with the task sequence? it appears the only way I can get the TS to continue is to reboot after 1st login and then the TS continues as normal  but i'm also getting the dirty environment error.

    Sunday, April 19, 2015 4:02 AM