none
Secondary DPM synchronizing unexpectedly too much data - file protection

    Question

  • Hello, I'm running on an issue and I'm afraid that i won't have the possiblity to open a case at MS so i hope an expert from MS would have an explanatin with this particular case:

    Scenario:

    two DPM Server version 2012 R2 V4.2.1603.0. One is a primary DPM protection for a our deduped File server and one is the secondary DPM Server protecting the first one.

    the Primary DPM do an optimized backup of the file server entire volume, we can see it represents 13TB used data on the Primary DPM replica volume

    the Secondary DPM is doing backup as non-optimized, which represents 31,5TB, indeed the dedup rate on our FS is more than 50%

    Everything worked well for year, until I reached the NTFS limitation on the secondary DPM: the file server, the Primary DPM and secondary DPM have been formated with NTFS 8K cluster size. This is enough thanks to dedup, but no more for the secondary DPM. It cannot grow over 32TB and now it needs more.

    So, on secondary DPM, I've deleted the protection group and replica and restart from scratch. I create a new protection group with replica size more than 32TB so Windows automatically formated it with NTFS cluster size 16K.

    Since then i'm running into this issue:

    The initial replica creation job on the secondary DPM succeed, but the first next synchronization job is synchronizing too much of data and fails with the error "disk full". When i look to properties of the replica on the secondary DPM, i can see it's indeed it's full, the synchronization job tried to sync more than 40TB of data whereas my file server represents about 32TB of non optimized data. So it's fail because it reached my replica volume size.

    I've run a consistency check which succeeded and go back to a normal state. But again the issue occur again at the next sync jobs.

    So question: in a file protection scenario, is it supported that the Primary DPM replica and the Secondary DPM replica are formatted with different NTFS cluster size? I suspect DPM Sync Filter not supporting this scenario correctly.

    As workaround, i'll try to use the registry setting forcefixeup to see if it can help in my case.

    Larry

     


    • Edited by Larry.B.IT Wednesday, February 07, 2018 5:17 PM typo
    Wednesday, February 07, 2018 5:14 PM

Answers

  • secondary protection for Dedup volumes is not a supported scenario

    possible workaround: make the Primary DPM replica be in non-optimized mode

    • Marked as answer by Larry.B.IT Monday, February 26, 2018 3:06 PM
    Monday, February 26, 2018 3:06 PM

All replies

  • Looks like i've identified the cause of my issue...

    I didn't notice before but suddently in the explorer I've seen an partition (ESP) that mapped with letter F: like this

    and i can't explain how is it possible but using resources monitor i've seen dpmra.exe synchronizing the data through this F: drive...

    removed the F: letter and now dpm synchronizations are performing normally through the correct replica volume path (mount point).

    now synchronizations are working correctly for the small test drive i'm protecting, let's see if i can synchronize correctly the big volume again

    Monday, February 19, 2018 11:08 PM
  • Still having the issue, removing the F: drive did not help.

    Again the consistency checks complete normally and successfully but subsequent synchronizations are abnormally transferring too much data and dont finish.

    What i've found is strange, i cans see dpmra.exe process writing data to the dedup chunk store of the secondary replica, which that should not happen because on a secondary file protection replica the backup is not optimized. The sync job spends all the time on synchronizing the dedup chunk store that i think is the issue:

    because this should not happen on a secondary replica

    I've check Consistency checks job, it doesn't synchronize dedup chunk store. So my issue seems coming from sync jobs themselves.

    Any idea how to fix??


    • Edited by Larry.B.IT Friday, February 23, 2018 10:30 PM
    Friday, February 23, 2018 10:28 PM
  • I already uninstalled and reinstalled DPM completely, it did not help
    • Marked as answer by Larry.B.IT Monday, February 26, 2018 3:04 PM
    • Unmarked as answer by Larry.B.IT Monday, February 26, 2018 3:04 PM
    Friday, February 23, 2018 10:32 PM
  • secondary protection for Dedup volumes is not a supported scenario

    possible workaround: make the Primary DPM replica be in non-optimized mode

    • Marked as answer by Larry.B.IT Monday, February 26, 2018 3:06 PM
    Monday, February 26, 2018 3:06 PM