locked
Windows 7 Laptop Timed Hibernation Not Working RRS feed

  • Question

  • Our laptops have power settings configured by Group Policy and it appears to be working because when we go into the power settings menus, the settings match what we set in group policy.

    Hibernation is enabled because it shows the hibernation option in the shutdown menu and it works when we hibernate manually.

    Our policy is set to have the laptops stay on an never sleep or hibernate when on AC power.

    The policy is set for closing the lid to do nothing.

    The policy is set for the system to never sleep.

    The policy is set for the system to hibernate after 20 minutes when on batter.

    So, I closed Outlook (so it would not keep checking for mail) and closed the laptop lid and put it in a bag and left the office.

    When I got around to opening the laptop bag and grabbing the laptop a few hours later, the laptop was very warm, when I opened the lid it woke up instantly (as if it was running and the screen was just tuned off) and the battery was almost dead. Obviously, it did not hibernate after 20 minutes on battery as the power plan settings specify.

    How can we fix this issue?

    Friday, April 4, 2014 9:11 PM

All replies

  • Hi,

    Please run the powercfg /query and powercfg /energy from command line, check if there are any applications that may prevent the laptop from entering hibernate mode. Or you can upload the results into onedrive, post the link here and we will help to take a look.

    Here is the command line options for reference:

    Powercfg Command-Line Options

    Best regards


    Michael Shao
    TechNet Community Support

    Monday, April 7, 2014 7:26 AM
  • Hi,

    Please run the powercfg /query and powercfg /energy from command line, check if there are any applications that may prevent the laptop from entering hibernate mode. Or you can upload the results into onedrive, post the link here and we will help to take a look.

    Here is the command line options for reference:

    Powercfg Command-Line Options

    Best regards


    Michael Shao
    TechNet Community Support

    Report

    One Drive Link To powercfg /query

    Tuesday, April 8, 2014 2:41 AM
  • Hi,

    The error shows that the policy that you have set is preventing the laptop from going into hibernate mode. When the High performance policy(on Battery) is enabled, and the disk idle is disabled(which means the disk is not configured to trun off after a period of disk inactivity), the laptop is considered not going into hibernate mode. When hibernation mode is activated, the contents of memory, which includes all current applications running in the computer, are saved to disk, and the computer is turned off.  Either by turning the power back on or pressing any keyboard key, the previous state of memory is read from disk, and the computer appears exactly as it did before hibernation.  Since the power is off in hibernation mode, it does not drain the battery.

    please take a check again to make sure there is no other policies that may conflicts.

    Best regards


    Michael Shao
    TechNet Community Support

    Wednesday, April 9, 2014 1:44 AM
  • I don't understand what you are saying will correct this problem without enabling other power settings we do not want.  

    Even though it is set for high performance, those settings have been customized.

    I understand what hibernation is and I have configured hibernation after 20 minutes (when on battery), but 20 minutes passes without hibernation going into effect.

    If the power plan configured to hibernate after 20 minutes, why does it matter about other settings?

    I do not want it to ever "sleep," only hibernate and even then only hibernate when on battery.

    Wednesday, April 9, 2014 3:12 AM
  • Can someone be more specific on the minimum that needs to be done to enable timed automatic hibernation only when on battery without also enabling sleep?

    Just enable turning off hard disk on battery and leave everything else the same?

    Change the profile from "high performance" to a different profile and then customizing the settings to disable sleep?

    Something else?

    Thursday, April 10, 2014 3:12 AM
  • As you can see that the configuration that you set is considered errors in the report, please first check with the configurations in the above, make sure it works with no errors.

    Rgds

    Tuesday, April 15, 2014 8:16 AM
  • I don't know what to check and make sure works with no errors.

    The information above does not appear to be "errors."

    I do not want to it to ever "sleep."  It should only hibernate.

    Is it not possible to both disable sleep state and still have the system hibernate after 20 minutes on the same system?

    Friday, April 25, 2014 11:56 PM