locked
Microsoft Application Virtualization Administrative Template (ADM Template) Not Working RRS feed

Answers

  • So it turns out that the ADM template doesn't work for x64 machines (even though they include a x64 template).  Long story short I used Group Policy Preferences to map to the correct registry key to set the server variable in the AppV 4.6 x64 Client.

    Microsoft, you need to update your ADM templates correctly this time!  Here is a hint, use this!

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\SoftGrid\4.5\Client\DC Servers

    http://www.microsoft.com/downloads/details.aspx?FamilyID=67CDF9D2-7E8E-4D76-A552-FD82DBBFF9BC&displaylang=en

    JS
    Thursday, March 11, 2010 8:15 PM

All replies

  • Hello,

    Tip would be the following;
    Verify that the GPO is applied successfully
    Verify what values are pushed out and where.

    /Znack
    Tuesday, March 9, 2010 7:53 PM
  • Thanks for the response

    After running a GPResult /R on the test machine it says the GPO was filtered out due to being empty.  This isn't true though, I have made modifications to the GPO.

    Update: I just ran the Group Policy results for the same user/machine on a domain controller.  It shows the GPO as "applied"
    JS
    Tuesday, March 9, 2010 8:41 PM
  • Hi,

    Did you also add the AppVirt64.adm template or just the AppVirt.adm template?
    Kent Agerlund | http://scug.dk/members/Agerlund/default.aspx | The Danish community for System Center products
    • Proposed as answer by znack Thursday, March 11, 2010 6:02 AM
    Wednesday, March 10, 2010 6:51 AM
  • Hi,

    Did you also add the AppVirt64.adm template or just the AppVirt.adm template?
    Kent Agerlund | http://scug.dk/members/Agerlund/default.aspx | The Danish community for System Center products
    Both

    JS
    Thursday, March 11, 2010 3:47 PM
  • So it turns out that the ADM template doesn't work for x64 machines (even though they include a x64 template).  Long story short I used Group Policy Preferences to map to the correct registry key to set the server variable in the AppV 4.6 x64 Client.

    Microsoft, you need to update your ADM templates correctly this time!  Here is a hint, use this!

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\SoftGrid\4.5\Client\DC Servers

    http://www.microsoft.com/downloads/details.aspx?FamilyID=67CDF9D2-7E8E-4D76-A552-FD82DBBFF9BC&displaylang=en

    JS
    Thursday, March 11, 2010 8:15 PM
  • Hello,

    This is really odd - I find the following keys referenced in the x64 adm;
     KEYNAME "Software\Wow6432Node\Microsoft\SoftGrid\4.5\Client\Configuration"
     KEYNAME "Software\Wow6432Node\Microsoft\SoftGrid\4.5\Client\Network"
     KEYNAME "Software\Wow6432Node\Microsoft\SoftGrid\4.5\Client\Reporting" 
     KEYNAME "Software\Wow6432Node\Microsoft\SoftGrid\4.5\Client\Permissions" 
     KEYNAME "SOFTWARE\Wow6432Node\Microsoft\SoftGrid\4.5\Client\CustomSettings"

    Doesn't look so bad - and no references to DC Servers?

    /Znack
    Thursday, March 11, 2010 9:20 PM
  • So the final path is this:

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\SoftGrid\4.5\Client\DC Servers\DisplayNameForAppVServer

    The keys under the DisplayNameForAppVServer folder are:

    Default
    Host
    ID
    Path
    Period
    Port
    Refresh
    Reporting
    Type

    JS
    Thursday, March 11, 2010 10:11 PM