locked
Game crash, freeze, or just stops. Program ends but the process does not. RRS feed

  • Question

  • Okay so lately I have had this problem. I play my games as normal, but once in a while it simply stops working. So I am prompted to end the task. After that I can not relaunch the game, web browser or even restart or shutdown my pc. If I don't have this problem, I can restart shutdown just fine. So what I did, is updated all my really old drivers, updated windows as it is set to auto, clean my drives, defragmented my HDD, and optimize all this stuff. Now my pc runs like new, but when I play Steam games they still have this problem. I have not tried other games yet, which I will do tonight. Anything else I ma try looking into? I would mess with my security setting in my software, but it worked be for so why would that have changed? 

    P.S. The only way I can find to shut off the broken process is to power down.

    • Edited by Samurninsai Thursday, February 27, 2014 7:53 PM Addition
    Thursday, February 27, 2014 7:52 PM

All replies

  • Hi,

    Do you mean when the game stops working and after you end the task, the desltop would not response to your actions, and the only way to shut down is to power the PC off?

    If it is, then there might be some hardware issue.

    Have you checked the game compatibility with hte OS and your hardware? This might be caused by the GPU.

    And we may consider to check this things on the steam website:

    https://support.steampowered.com/

    In addition, please take a look at the Event viewer, and check if there are any errors we could track with.

    Best regards


    Michael Shao
    TechNet Community Support

    Friday, February 28, 2014 8:56 AM
  •  

    Okay thank you. I can identify there is a problem with Steam. I see there is a error with the Firewall. More information is given about the events the occurred during the problem. I have this message from the event viewer:

    Event ID 10 - Event filter query functionality   problem

    There is a site saying I need WMI administrative tools to fix.

    Event ID 1015 - windows installer service availability. 

    Say to correct the ImagePath for a Msiexec executable.

    Event ID 12348 - Volume shadow copy service operations. 

    Says VSS does not have access to root directory.

    The program dota.exe version 0.0.0.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.

    Asks me to check the action center process ID. 

    There are a good many thing I need to fix I guess. Is there a way to make this easy? Or even to know that when I attempt to fix these what I am doing is right? 




    • Edited by Samurninsai Friday, February 28, 2014 3:28 PM
    Friday, February 28, 2014 3:27 PM
  • This seems the problem of that game, contact their support.

    Rgds

    Monday, March 3, 2014 3:28 AM
  • Now I remember when this started. I was running a Itunes movie, and it would turn to black. Sound kept playing but no video. Then I searched for why this would happen. In my task manager the process said it was using 1,300,000kb of system memory or something. I played the movie over and over to see if that was the problem. And every time the process reached around the 1.3 million mark the video would go blank. Now I see the same problem playing games too. I wonder it because my GPU uses both its own memory and shared memory if it is the problem. My GPU uses DDR3, and has a total or 1gb dedicated for itself. I checked the Total amount available and it says 3gb+1gb it has. Is there a way I could have changed this? Knowing me I would have add more memory to make games run faster or longer.
    Tuesday, March 4, 2014 4:07 AM
  • Also DX Diag won't show my Nvidia GPU. I use optimus, but still I think this is related, even though there is not proof. Something fishy with memory trades here. Maybe a setting I changed even. Then my library grew to large. Hmm this problem is out of my league. 
    Tuesday, March 4, 2014 4:28 AM
  • Here is an odd find. System information says, Geforce GT 550m, Dedicated video memory 1024 MB DDR3, System video memory 0, Shared system memory 3071mb. 
    Tuesday, March 4, 2014 4:33 AM