locked
Word 2010 + mailmerge + manual edit = wrong labels printed RRS feed

  • General discussion

  • Here is the situation.

    1) create a mail merge from an excel spreadsheet to a word document. This mail merge is for labels.

    2) do your address block and preview results, this all looks fine.

    3) Now in my case, i do not want to print pages and pages of labels. I only want to print two of the records. So i delete the rest of the records.

    4) I am re using the sheet of labels over again, so the labels are not necessarily in the positions i want them (as in some labels are used up so i need to manually reposition some labels). I copy and paste the labels to their proper places

    5) I print the labels. The labels which are printed are actually the first two records, not the records that i have copy and pasted. I go back and look at my document and the labels have AUTOMAGICALLY repopulated with the first two records from the merge. Its almost like its re-merging when i hit file menu -> print and whiping out any changes i made, such as moving labels around. I have not hit the "finish and merge" button.

     

    This behaviour does not occur with the exact same documents, in office 2007 or office 2003. I am able to move labels around, delete labels, then hit print and i get exactly what is showing on my screen. Also the document does not "auto update" the labels again after i have already merged it once.

     

    I think its a office 2010 bug as previous versions worked fine, but maybe its a "feature" that i can turn off? I have had no luck so far figuring it out and i just have to use another PC with office 2007 to do my labels now.

    Wednesday, January 19, 2011 9:22 PM

All replies

  • Maybe in Word 2010, you have the option to "Update fields before printing" checked under File>Options>Display>Printing Options and you had it unchecked in earlier versions.

    If that is not the case, you could select the desired labels and then use Ctrl+Shift+F9 to convert the data to ordinary text.  Do not then however save the document.  Or use Ctrl+F11 to lock the field and then Ctrl+Shift+F11 to unlock it after printing.


    Hope this helps.

    Doug Robbins - Word MVP,
    dkr[atsymbol]mvps[dot]org
    Posted via the Community Bridge

    "sharepointisneedlesslycomplex" wrote in message news:8f047c89-95d6-4a30-9dd9-f637282d321a@communitybridge.codeplex.com...

    Here is the situation.

    1) create a mail merge from an excel spreadsheet to a word document. This mail merge is for labels.

    2) do your address block and preview results, this all looks fine.

    3) Now in my case, i do not want to print pages and pages of labels. I only want to print two of the records. So i delete the rest of the records.

    4) I am re using the sheet of labels over again, so the labels are not necessarily in the positions i want them (as in some labels are used up so i need to manually reposition some labels). I copy and paste the labels to their proper places

    5) I print the labels. The labels which are printed are actually the first two records, not the records that i have copy and pasted. I go back and look at my document and the labels have AUTOMAGICALLY repopulated with the first two records from the merge. Its almost like its re-merging when i hit file menu -> print and whiping out any changes i made, such as moving labels around. I have not hit the "finish and merge" button.



    This behaviour does not occur with the exact same documents, in office 2007 or office 2003. I am able to move labels around, delete labels, then hit print and i get exactly what is showing on my screen. Also the document does not "auto update" the labels again after i have already merged it once.



    I think its a office 2010 bug as previous versions worked fine, but maybe its a "feature" that i can turn off? I have had no luck so far figuring it out and i just have to use another PC with office 2007 to do my labels now.


    Doug Robbins - Word MVP dkr[atsymbol]mvps[dot]org
    Wednesday, January 19, 2011 10:16 PM
  • Update fields is and was unchecked.

     

    Those ctrl shortcuts dont seem to work for me. I dont have F-Lock or anything, but i never use keyboard shortcuts so im not sure what sort of feedback they are supposed to provide.

     

    I highlight a few rows and press ctrl + f11 but it doesnt seem to do anything. Is there another way to lock the field?

    Also i tried printing and the problem still exists.

     

    thnks for the attempt though.

     

    Wednesday, January 19, 2011 10:28 PM
  • You won't see any change on the screen with either Ctrl+____+F9 or Ctrl+F11, but they will have the effect of preventing the data displayed by the fields from updating, by unlinking the data from the source in the first case, or locking the field in the second.


    Hope this helps.

    Doug Robbins - Word MVP,
    dkr[atsymbol]mvps[dot]org
    Posted via the Community Bridge

    "sharepointisneedlesslycomplex" wrote in message news:aaaf3b7a-2205-4711-831b-a7543300f3e2@communitybridge.codeplex.com...

    Update fields is and was unchecked.



    Those ctrl shortcuts dont seem to work for me. I dont have F-Lock or anything, but i never use keyboard shortcuts so im not sure what sort of feedback they are supposed to provide.



    I highlight a few rows and press ctrl + f11 but it doesnt seem to do anything. Is there another way to lock the field?

    Also i tried printing and the problem still exists.



    thnks for the attempt though.


    Doug Robbins - Word MVP dkr[atsymbol]mvps[dot]org
    Thursday, January 20, 2011 1:36 AM
  • well i found a way around it actually. If i go "finish and merge" -> edit individual documents, it opens a new document and when i make changes there they stay changed.

     

    I guess you guys must have changed the behaviours slightly between versions. Anyways it works now i just tried it.

    Thursday, January 20, 2011 8:41 PM