none
GP software instalation

    Question

  • Hi

    Coming to the point straight

    In my organistation there are lots of GP which has only computer configuration enabled, however in security filtering we have only Authenticated user added and not computer . how will this work, as computer configuration is computers

    i have created group policy to push the software in computer configuration, we have added the users and computer both in security filtering , but its not getting installed. we have selected Assigned optioned.

    one more query - the software in placed in a folder in the server and we shared the folder, and provided everyone with RO access, do we have to change this.

    Aamir


    NA

    Friday, October 30, 2015 6:49 PM

Answers

  • You may find the need to perform some further logging, and examine the logs.
    These articles may be helpful;

    Top 5 Reasons Group Policy Software Installation Is Not Working
    http://deployhappiness.com/top-10-ways-to-troubleshoot-software-deployment/

    Fixing Group Policy problems by using log files
    http://technet.microsoft.com/en-us/library/cc775423(v=ws.10).aspx
    Group Policy Blog: Troubleshooting: Quick Fixes
    http://blogs.technet.com/b/grouppolicy/archive/2008/11/05/troubleshooting-quick-fixes.aspx

    Ask the Directory Services Team - Blog:
    http://blogs.technet.com/b/askds/archive/2015/04/17/a-treatise-on-group-policy-troubleshooting-now-with-gpsvc-log-analysis.aspx

    Don [doesn't work for MSFT, and they're probably glad about that ;]

    • Marked as answer by Masthanomatic Wednesday, November 04, 2015 3:42 PM
    Tuesday, November 03, 2015 8:36 PM
  • Hi I normally only use the computer configuration for software installation. 

    What I've been doing and its been working really well is to create Security Group for each software i.e. if I want to install office 2010 then I'll create a sec group office-2010-install. 

    Add apply permissions to this group on the policy and add the computer account to this group when needed. 

    also make sure you are providing UNC share for the msi files i.e. \\server1\sharename

    also please check your share and NTFS permissions for the share.

    • Marked as answer by Masthanomatic Wednesday, November 04, 2015 3:42 PM
    Tuesday, November 03, 2015 8:55 PM

All replies

  • In my organisation there are lots of GP which has only computer configuration enabled, however in security filtering we have only Authenticated user added and not computer . how will this work, as computer configuration is computers

    AuthenticatedUsers effectively includes DomainUsers (user account objects) & DomainComputers (computer account objects)

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/6402b1e5-2163-453a-a78b-8ff9bd276f4c/does-the-authenticated-users-group-contain-computer-accounts?forum=winserverGP


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Saturday, October 31, 2015 9:04 AM
  • Hi,

    As mentioned by Don, AuthenticatedUsers includes computer objects, so the settings under Computer configuration will work.

    Please run “gpresult /h result.html” the on computer and check if the GPO applied correctly? Check this article for detailed information: https://technet.microsoft.com/en-us/library/cc733160.aspx?f=255&MSPPError=-2147217396

    >>we have added the users and computer both in security filtering

    Are you trying to push the software for all users on all computers or for specific users? If you want to install it on all computers, simply leave AuthenticatedUsers in the security filtering list should works.

    >>one more query - the software in placed in a folder in the server and we shared the folder, and provided everyone with RO access, do we have to change this.

    Make sure the Computer objects also have permission to access that share, if you would like to configure it under Computer configuration.


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 02, 2015 8:59 AM
    Moderator
  • Hi

    1) we ran gpresult /r and found policy is applied

    2) this is testing policy so just applied to 2 users and 2 computers

    3) i can open the software folder from the test machine

    Please give your inputs

    Aamir


    NA

    Monday, November 02, 2015 12:09 PM
  • On a pc where this policy applies, what does the event log say about the installation? It should be in the System event log

    Monday, November 02, 2015 2:21 PM
  • WARNING

    The Group Policy Client Side Extension Software Installation was unable to apply  one or more settings because the changes must be processed before system startup or user logon. The system will wait for Group Policy processing to finish completely before the next startup or logon for this user, and this may result in slow startup and boot performance.

     

    EVENT ID 1112

    ------------------------------

    INFORMATION

    The Group Policy settings for the computer were processed successfully. There were no changes detected since the last successful processing of Group Policy.

    EVENT ID 1500


    NA

    Monday, November 02, 2015 3:08 PM
  • That simply states that the GPO can only apply when the computer starts up. Reboot and see if software installs. Post the contents of the event log after computer has started up.

    • Edited by zxxzxx Monday, November 02, 2015 4:39 PM
    Monday, November 02, 2015 4:39 PM
  • Hi

    thanks for the reply

    After restarting the machine, gpupdate succesfully for both user and computer configuration and event id

    INFORMATION

    The Group Policy settings for the computer were processed successfully. There were no changes detected since the last successful processing of Group Policy.

    EVENT ID 1500

    but we are not able to find the installed software , trying to install microsoft fix it , its not available in add or remove programme or all programme

    Please suggest how to confirm if it installed


    NA


    Monday, November 02, 2015 5:13 PM
  • Can you please try Windows Search and see if you can find it?


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, November 03, 2015 9:09 AM
    Moderator
  • Hi Wendy,

    we already did that but not  able to find, if you suggest any other software to install with msi extention, we can test with that


    NA

    Tuesday, November 03, 2015 11:50 AM
  • You may find the need to perform some further logging, and examine the logs.
    These articles may be helpful;

    Top 5 Reasons Group Policy Software Installation Is Not Working
    http://deployhappiness.com/top-10-ways-to-troubleshoot-software-deployment/

    Fixing Group Policy problems by using log files
    http://technet.microsoft.com/en-us/library/cc775423(v=ws.10).aspx
    Group Policy Blog: Troubleshooting: Quick Fixes
    http://blogs.technet.com/b/grouppolicy/archive/2008/11/05/troubleshooting-quick-fixes.aspx

    Ask the Directory Services Team - Blog:
    http://blogs.technet.com/b/askds/archive/2015/04/17/a-treatise-on-group-policy-troubleshooting-now-with-gpsvc-log-analysis.aspx

    Don [doesn't work for MSFT, and they're probably glad about that ;]

    • Marked as answer by Masthanomatic Wednesday, November 04, 2015 3:42 PM
    Tuesday, November 03, 2015 8:36 PM
  • Hi I normally only use the computer configuration for software installation. 

    What I've been doing and its been working really well is to create Security Group for each software i.e. if I want to install office 2010 then I'll create a sec group office-2010-install. 

    Add apply permissions to this group on the policy and add the computer account to this group when needed. 

    also make sure you are providing UNC share for the msi files i.e. \\server1\sharename

    also please check your share and NTFS permissions for the share.

    • Marked as answer by Masthanomatic Wednesday, November 04, 2015 3:42 PM
    Tuesday, November 03, 2015 8:55 PM