locked
Windows 7 UI w/ Remote Desktop - won't allow the maximum restored screen size RRS feed

  • Question

  • I use Remote Desktop regularly. I have been using it under Windows XP.

    I often need to get to both of the task bars, the remote and the client desktop. To do this I would restore the RDP window and then slide the top of the window above the client screen and then stretch the window to full size.

    RDP seemed to understand what I was trying to do and would give me the full screen size as if the desktop was maximized and take away the scrollbars and give me a full screen of remote desktop while not maximized. This is a very important feature - I use it every day, all the time.

    With Windows 7, I have two irritating issues: 

    1. The OS tries to fullscreen my window when I attempt to slide the window top up to the top edge of the screen. I believe this can be turned off, but it is irritating as a default behavior.

    2. Most importantly, there is no way to stretch the RDP window to near-full-screen size, because where in XP I could slide a window above the screen, Windows 7 pushes it back down into the client screen area.

    This is very disappointing. Isn't there anyone else that has used this amazing feature that has missed it? I have not found much in searching. I am left with having to live without this and have scrollbars on my RDP window and lose critical space on the RDP screen.

    Thanks for any assistance anyone can provide.

    Regards,

    Robb

    Wednesday, June 6, 2012 1:59 PM

Answers

All replies

  • 2. Most importantly, there is no way to stretch the RDP window to near-full-screen size, because where in XP I could slide a window above the screen, Windows 7 pushes it back down into the client screen area.

    No Problem here.

    There are some display options you can set.
    Have you seen the Options button on the RDP connection dialog?


    lg
    Marcello

    Thursday, June 7, 2012 8:32 AM
  • Hi,


    Regarding the full screen issue when I attempt to slide the window top up to the top edge of the screen, this is a new feature of Windows 7 called Aero Snap.


    You can turned off this feature.

    Disable Aero Snap Auto Maximize and Arrange Window in Windows 7


    Regarding the size of Remote Desktop, you can change display settings of RDP to achieve.



    Please also select “Display the connection bar when I use the full screen”.


    More reference about Remote Desk"font-size:10.0pt;font-family:'Verdana','sans-serif';">
    Remote Desktop Connection: frequently asked questions

    http://windows.microsoft.com/en-US/windows7/Remote-Desktop-Connection-frequently-asked-questions

    Hope this helps



    Vincent Wang

    TechNet Community Support




    • Edited by Vincent Wang-MCSC Thursday, June 7, 2012 8:51 AM
    • Marked as answer by MrGiga Thursday, June 7, 2012 12:51 PM
    Thursday, June 7, 2012 8:49 AM
  • I didn't realize that the windows header snapping down to inside the screen would also change behavior when I turned that option off. That allowed me to resize to the full size of the screen and get my RDP functionality back. 

    Thanks for that!

    Thursday, June 7, 2012 12:53 PM