'The procedure entry point CxxFrameHandler3 could not be located in the dynamic link library msvcrt.dll' RRS feed

  • Question

  • hi

    I'd like to ask for help regrading installing windows 8.1 evaluation on the windows XP pro SP3.
    When trying to start installing from DVD drive or virtual drive the first window shows: 'The procedure entry point CxxFrameHandler3 could not be located in the dynamic link library msvcrt.dll'.
    and then the other: 'File autorun.dll couldn't be loaded or is corrupt. setup cannot continue. error code is [0x7F]'

    Please advise as I've tried to install Win8.1 on 3 computers wirh XP SP3 and the result was the same.
    On the other hand - installing on windows 7 home edition gave positive effect.

    thanks for any advice!

    VM llc it administrator

    Thursday, February 27, 2014 5:06 PM


All replies

  • Hi,

    How did you install it?

    To upgrade to Windows 8.1 from Windows XP, you'll need to install it from a Windows 8.1 DVD and perform a clean installation. This means you won't be able to keep any files, settings, or programs when you upgrade.

    Firstly, please doanload and run Windows 8 Upgrade Assistant to check if your computer could install Windows 8. You can get it from here.


    Karen Hu
    TechNet Community Support

    Friday, February 28, 2014 8:33 AM
  • Hi,

    I'm getting this same error when Setup.exe attempts to launch the Win 8.1 installation from the DVD. I can't proceed with the installation as it says that autorun.dll cannot be loaded. Do I need a new version of msvcrt.dll? I'm trying to install Win 8.1 on a lap top with Win XP SP3 installed. Why wouldn't the install disk have its own copy of msvcrt.dll to avoid conflicts with old dlls? Thanks.

    Friday, April 25, 2014 4:55 AM
  • Hi!

    I'm getting the same issue on my Dad's computer. I've run the upgrade advisor and it says I'm OK to procede.

    I've also tried reinstalling the msvcrt.dll file from the original XP disc in case the current one was corrupt but still no good.

    Please, if you've got any more ideas as to how to procede, I'd really appreciate it.


    Thursday, May 1, 2014 3:52 PM
  • The above response is not any solution. I am having the same issue after running the assistant. The DVD goes in the drive, then the error comes up. We never see the blue screen in Windows 8.1 that says to select a clean installation.

    Here is my upgrade assistant report

    Windows 8 Upgrade Assistant Report
    Computer name: S*****
    Operating system: Microsoft Windows XP Home Edition
    Manufacturer: Dell Inc.
    Model: Inspiron 531
    CPU: AMD Athlon(tm) Processor 2650e
    Memory: 4.1
    For you to review
    Install an app to play DVDs
    You may need to install an app to play DVDs in Windows 8.
    More info

    Secure Boot isn't compatible with your PC
    Your PC's firmware doesn't support Secure Boot so you won't be able to use it in Windows 8.
    More info

    Your screen resolution doesn't meet the requirement to install apps from the Windows Store
    You need a screen resolution of at least 1024 x 768 to install and use apps from the Windows Store (this includes apps that might be pre-installed on your PC). You might be able to change your resolution in the Display Control Panel.
    More info

    Microsoft Easy Assist v2
    Microsoft Corporation, Version 8.1.6416.0
    Not compatible
    Microsoft .NET Framework 1.1
    Update available

    Microsoft Corporation, Version 10.50.0679.0
    Go to the app website for help

    nVidia Display drivers/nView Desktop Manager (NVIDIA Drivers)
    Go to the app website for help

    Paint Shop Pro 6.0 (CD-ROM)
    Paid update available

    Windows Internet Explorer 8
    Microsoft Corporation, Version 20090308.140743
    Update available

    Windows Live Essentials
    Microsoft Corporation, Version 14.0.8117.0416
    Update available

    Windows Live Sign-in Assistant
    Microsoft Corporation, Version 5.000.818.5
    Update available

    Windows Messenger 5.1
    Go to the app website for help

    Adobe Download Manager
    NOS Microsystems Ltd.
    Adobe Reader XI (11.0.06)
    Adobe Systems Incorporated
    AntiLogger SDK version
    Zemana Ltd.
    Apple Inc.
    Constant Guard Protection Suite
    Dell System Detect
    File Type Assistant
    Trusted Software
    HP Document Viewer 7.0
    Malwarebytes Anti-Malware version
    Malwarebytes Corporation
    Microsoft .NET Framework 2.0 Service Pack 2
    Microsoft Corporation
    Microsoft .NET Framework 3.0 Service Pack 2
    Microsoft Corporation
    Microsoft .NET Framework 3.5 SP1
    Microsoft Corporation
    Microsoft .NET Framework 4 Client Profile
    Microsoft Corporation
    Microsoft Office PowerPoint Viewer 2007 (English)
    Microsoft Corporation
    Microsoft Office XP Professional
    Microsoft Corporation
    Microsoft Silverlight
    Microsoft Corporation
    Microsoft Works
    Microsoft Corporation
    OCR Software by I.R.I.S 7.0
    RedMon - Redirection Port Monitor
    Roxio Creator DE
    StartNow Toolbar
    Windows Live Sync
    Microsoft Corporation
    Windows Media Player 11
    HID-compliant mouse
    HP Photosmart C6100
    HP Photosmart C6100 series
    HP Photosmart C6100 series
    HP Photosmart C6100 series (DOT4)
    HP Photosmart C6100 series (DOT4PRT)
    HP Photosmart C6100 series (DOT4USB)
    Microsoft USB Natural Keyboard
    NVIDIA GeForce 6150SE nForce 430
    NVIDIA Network Bus Enumerator
    PDFLite Virtual Printer
    Photosmart C6100 (DOT4PRINT)
    Realtek High Definition Audio
    USB Mass Storage Device
    Compatible USB storage device

    • Proposed as answer by casawdey Thursday, July 3, 2014 6:05 PM
    • Unproposed as answer by casawdey Thursday, July 3, 2014 6:05 PM
    Thursday, May 22, 2014 1:21 AM
  • I ran into this same problem. the framehandler3 could not be found and the autorun.dll was corrupt or whatever it said.I tried downloading the upgrade assistant but that would work either. Here is what did work though....

    Restart the computer and boot directly from the CD/DVD. The installation ran just fine after I did this.

    Thursday, July 3, 2014 6:07 PM
  • Thanks very much, I did this and it's working for me. What a gem!
    Friday, July 11, 2014 4:55 AM
  • I'm getting the exact same issue with my machine which is why I am here.
    Wednesday, July 16, 2014 9:54 AM
  • It works!! I had the same issue initially on both inserting the DVD with XP running and restarting my PC with the disk in the drive. This was after a disastrous adventure with a bogus Windows 7 from ebay. (never again) I did a fresh install of XP and tested the DVD on restart and got the error. After the machine settled for a day and fully updated off the net it now works. On XP simply put the DVD in the drive and restart.
    Wednesday, July 16, 2014 10:13 AM
  • Me too, I get the Cxxframehandler error.

    I bought the cd at Microsoft store.

    My laptop is an Dell Inspiron 1150 with Windows XP.

    I also tried to boot from the cd, however, after changeing the bootsequence, this happens:

    Laptop says: Hit any key to boot from cd/dvd, so I do..

    Than a minute or so, files are loaded from the CD drive.

    Than a black screen for 5 seconds and than the system reboots again, aking the same.... 

    This happens over and over.

    So No Install for me yet.... 


    Sunday, August 17, 2014 9:04 PM
  • How do I boot directly from the CD/DVD?

    Wednesday, April 1, 2015 2:36 PM