locked
Exchange 2007 message size limit RRS feed

  • Question

  • We are in a child domain. We want to limit message size limit to 10M.

    So i configure the message size limit on all the send connector and receive connector.

    Because we are a child domain, so i don't want to configure the limit at organization level.

    Now the result is:

    1. Internal user unable to send message lager than 10M to internet.

    2. Internet user unable to send message lager than 10M to internal.

    But internal users can send message lager than 10M to each other via Outlook or OWA.

    It seems the limit take affect on send connector, but  it doesn't take affect on receive connector.

    Why?

    Tuesday, November 1, 2011 6:26 AM

Answers

  • No they dont use the receive connector which you see,  There are some invisible connectors created which are used.

    You can always set at the Transport level, but this will be for all users are your Org and not only the child domain, so by setting it on each mailbox on that child domain is the way to go.


    Sukh
    • Marked as answer by Jerome Xiong Wednesday, November 2, 2011 2:16 AM
    Tuesday, November 1, 2011 5:58 PM

All replies

  • So i configure message size limit via this command

    Get-mailbox -database "mailbox server name\Storage group name\ database name" | set-mailbox -MaxSendSize 10240000

    Then it worked.

    But i can't comprehend. Don't  the internal mail flow check the configuration on receive connector?

    Tuesday, November 1, 2011 1:19 PM
  • No they dont use the receive connector which you see,  There are some invisible connectors created which are used.

    You can always set at the Transport level, but this will be for all users are your Org and not only the child domain, so by setting it on each mailbox on that child domain is the way to go.


    Sukh
    • Marked as answer by Jerome Xiong Wednesday, November 2, 2011 2:16 AM
    Tuesday, November 1, 2011 5:58 PM
  • how can i find the invisible receive connector?
    Wednesday, November 2, 2011 2:17 AM
  • You cant really see them but you can enable logging on them, Use Set-Transportserver - IntraOrgConnectorProtocolLoggingLevel

    http://technet.microsoft.com/en-us/library/bb124238(EXCHG.80).aspx


    Sukh
    Wednesday, November 2, 2011 12:15 PM
  • Please issue "Get-SendConnector | fl" and "Get-ReceiveConnector | fl". Note the "max message size" property on both connectors. Please post the results back here so we can further assist you. I ran into this more than two years ago.
    Wednesday, November 2, 2011 7:44 PM