locked
Exchange 2010 Pack Issues RRS feed

  • Question

  • I am having a bit of trouble with the OpsMgr pack for Exchange 2010 (running OpsMgr r2)

     

    The first is with the active sync. 

    Some of the Client Access server connectivity transactions failed. Detailed information: ------------------------------------- Target: <SERVERNAME>|HQ1 Error: [System.Net.WebException]: The remote server returned an error: (401) Unauthorized. HTTP response headers: Cache-Control: private Content-Type: text/html; charset=utf-8 Server: Microsoft-IIS/7.5 WWW-Authenticate: Negotiate,NTLM X-Powered-By: ASP.NET Date: Thu, 17 Jun 2010 14:02:20 GMT Content-Length: 6397 ------------------------------------- Diagnostic command: "Test-ActiveSyncConnectivity -MonitoringContext:$true -MonitoringInstance:$ScriptContext.ManagementGroupName -TrustAnySSLCertificate:$true -LightMode:$true"

     

    The second is with autodiscover

    The test step GetReferral running over protocol 'ncacn_http' issued from test user '<DN>  (FYDIBOHF23SPDLT)/cn=Recipients/cn=extest_1c93cfb7a4bc480ceccce' failed with error: '1722(The RPC server is unavailable)'. 

    The server is working correctly as far as I can tell.

     

    the third issue is that 4 out my 7 exchange 2010 servers have not been discovered in ops after 5 days.....

     

    Can anyone assist with any of these please?

    Thursday, June 17, 2010 3:47 PM

Answers

  • Hi, No activity for 30 days. Will mark as answer. Feel free to re-open. Thanks


    Anders Bengtsson | Microsoft PFE | blog at http://www.contoso.se
    Sunday, December 26, 2010 7:54 PM

All replies

  • Start with agent health.  From the errors above, there seem to be a few different errors, ranging from permissions that are being used to attempt the monitoring transactions, to COM issues (which are also usually permission based).

    Since you are not seeing discovery work, start by seeing if your agents are healthy, whether the agents are configured to allow proxy discovery (so called agent proxy setting needs to be true for all of the agents deployed to exchange server roles on all server roles.

    If you have unhealthy agents, all bets are off at the individual MP level.

    Next, read the extensive documentation on configuring the MP.  Most of the synthetic transaction tests require localsystem as the run-as account for the transaction test - this is covered in the guide.

    If you have firewalls on your exchange servers, you need to check that the ports required for agent traffic are open.  For mail flow, the ports required by exchange servers are required to be open. 

    If you have MacAfee anti-virus installed, this can also cause some of the symptoms you are seeing.

     


    Microsoft Corporation
    • Proposed as answer by Nicholas Li Friday, June 25, 2010 5:55 AM
    • Marked as answer by Nicholas Li Monday, June 28, 2010 3:11 AM
    • Unmarked as answer by Zak Humphries Thursday, July 1, 2010 4:23 PM
    • Unproposed as answer by Zak Humphries Thursday, July 22, 2010 7:43 AM
    Saturday, June 19, 2010 5:07 PM
  • Hi Dan,

     

    Cheers for info. All the agents are healthy & have the agent proxy setting enabled. I have read the extensive(ish) documentation as one should alway do before deploying into a production environment.

    After a week on holiday I still have 2 CAS and one Edge Transport in the DMZ that have still not discovered the exchange components.

    I have over-ridden the synthetic transactions for the moment and will look into them further once I have the complete organization discovered.

    Any further thoughts on the discovery?

     

    Cheers

    Zak

    Thursday, July 1, 2010 4:31 PM
  • Troubleshooting discovery is always done by following the same steps:

     

    On the agent that you expect to see the discovery done, look in the Operation Manager event log and see if there are errors you can attribute to the particular discovery.

    If found, that error will tell you more information.

    Next, look on the operations manager RMS server and see if the discovery data is being rejected - you guessed it - via an error in the Operations Manager log.

    If the discovery data is failign to be submitted by the agent - no discovery.  If the discoveyr data is rejected by the RMS, no discovery.


    Microsoft Corporation
    Thursday, July 1, 2010 9:41 PM
  • Thanks for info dan,

     

    Ive gone through the logs (RMS & local) with a fine tooth comb (and log smith) and cant find any issues with these servers. Ive reset the health service by stopping the service and deleting the "Health Service State" data, this has worked on the two CAS servers and they are now showing up correctly in ops. The edge server (in the DMZ connected via gateway) is unfortunately still not working and I can find no errors, any more thoughts?

     

     

    Cheers a bunch

    Zak

    Monday, July 5, 2010 12:34 PM
  • I'm having the exact same issue with a 2010 UM server and 5 of my 8 2010 MB servers.  I've tried everything mentioned here and just as the last poster mentioned I cannot find a cause for this.  In my case I also tried stopping the Health Service and deleting Service State data, but this has not caused OpsMgr to discover the missing server.  The servers missing from Exchange 2010 Server State are found and Healthy, they just don't show up as Exchange 2010 servers...

    What other troubleshooting steps can be taken to get this discovery to complete successfully?

    Tuesday, July 6, 2010 10:59 PM
  • Can you verify that the Exchange 2010 workflows are being executed on
    the agents on the server,
     
    From Monitoring Tab of Operations Console -> Discovered Inventory
     
    Right click middle pane and select "Change Target Type." Select Agent
     
    Click the servers that are not being discovered, in actions pane under
    Health Service Tasks, select "Show Failed Rules and Monitors for this
    Health Service" and "Show Running Health Rules for this Health Service."
    After this runs, click copy text and paste into notepad, this will give
    a more verbose reading than the HTML report that is generated and you
    can look for the specific Exchange 2010 workflows.
     

    -- Mike Burr
    Tuesday, July 6, 2010 11:21 PM
  • When I run the "Show Running Health Rules for this Health Service" job, I find the following text in the output:

    ExchangeRequiredHotfixesNotInstalledThe required SCOM hotfixes for Exchange MP are not installed.

    I do not find similar text in the output of that job when it's run against other 2010 mailbox servers which have been correctly discovered.

    To mitigate, I've tried the following steps, none of which have worked on this particular mailbox server:

    • Stop Agent Health Service, remove contents of HealthServiceState folder, restart Agent.
    • Stop Agent Health Service, remove contents of HealthServiceState folder, replace contents of c:\Program Files\System Center Operations Manager 2007\ folder with contents of same folder from a working mailbox server Agent, restart Agent.
    • Delete Agent from RMS, uninstall Agent from 2010 mailbox server, reinstall Agent (manually), stop Agent, apply KB974144-x64-Agent.msi and KB979257-x64-Agent.msi, restart Agent, approve manually added Agent in RMS.
    In each of the above cases the Agent is still not detected as an Exchange 2010 mailbox server, and the same "ExchangeRequiredHotfixesNotInstalled" error is reported in the "Show Running Health Rules for this Health Service" job.  My OpsMgr 2007 R2 server is at CU2, and all Agents installed on my Exchange 2010 servers report as having Agent version 6.1.7221.0.

    What else can I try?  Thanks in advance...

    Wednesday, July 7, 2010 10:18 PM
  • There are no failed workflows.

     

    The only exchange related workflows active on the server are related to forefront, there is none for the core exchange 2010 product.

     

    Cheers

    Zak

    Thursday, July 8, 2010 8:15 AM
  • Yeah I forgot to mention that there are no failed workflows on my undiscovered 2010 mailbox server either...
    Thursday, July 8, 2010 2:52 PM
  • Does anyone have some additional thoughts on this?  I have only one remaining mailbox server out of eight that can't be detected by OpsMgr for some reason, and of course this means I'm getting false positives like crazy for a portion of our databases...  Thanks in advance.
    Monday, July 12, 2010 10:13 PM
  • Hi, No activity for 30 days. Will mark as answer. Feel free to re-open. Thanks


    Anders Bengtsson | Microsoft PFE | blog at http://www.contoso.se
    Sunday, December 26, 2010 7:54 PM
  • Anders - this hasnt been answered so shouldnt have been marked as such.

    I too have the problem of no discovery of our Exchange 2010 servers, has anyone been able to fix this?


    Stew
    Monday, January 10, 2011 6:23 AM