locked
Problem displaying excel Service Pivotchart and pivot table RRS feed

  • Question

  • Hi Folks,

    I am struggling with Excel Service since 25days. Need couple of advices.

    Below are few details:

    -- Using MOSS, SQl Server 2008

    -- MOSS and Database are on same server.

    -- My Application pool is running under System Account credentials.

    Earlier, When i publish excel workbook - i was able to see PivotTable & PivotChart on Browser (IE 7) which shows excel service was running. But, I was not able to get update in PivotChart whenever Sharepoint List get change. Few days I google and ran below command on my MOSS server to get updates in PivotChart.

    > stsadm -o set-ecssecurity -Ssp <SSP name> -AccessModel Delegation....

    Thereafter, whenever i publish workbook i get below error on Browser.

     "An error has occurred.  Please contact your system administrator if this problem persists. "

    So, i ran all below stsadm command in my Server.

    > stsadm -o updatefarmcredentials -userlogin username -password password

    > stsadm -o updatefarmcredentials -userlogin username -password password-local

    > stsadm -o updateaccountpassword -userlogin username -password password-noadmin

    > stsadm.exe -o spsearch -farmserviceaccount username -farmservicepassword password

    > stsadm.exe -o spsearch -farmcontentaccessaccount username -farmcontentaccesspassword password

    > stsadm.exe -o editssp -title DevSharedServices -ssplogin username -ssppassword password

    > stsadm.exe -o osearch -farmserviceaccount username -farmservicepassword password

    > stsadm.exe -o spsearch -farmserviceaccount username -farmservicepassword password

    > stsadm.exe -o spsearch -action start -farmserviceaccount username -farmservicepassword password

      Still I am getting below error:

    An error has occurred.  Please contact your system administrator if this problem persists. 

    Checking Server event log I got below error:

    Login failed for user 'NT AUTHORITY\NETWORK SERVICE'. Reason: Failed to open the explicitly specified database. [CLIENT: <local machine>]

    I don't understand that my app pool is running under System Account, so why Network Service authenticates to Database. Right?

    Please Please advice.

    Thanks,

    Chintan

     


    Friday, April 15, 2011 1:04 PM

All replies

  • Hi Chintan123,

     

    It seems that this is an Database Login problem. Could you please check your Database event log? I believe you have encountered an error, and its event ID is 18456, you can go through this thread to see if your issue is similar with the one in it. If it is, you can refer to this blog and try the solutions there: http://www.eraofdata.com/blog/sql-18456-login-failures/.

     

    Thanks & Regards,

    Peng Lei

    Monday, April 18, 2011 2:16 AM
  • Hi Peng,

    Thx for your reply. Your given link was helpful. I ran command "select * from sys.traces where is_default = 1" and with this I opened tracing file "log_16.trc" from path "C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER\MSSQL\Log\log_16.trc". But I see junk values in log file. I couldn't even find Severity and State number of this error.

    1 question:

    1. My app pool is running under my (System) account whic has proper privilege to connect Sql Server DB. I checked under DB Properties -> Permission page. However, Server event log is generating login failure for "NT AUTHORITY\NETWORK SERVICE".    Why so? It should point to my account. I am getting 3 consecutive error of NT AUTHORITY\NETWORK SERVICE login failure in server event log every minute without doing any action.

    Please advice.

    Plz Note: I am using Sql Server 2008.

    - Chintan





    Monday, April 18, 2011 8:35 AM