locked
Edit Content of a Session Cookie RRS feed

  • Question

  • I am publishing an web app through UAG 2010 and when I get to the login page of the webapp a JSESSIONID is set, however it also appends the PATH /uniquesig.... to the jsessionid.  This stops me being able to login to the app.  If I use the webdev plugin for firefox and EDIT the JSESSION cookie to alter the PATH from "/uniquesig...etcetc" to just "/" and then attempt to login it works perfectly.  I have tried looking to see how to alter the path to just "/" and leave the JSESSIONID value intact but I am confusing myself.  Any pointers or even better an example how to modify this session cookie as it is set?

    Many Thanks

    Thursday, June 9, 2011 3:45 PM

Answers

  • Hi Amig@. I think you could use two different approaches:

    1) The first one is to manipulate the cookie http://technet.microsoft.com/en-us/library/dd278130.aspx

    2) The second one is to publish the application with a "application specific hostname" template. This way ther is no signature and the path will be "/"

     

    Regards


    // Raúl - I love this game
    • Marked as answer by rstables Wednesday, June 15, 2011 2:47 PM
    Saturday, June 11, 2011 9:44 AM

All replies

  • Hi Amig@. I think you could use two different approaches:

    1) The first one is to manipulate the cookie http://technet.microsoft.com/en-us/library/dd278130.aspx

    2) The second one is to publish the application with a "application specific hostname" template. This way ther is no signature and the path will be "/"

     

    Regards


    // Raúl - I love this game
    • Marked as answer by rstables Wednesday, June 15, 2011 2:47 PM
    Saturday, June 11, 2011 9:44 AM
  • Hi,

     

     Many thanks for your reply, I went for option 2 which has had success so many thanks for that, but as always a new issue has arisen ;-)

     

     The trunk is set to load the application I am publishing initially rather than the portal. 

     

    When I go to the site I get an IE Message back, "the page cannot be displayed".  If I refresh this I get the same message, if I refresh it again the application page loads without issue and I can login to the app and it works as normal.  This happens every time I visit the site, loads on the third attempt everytime, not two, not four, three everytime. 

     

    EDIT - Sorted this by combing through the scripts being loaded by the application and found another couple of paths being accessed that I hadn't allowed for, added those and it works perfectly.  Many Thanks.

     

    Best Regards

     

    Robert


    Wednesday, June 15, 2011 1:17 PM
  • Glad to help

    Regards


    // Raúl - I love this game
    Thursday, June 16, 2011 8:13 AM