none
Search Administration: Could not establish trust relationship for the SSL / TLS secure channel

    Question

  • Hello -

    I'm seeing this error when I go to search administration page.    Has anyone encountered this before?    No changes made to certs on our servers.

    Friday, April 21, 2017 12:24 PM

Answers

  • Ended up opening a case with Microsoft on this one.   We ran the command below to provision the web service on servers  to fix the issue.

    $Service=Get-SPServiceHostConfig

     

    $Service      


    This restores the common web service settings:

     

    HttpPort                : 32843

    HttpsPort               : 32844

    NetTcpPort              : 32845

    SslCertificateStoreName : SharePoint

    SslCertificateFindType  : FindBySubjectDistinguishedName

    SslCertificateFindValue : CN=SharePoint Services, OU=SharePoint, O=Microsoft, C=US


    • Edited by XRS Thursday, August 3, 2017 11:14 AM
    • Marked as answer by XRS Friday, August 4, 2017 12:43 PM
    Thursday, August 3, 2017 11:13 AM

All replies

  • I should note that on the search server, in IIS, I see that the 'SharePoint Web Services' site has an SSL certificate in it's site binding.   Not sure how that got there, but I'm going to see if I can remove that.   it's on https type on port 32844
    Friday, April 21, 2017 12:51 PM
  • Hi,

    Can you try adding the root certificate to manage trust.

    Go to Central Administration > Security > Manage Trust > add your certificate


    Mark it as an answer if it helped you out. Regards Rahul Dagar

    Friday, April 21, 2017 12:56 PM
  • Hi -    I did try that before and that didn't help.     I guess I need to find a way to remove the cert from 32844.  it's not allowing me to do that from IIS and I don't want to modify the applicationhost.config file just yet. 
    Friday, April 21, 2017 1:09 PM
  • Ended up opening a case with Microsoft on this one.   We ran the command below to provision the web service on servers  to fix the issue.

    $Service=Get-SPServiceHostConfig

     

    $Service      


    This restores the common web service settings:

     

    HttpPort                : 32843

    HttpsPort               : 32844

    NetTcpPort              : 32845

    SslCertificateStoreName : SharePoint

    SslCertificateFindType  : FindBySubjectDistinguishedName

    SslCertificateFindValue : CN=SharePoint Services, OU=SharePoint, O=Microsoft, C=US


    • Edited by XRS Thursday, August 3, 2017 11:14 AM
    • Marked as answer by XRS Friday, August 4, 2017 12:43 PM
    Thursday, August 3, 2017 11:13 AM