Closing tabs causes I.E. to hang RRS feed

  • Question

  • Hi

    I have been experiencing a strange issue on my 64bit Win7 Pro machine running I.E. 11. Note that the option to 'Install new versions automatically' is checked and that we use WSUS on a Win 2012 R2 member server to deliver updates.

    What happens is that I will be using I.E. to research a topic. I'll have my default home pages open (BBC and our intranet), plus a Google Search page, and search results pages will be open as well (I have it configured so that results open in a new tab). I may have 4 tabs open or sometimes more, but rarely more 6 or 7 tabs at any one time.

    I have found that if I close the tabs individually (from right to left), I can close one or two but then I.E. may become unresponsive. The contents of the last tab I closed (which disappears as it should) become visible on the next tab - meaning that if the next tab's contents were a search results page, they are not visible and are replaced by what was just visible.

    I have to use Task Manager's Process tab to 'End task' all remaining instances of I.E.

    I have uninstalled Google Toolbar and downloaded and installed the latest version in case the behaviour was caused by an old version but the issue persists.

    The problem is intermittent but happens at least once a day.

    Anyone else seen this behaviour or know what may be causing it and how I might fix it, please?


    Monday, November 14, 2016 2:43 PM


  • I noticed that this issue began after I installed November security patch (probably monthly quality rollup update).

    Issue was gone after I disabled Google Toolbar.

    • Edited by JYP1215 Tuesday, November 15, 2016 4:36 PM
    • Marked as answer by Mark-Blood Monday, November 21, 2016 9:39 AM
    Tuesday, November 15, 2016 4:24 PM

All replies

  • Hi RealBlood,

    my reply is quite long-winded... it is on purpose for the benefit of others that may read this answer...

    bbc uses Flash quite allot.....


    Start>Control Panel>Flash Player (32 bit)>Storage tab,

    fist you may like to click "Local Storage settings by site"... to view the list of domains that are storing 'Flash cookies' on your computer... many may not be familiar to you...

    return to the Storage tab, and change your options for 'flash cookies'...'Block all sites from storing information on this computer' are my settings in this time of change.

    I have tried 'Ask me before allowing new sites to save information on this computer' but there is only a small set of sites (of a certain genre) that are not playing to the unwritten rules of flash conduct and have not been able to test the impact of that setting on web browsers... for example in your case where IE crashes when you close a tab, having a prompt appear (say 'Do you want to allow site 'x' save data on your computer') is the actual cause of the crash or whether the crash is caused by other malicious content or malicious content on a site that 'flash' is trying to redirect you to....

    you may like to review your other settings for 'flash cookies' while you are in the control panel

    Camera & Mic, Playback and the Advanced tab.... all have settings that can impact your privacy.

    Note: if you have other types of web browsers installed on your computer, click the link

    'Learn more about configuring Flash Player with Chromium based browsers'

    If you disable your 'flash cookies', some of the websites you visit may not work as expected.. eg.. online games that use flash cookies to record your progressive scores. bbc radio may no longer work at all..

    There are third-party browser addons that can completely block flash from running in your web browser, but these may impact some high volume websites that you are using, that do not use the latest technologies for media broadcasting on the web.

    IE has 'ActiveX Filtering' (Flash is an ActiveX control in IE, on other web browsers it is called a 'plugin') which is site configurable to prevent Flash content running on websites. To turn it on select the

    Tools>ActiveX Filtering menu in IE.....

    !important - when flash or any other ActiveX content (Silverlight, online games, translators) is encountered on a web page and is prevented from loading.... you will see a blue circle icon with a cross through it... in the IE Address bar, double click the button to turn ActiveX Filtering off for THE CURRENT WEB SITE.

    On company intranets , the IE ActiveX Filter has no affect (custom ActiveX controls are not blocked) as it is not turn on for domains in the Intranet zone.

    If you are using Windows Pro or Enterprise editions you can use the Event Viewer to view detailed information about any 'crashes' that occur in any software on your computer...

    Start>Control Panel>Administrative Tools>Event Viewer>Applications>Internet Explorer

    Please include any 'Error' reports from Event Viewer with your questions....

    Generally, IE will ONLY crash because a third-party addon (Toolbar or Browser Helper) does something that impacts your privacy or computer security.... we all know that googol is 10 to the power 100, so the FIRST STEP in troubleshooting web browser issues is to test in NoAddons mode..or with InPrivate Mode.

    No Addons test - from a run prompt enter 'iexplore.exe -extoff' and press enter..... navigate to the website that is causing any problems.

    InPrivate test - from IE select the Tools>InPrivate browsing menu (ctrl+shift+p)... this opens a new window (completely separated from your current browser window)... navigate to the web site that was giving you problems.

    Please let us know if the above stops you browser from crashing...


    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    • Proposed as answer by Tony_Tao Tuesday, November 15, 2016 1:53 AM
    • Unproposed as answer by Mark-Blood Monday, November 21, 2016 9:45 AM
    Monday, November 14, 2016 7:29 PM
  • I noticed that this issue began after I installed November security patch (probably monthly quality rollup update).

    Issue was gone after I disabled Google Toolbar.

    • Edited by JYP1215 Tuesday, November 15, 2016 4:36 PM
    • Marked as answer by Mark-Blood Monday, November 21, 2016 9:39 AM
    Tuesday, November 15, 2016 4:24 PM
  • Hi, Rob

    Thanks very much for the comprehensive response. I have disabled Flash storage and have turned on ActiveX filtering. I will test over the next couple of days and see what happens.


    Wednesday, November 16, 2016 12:14 PM
  • Hi, JYP1215

    Thanks for you responding. I am reluctant to disable the toolbar as I use it a lot. If the above does not help, then I shall uninstall it and use Google's main page instead and see what happens.


    Wednesday, November 16, 2016 12:16 PM
  • We are looking forward to your good news:)

    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 18, 2016 7:34 AM
  • If you do not want to completely disable toolbar, you can disable feature that is causing the crash.

    From general settings, disable these two search features.

    Suggest searches as you type

    Store search history on my computer

    Friday, November 18, 2016 5:38 PM
  • Hi, Rob

    Thanks again for the comprehensive response. I tried these settings and used I.E. for several days but the crashes continued. The solution was to uninstall Google Toolbar.

    Monday, November 21, 2016 9:47 AM
  • Thanks again for taking the time to respond. As mentioned above, I tried using I.E. with different settings, but the crashes continued. I have since uninstalled Google Toolbar and I.E. has been running without issue.

    I will give it a month or so before trying it again - however, I only ever used the search function so will probably just add google to a favourite!


    Monday, November 21, 2016 9:50 AM