locked
Edit Drop Down list missing with Name column when view is grouped. RRS feed

  • Question

  • The All Documents View gives the Edit drop down list for the Name column, but if you create a new view and "group" items, the Edit drop down list for the Name column is missing.  This is happening with user profiles that have group policies in place that restrict a user.  Not sure what is causing this behavior.  Or what restriction we've put in place to make this happen.  Any one else seen this issue before? 

    Thank you, Pam

    • Moved by Mike Walsh FIN Wednesday, August 3, 2011 6:43 AM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Tuesday, August 2, 2011 8:20 PM

Answers

  • Discovered the culprit.  Thought I'd post in case someone else comes across this when trying to "Lock Down" a users profile in a network environment.

    Basically it's a Internet Explorer setting in Internet Options.  Go to the Security tab and select Internet, then go into Custom Level.  Go to the Scripting section and change "Active scripting" to Enable.

    If you pick Prompt, the user will get a window the each time they access a view in a grouping view, "Scripts are usually safe. Do you want to allow scripts to run?  The user would have to answer with Yes every time.

    • Marked as answer by Emir Liu Friday, August 5, 2011 6:28 AM
    Wednesday, August 3, 2011 9:14 PM

All replies

  • Hello Pam,

    Well there are basically three "Name" columns available.

    1. Name (Linked to document with Edit menu)

    2. Name (For use in Forms)

    3. Name (Linked to document)

     

    Could you please verify that the Name columns that you are displaying in the view  is Option 1 i.e. Name (Linked to document with Edit menu)

     


    Regards, Rohan

    Tuesday, August 2, 2011 8:44 PM
  • Thank you, yes it is Option 1.  I should have stated that initially, the "Name (Linked to document with Edit menu)" is checked.

    Pam

    Tuesday, August 2, 2011 8:58 PM
  • Discovered the culprit.  Thought I'd post in case someone else comes across this when trying to "Lock Down" a users profile in a network environment.

    Basically it's a Internet Explorer setting in Internet Options.  Go to the Security tab and select Internet, then go into Custom Level.  Go to the Scripting section and change "Active scripting" to Enable.

    If you pick Prompt, the user will get a window the each time they access a view in a grouping view, "Scripts are usually safe. Do you want to allow scripts to run?  The user would have to answer with Yes every time.

    • Marked as answer by Emir Liu Friday, August 5, 2011 6:28 AM
    Wednesday, August 3, 2011 9:14 PM