locked
Skype for Business loses Outlook Integration when I receive a voicemail RRS feed

  • Question

  • Hi Everyone,

    I'm having a strange issue that I can't track down.  We have an internally hosted Exchange Server 2013 and Skype for Business Server 2015.  The workstations have Office Standard 2016 and Skype for Business 2016.

    This issue is only happening to some users, not all.  For the affected users, when they receive a voicemail in Skype for Business, Skype will display an error in the bottom right corner.  It's a triangle with an explanation point.  It's says "Outlook Integration Error" and states that it lost connection with Exchange and is working to reconnect.  I check the configuration information in Skype, and it says "MAPI status OK", and "EWS unavailable, retrying".  I don't think EWS is the issue, because I type in the Internal and External URL's in the browser, and I get the login prompt, meaning EWS is up and running.

    I can temporarily fix the issue by deleting the SIP cache in the user profile temp folder.  But the next time they receive a voicemail, it comes back.  I've installed every update available for both Office and Skype, but that didn't fix the issue.

    I also tried to disable Outlook Integration in Skype.  Under Tools > Options > Personal, I disabled every setting under Exchange and Outlook Integration.  Yet the issue still occurs.

    I'm not an Exchange or Skype/Lync guru.  This is a system I inherited from the previous Network Administrator.  I've found many articles and sites showing fixes for similar issues, but none of these have worked for me.

    I'm at my wits end.  I'm about to move everyone back to Skype for Business 2013 if I cannot get this resolved.  It seems like the issue happened after everyone moved to the 2016 version of Skype and Office.

    Any guidance on this issue is very appreciated.

    Thanks,

    Adam

    Tuesday, March 28, 2017 8:10 PM

Answers

  • Hi Jim,

    It's been a while, but I made some headway.  I've been learning a lot about Skype for Business and Exchange integrations and the commands associated with them.

    Well, anyways, I put my knew knowledge to use and found the cause of the issue.  EWS was enabled on the Exchange server, but not on the individual user accounts.  I didn't know this setting existed until I took the time to learn all the commands.

    What fixed it was, in Exchange management powershell:

    Get-CASMailbox user@company.com | Format-List Ews*
    Saw that EWS was not enabled for the user.  Then ran the below command:
    Set-CASMailbox user@company.com -EwsEnabled $true

    I did this for each individual user.  This didn't fix it immediately.  I had to clear out the Skype cache and disable/enable Unified messaging on each user.  This helped cycle in the new settings.  Once I did those steps for each user, no one is receiving the exclamation point in call history/voicemail in Skype for Business.  Users are not forced to use Outlook to access voicemail.

    I appreciate your assistance Jim, and I hope this article will help others out there who inherit broken IT systems like me, haha.

    Cheers,

    Adam


    Alert from TechNet.

    • Marked as answer by Adam Tuttle Wednesday, June 14, 2017 4:03 PM
    Wednesday, June 14, 2017 4:03 PM

All replies

  • Hi Adam,

    To this issue, please refer to the following steps to check if the issue persist:

    1. Exit SFB Client
    2. Backup your old “Conversation History” folder contains in Outlook (export it to a file)
    3. Delete the “Conversation History” folder and close “outlook”
    4. Make sure that SFB and outlook are completely closed and no processes are running in the Task Manager
    5. Start “run” and type in outlook /resetfoldersStart Lync, and test (wait 10 minutes for the folder to start saving)

    In addition, you could refer to the following steps to troubleshoot this issue:
    http://lyncdude.com/2014/05/27/complete-guide-for-troubleshooting-lync-outlook-clients-integration/

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    Best Regards,
    Jim Xu
    TechNet Community Support


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by jim-xu Friday, March 31, 2017 9:58 AM
    Thursday, March 30, 2017 9:33 AM
  • Hi Jim,

    I appreciate the reply.  I went through the steps you listed, but it still loses integration after I receive a voicemail.  I tried it again, while also deleted the SIP profile cache, and that didn't work either.

    I will look at the document from lyncdude.com and will try the troubleshooting steps listed.  I'm in the middle of a network rewiring project, so I'll test today and reply with my results early next week.

    Thanks,

    Adam


    Alert from TechNet.

    Friday, March 31, 2017 12:06 PM
  • Hi Adam,

    Are there any updates for this issue?
    Did the issue solve?

    For affected user and working user, run the following command to compare it’s AD attributes:
    Get-CsUser <SIP address>


    Best Regards,
    Jim Xu
    TechNet Community Support


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, April 4, 2017 8:09 AM
  • Hi Jim,

    I ran through those steps in the troubleshooting document, and it didn't work.  All my registry settings were correct for the Skype addin for Outlook.  All my Internal and External URL's were correct, which means the DNS and SRV records for Autodiscover are setup correctly in our domain and Exchange.  The user address and the SIP address are also the same as well.  I tried the steps you suggested, but Skype lost integration again when I received a voicemail.

    As a test, I reinstalled Lync 2013, and it had the same issue.  I stated in the first post that Lync 2013 was working, but now it's not.  I'll test it with Skype for Business 2016 and Office 2013 and see how that behaves.

    Below is the output from the Get-CsUser command, with my domain name and phone number marked out.

    I noticed it states Exchange Archiving Policy is set to uninitialized.  I'll research that in a little bit.

    Identity                    : CN=Adam Tuttle,OU=Network 
                                  Administrator,OU=Information 
                                  Systems,DC=XXXXXX,DC=com
    VoicePolicy                 : 
    VoiceRoutingPolicy          : 
    ConferencingPolicy          : Standard+Enterprise+Plus
    PresencePolicy              : 
    DialPlan                    : 
    LocationPolicy              : 
    ClientPolicy                : 
    ClientVersionPolicy         : 
    ArchivingPolicy             : 
    ExchangeArchivingPolicy     : Uninitialized
    PinPolicy                   : 
    ExternalAccessPolicy        : 
    MobilityPolicy              : 
    PersistentChatPolicy        : 
    UserServicesPolicy          : 
    CallViaWorkPolicy           : 
    ThirdPartyVideoSystemPolicy : 
    HostedVoiceMail             : 
    HostedVoicemailPolicy       : 
    HostingProvider             : SRV:
    RegistrarPool               : PYSVSFB01.XXXXXX.com
    Enabled                     : True
    SipAddress                  : sip:atuttle@XXXXXX.com
    LineURI                     : tel:+XXXXXXXXXXX;ext=XXXX
    EnterpriseVoiceEnabled      : True
    ExUmEnabled                 : True
    HomeServer                  : CN=Lc 
                                  Services,CN=Microsoft,CN=1:1,CN=Pools,CN=RTC Serv
                                  ice,CN=Services,CN=Configuration,DC=XXXXXX,DC
                                  =com
    DisplayName                 : Adam Tuttle
    SamAccountName              : atuttle


    Alert from TechNet.

    Tuesday, April 4, 2017 12:12 PM
  • Hi Adam,

    Uninitialized Indicates that archiving will be based on the In-Place Hold settings configured for the user's Exchange mailbox; if In-Place Hold has not been enabled on the user's mailbox then the user will have his or her messaging and Web conferencing transcripts archived in Skype for Business Server.

    Please run Get-CsUser for working user to check if it is uninitialized.


    Best Regards,
    Jim Xu
    TechNet Community Support


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.
    • Edited by jim-xu Friday, April 7, 2017 2:34 AM
    Friday, April 7, 2017 2:33 AM
  • Hi Jim,

    It's been a while, but I made some headway.  I've been learning a lot about Skype for Business and Exchange integrations and the commands associated with them.

    Well, anyways, I put my knew knowledge to use and found the cause of the issue.  EWS was enabled on the Exchange server, but not on the individual user accounts.  I didn't know this setting existed until I took the time to learn all the commands.

    What fixed it was, in Exchange management powershell:

    Get-CASMailbox user@company.com | Format-List Ews*
    Saw that EWS was not enabled for the user.  Then ran the below command:
    Set-CASMailbox user@company.com -EwsEnabled $true

    I did this for each individual user.  This didn't fix it immediately.  I had to clear out the Skype cache and disable/enable Unified messaging on each user.  This helped cycle in the new settings.  Once I did those steps for each user, no one is receiving the exclamation point in call history/voicemail in Skype for Business.  Users are not forced to use Outlook to access voicemail.

    I appreciate your assistance Jim, and I hope this article will help others out there who inherit broken IT systems like me, haha.

    Cheers,

    Adam


    Alert from TechNet.

    • Marked as answer by Adam Tuttle Wednesday, June 14, 2017 4:03 PM
    Wednesday, June 14, 2017 4:03 PM