locked
Exchnage 2010/Outlook 2010 JunkMail issue RRS feed

  • Question

  • Hi we have the following issue

    For whatever reason at some point in history an invalid email address “name@domainname.co..uk”  was added to the safe senders list for my Mailbox, over time we’re obviously upgraded our Exchange versions and now we have the situation where every Exchange 2010 method of altering the Junk Email Configuration fails:

    • Outlook 2010 settings aren’t written to the Mailbox (this failure is silent)
    • Outlook WebApp shows an error message

    You get "Junk e-mail validation error. Value:name@domainname.co.uk"

    • EMC (which in turn uses Exchange PowerShell) produces a similar error message to the WebApp

     To demonstrate this to yourself  run this PowerShell Command (with an account which has sufficient Exchange privileges):

    Get-Mailbox first.lastname | Set-MailboxJunkEmailConfiguration -Enabled $false

    You will receive the following:

    Junk e-mail validation error. Value: name@domainname.co..uk.

        + CategoryInfo          : NotSpecified: (0:Int32) [Set-MailboxJunkEmailConfiguration], JunkEmailValidationExceptio

       n

        + FullyQualifiedErrorId : 897F9609,Microsoft.Exchange.Management.StoreTasks.SetMailboxJunkEmailConfiguration

    there are no entries I need to keep so you just need to get the Junk settings reset to defaults somehow. 

    All help appreciated

    Monday, July 11, 2011 2:11 PM

Answers

  • It seems due to the invalid characters in the blocked sender.

    Could you please try to reset the junk E-mail filter with MFCMAPI?

    To force a reset of the Junk E-mail Filter, you can use MFCMAPI to remove the "Junk E-mail Rule" message from the "Associated Contents Table" of the Inbox folder. You might need to disable Cached Exchange Mode for it to be fully effective.

    Download MFCMAPI

    More information:

    Exchange Junk Mail Configuration Not Functioning

    • Marked as answer by Jerome Xiong Monday, August 1, 2011 1:29 AM
    Wednesday, July 13, 2011 7:45 AM

All replies