locked
Yamaha YMF753 Sound Card - Vista Driver RRS feed

  • Question

  • I just upgraded my computer to Vista Ultimate.  After running the diagnostics I was told I would not have any problems with my Sound Card.  Once the install was complete, I do not have a driver that will work.  I have a Yamaha YMF753 sound card.  I have been searching the net for a Vista driver for a few hours... any help would be appreciated.

    Thanks

    MikeC

    • Moved by The March Hare Friday, May 21, 2010 4:37 AM not about Media Foundation SDK (From:Media Foundation Development)
    Friday, December 1, 2006 11:59 PM

Answers

  • Have you picked up all Windows Updates that are available?

    If you try that and your sound card still isn't working, go into the Device Manager (devmgmt.msc from a command prompt), find your device, right-click for Properties, Details, and cut&paste the "Hardware Ids", and I'll see if someone here can try it out.

    Monday, December 4, 2006 2:46 PM

All replies

  • Have you picked up all Windows Updates that are available?

    If you try that and your sound card still isn't working, go into the Device Manager (devmgmt.msc from a command prompt), find your device, right-click for Properties, Details, and cut&paste the "Hardware Ids", and I'll see if someone here can try it out.

    Monday, December 4, 2006 2:46 PM
  • Originally I did a clean install of Windows Vista.  Unfortunately I could not get several of the drivers to install this way.  I reinstalled my computers original recovery discs and then did an upgrade to Vista.  Vista picked up all of the necessary drivers and it is now working properly.

    Thanks for all the help!

    Tuesday, December 5, 2006 1:49 PM
  • I have the same issue.  No sound and here are the hardware id's

    PCI\VEN_1039&DEV_7012&SUBSYS_8127104D&REV_A0
    PCI\VEN_1039&DEV_7012&SUBSYS_8127104D
    PCI\VEN_1039&DEV_7012&CC_040100
    PCI\VEN_1039&DEV_7012&CC_0401

    I really appreciate, if anyone could find an appropriate driver for this sound card in Vista

    Tuesday, March 6, 2007 5:31 AM
  •  

    I have a Toshiba Satellite 5105 -S501 laptop with the YMF753 chip (below are my sound card spec's) running windows vista Ultimate, i did a clean install of windows, windows loaded the Intel(r) 82801CA/CAM AC'97 Audio Controller. and my Sound works fine. you should try the driver and see if it works for you.

    Sound

    Yamaha YMF753 Codec Chip

    16-bit stereo, Windows Sound System Ver. 2.0; SoundBlaster

    Pro compatible (in DOS box only)

    Built-in harman/kardon Stereo Speakers with subwoofer

    3D sound support with HRTF 3D positional audio; Direct 3D

    Sound (supported by sound driver); Hardware acceleration for

    DirectSound and DirectMusic; Full Duplex and MIDI (play back)

    support, 64 voices

    Sound Volume (by Dial)

    Ports: External Microphone port, headphone port (integrated to

    S/P DIF), Line-in port, Line-out (unified with TV-Out), Dolby AC3

    Digital support (S/P DIF Optical)

    Wednesday, December 12, 2007 5:12 PM
  • Stop wasting your time.  There is not an update to the 753 that works.  I've been researching this for some time now and have talked to Yamaha, Toshiba and Microsoft about it.  As always, anytime multiple manufacturers are involved they blame each other rather than come up with an answer.  The latest official Yamaha AC-XG YMF753 driver out there is 6.13.10.3157.  You can literally find this any place on the net if you do a search.....
    Saturday, May 17, 2008 8:53 PM
  • Hi  Magic Wheel 15,

    Could you please give the link where I can find the driver for Vista?

    Regards,
    Swadhin
    Tuesday, July 8, 2008 9:39 AM
  • I HAVE A YAMAHAWAVE FORCE SOUND CARD MODELWF 192XG THAT I CAN NOT FIND VISTA DRIVERS FOR DO YOU HAVE A FREE DOWNLOAD DRIVER SITE THAT I CAN GO TO PLEASE SEND ME AN EMAIL AT JENFARIAS@HOTMAIL.COM IF YOU DO THANKYOU VERY MUCH JOE FARIAS

    Monday, October 13, 2008 7:46 AM