locked
Activate Windows watermark bottom right of screen RRS feed

  • Question

  • I went to the bathroom at least an hour ago and came back to see the Activate Windows thing in watermark on the bottom right corner of screen, it said "Go to Settings to activate Windows" under it. The problem is my PC is running Windows 10, everything has been updated correctly and Windows 10 was installed last year. I had clicked on the Update to Windows 10 notification back when my computer ran Windows 7, I updated to Windows 10 and had no issues with it. 

    I done as the watermark said by going to Settings and it said We can't activate Windows on this device because you don't have a valid digital license or product key. If you think you have a valid license or key, select Troubleshoot below. Error code: 0xC004F012

    I clicked on Troubleshoot and after waiting for 30 minutes it, the Troubleshoot thing said "We found a Windows 10 Pro digital locense for this device running Windows 10 Pro. To activate using this digital license you need to install Windows 10 Pro. I don't know what this means, I have already got Windows 10 Pro activated and it makes no sense that the text is appearing on screen to begin with. 

    Friday, March 2, 2018 5:07 PM

Answers

  • I figured Windows got deactivated and the error code 0xC004F012 appearing was because I forcefully rebooted my computer. I restarted the computer and it's back to normal. I guess Windows didn't have enough time to load properly and that made the system go iffy. 

    • Proposed as answer by -Mr Happy- Saturday, March 3, 2018 1:00 PM
    • Marked as answer by Carey FrischMVP Thursday, December 27, 2018 7:44 AM
    Saturday, March 3, 2018 11:01 AM

All replies

  • Open C:\Windows\System32\SPP\Store\2.0.

    Rename ‘tokens.dat’ file in the 2.0 folder to ‘tokens.old’.

    Open Command Prompt as Admin and type the following command:

    net start sppsvc and hit the Enter key.

    Next execute the following command:

    cscript.exe slmgr.vbs /rilc and hit the Enter key.

    Reboot the system twice.

    Open Settings > Activation > Run Activation Troubleshooter

    If the above doesn't fix then either change the product key or try Phone Activation.


    S.Sengupta,Microsoft MVP Windows and Devices for IT, Windows Insider MVP

    Saturday, March 3, 2018 2:55 AM
  • I figured Windows got deactivated and the error code 0xC004F012 appearing was because I forcefully rebooted my computer. I restarted the computer and it's back to normal. I guess Windows didn't have enough time to load properly and that made the system go iffy. 

    • Proposed as answer by -Mr Happy- Saturday, March 3, 2018 1:00 PM
    • Marked as answer by Carey FrischMVP Thursday, December 27, 2018 7:44 AM
    Saturday, March 3, 2018 11:01 AM
  • Hi,

    Error code 0xC004F012 will occur when the activation status is lost. You might lost connection with activation server at that time. But at last, the issue was resolved after reboot computer, it is really a good thing to celebrate.

    Bests,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Edited by Joy-Qiao Monday, March 5, 2018 9:01 AM
    • Proposed as answer by Joy-Qiao Friday, March 30, 2018 9:56 AM
    Monday, March 5, 2018 9:01 AM
  • This worked perfectly.

    Thank you!

    Wednesday, May 2, 2018 11:14 AM
  • I'm having the same problem but after upgrading from Windows 10 Home Edition to the PRO.

    I Upgraded the System back in March and everything was working just fine until this afternoon...

    When I run the troubleshooting, I get the message stating " "We found a Windows 10 Home digital license for this device running Windows 10 Pro. To activate using this digital license you need to install Windows 10 Home"...

    I tried the instructions given by S.Sengupta but I'm still stuck with the same watermark..

    Because i'm in a trip to China, I have no way to get a phone support (we just can't call the support numbers)

    Hope it doesn't stop before I get back to Portugal... 

    Thursday, November 8, 2018 2:30 PM
  • Please see: Windows 10 suddenly deactivated

    Carey Frisch

    Thursday, November 8, 2018 3:43 PM
  • Running a quick scan for malware using McAfee Internet Security Suite resulted in removal of the opaque "Activate Windows" watermark in the bottom right corner of the display screen.  Apparently it was malware that got installed somehow. 

    Also fyi, I have received ' An item has been added to you startup, run a quick scan now? ' several times from SuperAntiSpyware over the last few days, and a quick scan with SASpyware removed then.

    Best Wishes.

    Saturday, November 10, 2018 6:17 PM