locked
Vista install in a virtual machine RRS feed

  • Question

  •  

    Some background first!

     

    virtual pc and virtual server are great for many things not least as a testing environment.

     

    with this in mind all Vista beta releases that had come my way were tried out in virtual machines, primarily on virtual server 2005 R2 and later in virtual server 2005 R2 SP1 Beta 2 x64.

     

    all the vista betas worked ok. they installed without issue. same for a couple of longhorn betas.

     

    When a distribution vista DVD with both 32bit and 64bit versions of Vista came my way, it was testing time. having a spare physical machine at the time the first install was on this machine. the machine has an ATA 250GB drive, nVidia 7600 graphics, 1GB DDR2 memory. Both 32bit and 64bit versions of Vista were installed. Both times, x86 and x64, completed without any issues.

     

    so far so good and now for the reason for this post.

     

    My preferred method of testing a new release of whatever software I get is to first convert the media to an ISO image and then work off the image in a virtual machine environment. The preferred tool for this is LCISOCreator. It is simple, quick and has proven very reliable. The vista DVD in my possession, having all the flavors, including 32bit and 64bits, weighs in at over 4GB. 4,651,550,720 bytes to be exact.

     

    After creating the ISO I copied it to the virtual machine host and created a new virtual machine. by the way, the host machine is running windows server 2003 enterprise r2 x64 SP2 with virtual server 2005 R2 beta 2. it has 4GB of 667MHz ECC memory and about 2TB of hard disks. currently on this server there are about 7 other virtual machines running fulltime.

     

    The new vista virtual machine was configured with 512MB of RAM and a 32GB expanding virtual disk. After mounting the Vista ISO image in the virtual CD/DVD drive the virtual machine booted and setup started. The boot loader popped the selection menu for x86 or x64 and x86 was selected. Setup continued and before long the all too familiar "autorun.dll can't be loaded or is corrupt" message with error code 0xC1 appeared.

     

    Keeping in mind that vista betas as virtual machines had been setup on this virtual server many times, and also keeping in mind that the new Vista DVD had been setup in both x86 and x64 flavors on a physical machine, it was mighty peculiar as to what the problem might be.

     

    Looking at the forums and searching for autorun.dll posts it became clear that there was an issue with the DVD format and potentially the DVD drive's ability to read the UDF format of large DVDs.

     

    So a process of elimination was started and to make a long story short I will relate here the end result and I would appreciate any feedback as to the validity of the my conclusion.

     

    To keep things simple I used Virtual PC 2007 on a Windows XP Professional SP2 that I know and trust. All the patches etc. are installed on this machine it is ultra stable and fast.

     

    A new virtual machine was configured and the virtual CDROM was bound to the machine's physical DVD drive. In the physical drive the Vista DVD described above was inserted.

     

    The virtual machine was booted and the x86 flavor was chosen. Installation proceeded without a problem and worked flawlessly. No Autorun.dll errors were seen and the setup concluded without a problem.

     

    The Vista DVD was then imaged as an ISO using two different tools. First LCISOCreator was used and then MagicISO. The resultant images were the same size.

     

    A new virtual machine was booted from each of these ISO images. The behavior of both attempts using the different ISOs was the same. The x86 flavor of Vista was used and the installation stalled with the autorun.dll error.

     

    To verify the ISO creation WinDiff was run between the images and the physical DVD. This wasn't done image to image but file to file . To accomplish this, the physical DVD was in the physical DVD drive and first the LCISOCreator ISO image, and then the MagicISO ISO image, was mounted as a virtual CDROM using Nero's ImageDrive tool.

     

    Then WinDiff was asked to compare the files within these DVD file structures. No differences or errors were reported between either images and the physical DVD. Windiff was not run between the file structures of the ISO images. These results seem to indicate that the ISO images are accurate copies of the DVD itself.

     

    My conclusion based on all this that the virtual CD/DVD driver in VirtualPC 2007 and Virtual Server 2005 R2 SP1 Beta2 are having difficulty reading the large UDF formatted ISO images. Virtual Server 2005 R2, nor VirtualPC 2004, were not tried. The assumption here being that they employ the same CD/DVD driver.

     

    Does this seem like an inescapable conclusion?

     

    Any feedback on this would be greatly appreciated.

    Sunday, April 8, 2007 12:55 PM