none
Hyper-V Manager unable to connect to server "Local computer" RRS feed

  • Question

  • I have a brand new beefy Dell system running Windows 10 v1809 (OS Build 17763.253) (Enterprise).  I'm trying to get Hyper-V set up, but I get this error in Hyper-V Manager when I click on "Connect to Server...", select "Local computer" and click OK:

    "An error occurred while attempting to connect to server "MY-PC-NAME". Check that the Virtual Machine service is running and that you are authorized to connect to the server.  Hyper-V encountered an error trying to access an object on computer 'MY-PC-NAME' because the object was not found. The object might have been deleted. Verify that the Virtual Machine Management service on the computer is running."

    Notes on what I have done so far to check/correct the issue:

    1. Verified that the Hyper-V Management Tools and Hyper-V Platform are installed via Windows Features

    2. Verified all the virtualization BIOS settings are enabled

    3. Verified the "Hyper-V Virtual Machine Management" service is running, noting that I have to manually start it after a reboot even though it is set to Automatic.  An event shows up in the event log that it failed to start after the reboot.

    4. Verified I am an Administrator on the machine

    5. Tried the  "mofcomp C:\Windows\System32\WindowsVirtualization.V2.mof" trick outlined elsewhere.  This did not help.

    6. Disabled Symantec antivirus.  This did not help.

    7. Uninstalled and reinstalled the Hyper-V Tools & Platform.  This did not help

    I see a lot of System Event Log entries whenever I perform anything related to Hyper-V (i.e. starting or stopping the service, trying  to connect, etc.):

      The server {7966B4D8-4FDC-4126-A10B-39A3209AD251} did not register with DCOM within the required timeout

    That GUID refers to something called WebPlatStorageBrokerServer

    And I also noticed this event show up:

      The Hyper-V Virtual Machine Management service terminated with the following error:
         Ran out of memory

    The PC has 32GB RAM with 81% free.

    I also see this in the event log when I stop and restart the Hyper-V VMM service:

     The Hyper-V Host Compute Service service failed to start due to the following error:
       The service did not respond to the start or control request in a timely fashion.

    And indeed the Hyper-V Host Compute Service is not running.  When I try to manually start that service, I get this error:

      Windows could not start the Hyper-V Host Compute Service service on Local Computer. 

      Error 1053: The service did not respond to the start or control request in a timely fashion.

    Any ideas what I might try next?

    Friday, January 25, 2019 7:29 PM

Answers

  • Hi,

     

    Good Day!

     

    You may refer to the following steps to troubleshoot the issue:

     

    1. Open "Window Security"

    2. Open "App & Browser control"

    3. Click "Exploit protection settings" at the bottom

    4. Switch to "Program settings" tab

    5. Locate "C:\WINDOWS\System32\vmcompute.exe" in the list and expand it

    6. Click "Edit"

    7. Scroll down to "Code flow guard (CFG)" and uncheck "Override system settings"

    8. Start vmcompute from powershell

    net start vmcompute

    Please let me know if there is any update after that. Thanks for your time.

    Best Regards,



    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Tim Trout Monday, January 28, 2019 2:59 PM
    Monday, January 28, 2019 7:35 AM

All replies

  • I managed to "fix" the issue on my Surface Book by completely uninstalling Symantec AV ( sparked by other threads mentioning a similar issue with McAffee).  Host Compute and VMMS both start by themselves at startup with no errors in the event log, and Hyper-V Manager connects to my Local Machine automatically.  My company is in the process of moving to a different security platform, so no biggie - I won't get in trouble with the IT department.  I'll try this on the Dell system Monday.
    Sunday, January 27, 2019 7:49 PM
  • Unfortunately removing Symantec did not fix the problem on my Dell.  Host Compute service still will not start, with the same errors
    Sunday, January 27, 2019 8:28 PM
  • Hi,

     

    Good Day!

     

    You may refer to the following steps to troubleshoot the issue:

     

    1. Open "Window Security"

    2. Open "App & Browser control"

    3. Click "Exploit protection settings" at the bottom

    4. Switch to "Program settings" tab

    5. Locate "C:\WINDOWS\System32\vmcompute.exe" in the list and expand it

    6. Click "Edit"

    7. Scroll down to "Code flow guard (CFG)" and uncheck "Override system settings"

    8. Start vmcompute from powershell

    net start vmcompute

    Please let me know if there is any update after that. Thanks for your time.

    Best Regards,



    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Tim Trout Monday, January 28, 2019 2:59 PM
    Monday, January 28, 2019 7:35 AM
  • Perfecto!  That did the trick.  Thanks much, Zoe!
    Monday, January 28, 2019 3:00 PM
  • I am pleased to know that the information is helpful to you.

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, January 29, 2019 1:19 AM
  • Thanks a lot, Zoe, works perfectly!
    Tuesday, April 30, 2019 12:23 PM
  • After this I set VMMS to automatic and it worked perfectly
    Friday, May 10, 2019 7:02 AM
  • Worked for me!

    Neil Clinch

    Thursday, August 1, 2019 2:08 PM
  • Great!. It was very helpful. 
    Saturday, October 26, 2019 6:24 PM
  • Thanks! this resolved the issue Hyper-V Manager able to connect to local computer
    Thursday, November 14, 2019 5:57 AM