none
Exchange Transport Error Event ID 12014

    Question

  • Server is Exchange 2010. A UC certificate is installed and linked to the IIS service only. The UC certificate is issued for mail.domain.com and autodiscover.domain.com. The Exchange server is a single server with a all roles running on the same server. The Send Connection FQDN is mail.domain.com. The Receive Connectors all have servername.domain.local as the FQDN. I am afraid to assign the SMTP service to the UC certificate as I think all the Outlook clients will get a certificate error as they are looking for servername.domain.local not mail.domain.com. What should I do?

    Michael Maxwell

    Wednesday, May 28, 2014 10:16 PM

All replies

  • Server is Exchange 2010. A UC certificate is installed and linked to the IIS service only. The UC certificate is issued for mail.domain.com and autodiscover.domain.com. The Exchange server is a single server with a all roles running on the same server. The Send Connection FQDN is mail.domain.com. The Receive Connectors all have servername.domain.local as the FQDN. I am afraid to assign the SMTP service to the UC certificate as I think all the Outlook clients will get a certificate error as they are looking for servername.domain.local not mail.domain.com. What should I do?

    Michael Maxwell

    this will happen if you change the SCP but not in the case of receive connector.

    Where Technology Meets Talent

    Thursday, May 29, 2014 1:31 AM
  • So you cant change the Default Receive Connector FQDN, are you saying change the Client Receive Connector to from servername.domain.local to mail.domain.com ?  What is your suggestion? How will that fix the error?

    Michael Maxwell

    Thursday, May 29, 2014 4:31 AM
  • Hi,

    Please refer to the following article:

    http://www.microsoft.com/technet/support/ee/transform.aspx?ProdName=Exchange&ProdVer=8.0&EvtID=12014&EvtSrc=MSExchangeTransport

    To resolve this warning, perform the following steps:

    1. Examine the configuration of the certificates installed on the Exchange server and the configuration of all Receive connectors and Send connectors installed on the server. The following commands are used to view the configuration:

      Get-ExchangeCertificate | FL *

      Get-ReceiveConnector | FL name, fqdn, objectClass

      Get-SendConnector | FL name, fqdn, objectClass

      Note   To display the services that are enabled for the installed certificate, you must use the asterisk (*) when you run the FL argument on the Get-ExchangeCertificate cmdlet. The Services values will not display if the * is not specified in the task parameters.

      Run the commands and compare the FQDN that is returned with the Warning event with the FQDN that is defined on each of the connectors and with the CertificateDomains values that are defined on each of the certificates. The CertificateDomains value is a concatenation of the Subject and Subject Alternative Name fields on the certificate.

      The goal is to verify that each connector that is using TLS has a corresponding certificate that includes the connector's FQDN in the CertificateDomains values of the certificate. Note any connectors that are enabled for TLS but do not have a corresponding certificate where the connector FQDN is in the CertificateDomains values of the certificate.

      Inspect the Services value on each certificate. If you are using a certificate for TLS, it must be enabled for the SMTP service with a Services value of SMTP.

    2. If the FQDN is not listed on the CertificateDomains parameter, you must create a new certificate and specify the FQDN of the connector that is returned in this warning message. You can create the certificate by using the New-ExchangeCertificate cmdlet. Or you may prefer to use a third-party or custom certificate. You can use the New-ExchangeCertificate cmdlet to generate the certificate request. For more information, see Creating a Certificate or Certificate Request for TLS.

    3. If a third-party or custom certificate has been installed on the server and it contains a matching FQDN but the certificate is not enabled for the SMTP service, the certificate must be enabled for the SMTP service. For more information, see Enable-ExchangeCertificate.

    Thanks.


    Niko Cheng
    TechNet Community Support

    Thursday, May 29, 2014 6:57 AM
    Moderator
  • I have already found that write up. So, number 3 applies. If I do that all the Outlook clients will get a certificate error. Please re-read my original post.

    Michael Maxwell

    Thursday, May 29, 2014 2:27 PM
  • Did you install the certificate on SMTP service? If not then you have to. Looks like you want to use TLS

    Where Technology Meets Talent

    Thursday, May 29, 2014 2:35 PM
  • No, please read my original post. "A UC certificate is installed and linked to the IIS service only".

    So, when I link the cert to SMTP, wont the Outlook clients all get a certificate error? as they are looking for servername.domain.local not mail.domain.com.


    Michael Maxwell

    Thursday, May 29, 2014 6:17 PM
  • see these article to help you understand

    http://www.microsoft.com/technet/support/ee/transform.aspx?ProdName=Exchange&ProdVer=8.0&EvtID=12014&EvtSrc=MSExchangeTransport

    http://social.technet.microsoft.com/Forums/en-US/b9ec2ab2-3e01-4c24-a066-a67fdd72d425/event-id-12014?forum=exchangesvrsecuremessaginglegacy


    Where Technology Meets Talent

    Thursday, May 29, 2014 6:20 PM
  • Those are no help. Send connector already has mail.domain.com as the FQDN.

    I realize to fix the 12014 error I should add SMTP service to my certificate, but I don't want to break all the Outlook clients as they are looking for servername.domain.local still.


    Michael Maxwell

    Thursday, May 29, 2014 7:01 PM