locked
Printer shows offline in Print Management - it isn't RRS feed

  • Question

  • A network printer was moved from one location to another recently, and it got a new IP address since it is now in a different subnet.

    I confirmed that the IP address in the printer was changed and, on the print server.  But it still shows up in Print Management as "offline", so it is also showing up as offline on the workstations it's deployed to.  The users can print to it.  I can ping it's IP.

    Any ideas why it would be showing as offline?

    Tuesday, April 2, 2013 1:38 PM

Answers

  • Go to the printer properties > Ports > Configure Port and uncheck the SNMP Status Enabled.

    ***** This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by JohnB352 Tuesday, April 2, 2013 3:53 PM
    Tuesday, April 2, 2013 2:50 PM

All replies

  • Hi JihnB352,

    the first suggestion that you have changed the IP port but not at 'SNMP status' (some Xerox drivers has it set inside their own settings aswell)

    Second: network routers does not forward port 161 to another subnet.

    try telnet printer's_ip 161 from the printserver.

    Tuesday, April 2, 2013 2:16 PM
  • Check to assure your printer has not been set to “sleep” or “power save” mode. If the printer “sleeps” it could appear “offline”.

    Reddy

    Tuesday, April 2, 2013 2:21 PM
  • Go to the printer properties > Ports > Configure Port and uncheck the SNMP Status Enabled.

    ***** This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by JohnB352 Tuesday, April 2, 2013 3:53 PM
    Tuesday, April 2, 2013 2:50 PM
  • Go to the printer properties > Ports > Configure Port and uncheck the SNMP Status Enabled.

    ***** This posting is provided "AS IS" with no warranties, and confers no rights.


    I just checked that.  SNMP status was already unchecked.  The only settings on the printer that were changed, when it moved to it's new location was the IP information.  The printer did not have this problem before it was moved.
    Tuesday, April 2, 2013 3:49 PM
  • Hi JihnB352,

    the first suggestion that you have changed the IP port but not at 'SNMP status' (some Xerox drivers has it set inside their own settings aswell)

    Second: network routers does not forward port 161 to another subnet.

    try telnet printer's_ip 161 from the printserver.

    Hi - I assume you're referring to the same SNMP setting Tony was?  That was not changed when it was moved - it is not checked off.

    I can telnet from the print server to the printer, using port 9100, which is what it's set to in Port settings.

    Tuesday, April 2, 2013 3:51 PM
  • Go to the printer properties > Ports > Configure Port and uncheck the SNMP Status Enabled.

    ***** This posting is provided "AS IS" with no warranties, and confers no rights.


    After checking that I decided I'd try checking that box.  As soon as I clicked on OK the printer went back to Online.  So then I went back into properties and removed that check again, and it is still online.  So I don't know... but it's online and that's all that is important.  Thanks.
    • Proposed as answer by pete kokkinis Friday, April 17, 2015 4:58 PM
    Tuesday, April 2, 2013 3:53 PM
  • ok, maybe it is a stupid question, but have you restarted server or at least print spooler?
    Tuesday, April 2, 2013 3:54 PM
  • Make sure in the printer itself has the SNMP enabled and it has the correct Community Name. One of my junior admins disabled that setting in some of the HP printers and that caused "weird" issues.


    ***** This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, April 2, 2013 3:56 PM
  • Exact same problem here.  Turned out to be SNMP disabled on the HP Jetdirect and unchecked on the Windows printer port settings.  I enabled Read Only SNMP on the HP JetDirect and enabled SNMP on the Printer Port configuration on the Windows server and the printer immediately switched to Online.  Thanks!

    Friday, December 6, 2013 3:11 PM
  • This worked for me , issue got resolved 

    Thank you much , can anyone elaborate why this issue accrued 

    Thanks

    Ajit

    Friday, February 13, 2015 1:23 PM
  • Go to the printer properties > Ports > Configure Port and uncheck the SNMP Status Enabled.

    ***** This posting is provided "AS IS" with no warranties, and confers no rights.


    Solved my misery, so silly to waste our time on. Thanks for the help.
    Thursday, February 18, 2016 6:55 AM
  • Go to the printer properties > Ports > Configure Port and uncheck the SNMP Status Enabled.


    ***** This posting is provided "AS IS" with no warranties, and confers no rights.


    Solved my misery, so silly to waste our time on. Thanks for the help.

    I found in my case that there were 2 ports created. I manually created a port, but when I deployed via Group Policy the Print Manager created another port for the same IP address. This check box helped me get the printer back online, and I manually removed the Ports that I had created that were not being used. Don't want to confuse the MS software. LOL

    Thanks!

    Monday, July 25, 2016 3:13 PM
  • This worked like a charm. 
    Tuesday, July 21, 2020 3:14 PM