locked
Event Source: MSExchangeIS RRS feed

  • Question

  • Event Type: Error
    Event Source: MSExchangeIS
    Event Category: General
    Event ID: 9667
    Date:  3/28/2010
    Time:  8:20:35 AM
    User:  N/A
    Computer: ??????

    Description:
    Failed to create a new named property for database "First Storage Group\Heavy-Users Store (??????)" because the number of named properties reached the quota limit (8192).
     User attempting to create the named property: "????????"
     Named property GUID: 00020386-0000-0000-c000-000000000046
     Named property name/id: "X-Imriu"

    For more information, click http://www.microsoft.com/contentredirect.asp.

     

    do i need to run an offline defragment or there is another solution?

    Sunday, May 16, 2010 6:25 AM

Answers

  • Hi

    Which version of Exchange are you talking about here?

    I found a link, maybe it's helpful for you if you're talking about Exchange 2003

    http://msexchangeguru.com/2009/09/04/event-id-9667/

    http://support.microsoft.com/default.aspx?scid=kb;en-us;820379&sd=ee


    Jonas Andersson MCTS: Microsoft Exchange Server 2010, Configuration | MCITP: EMA | MCSE/MCSA Blog: http://www.testlabs.se/blog
    • Proposed as answer by Gavin-Zhang Thursday, May 20, 2010 2:49 AM
    • Marked as answer by Gavin-Zhang Thursday, May 20, 2010 3:03 AM
    Sunday, May 16, 2010 10:55 AM
  • Hi,

    Go with the following link and it would be helpful for you.

    http://support.microsoft.com/kb/820379

     

     

     


    Ashwin Raj
    • Proposed as answer by Gavin-Zhang Thursday, May 20, 2010 2:49 AM
    • Marked as answer by Gavin-Zhang Thursday, May 20, 2010 3:03 AM
    Sunday, May 16, 2010 1:09 PM
  • On Mon, 17 May 2010 05:36:19 +0000, Mohammed_Omar wrote:
     
    >all links describe how to change on the registery but as i understand its not a permenant solution the other solution to create another DB and move some uers to it. but i want to ask if i did an offline defrag to reduce the DB size is this will be a good solution
     
    The original post refers to a problem where the number of named
    properties has exceeded the maximm number allowed. Defragging the
    database won't help even if you reduced its size to zero.
     
    Moving ALL the mailboxes to another database will halp -- temporarily.
    The only way to stop the increase in tne number of named properties is
    to remove the unwanted X-Headers from the messages before they arrive
    at the information store.
     
    Exchange 2007 SP1 RU9 can do that. There's also a transport agent that
    can be used to remove the headers. Exchange 2003, sadly, has no such
    ability unless you write your own code.
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    • Proposed as answer by Gavin-Zhang Thursday, May 20, 2010 2:48 AM
    • Marked as answer by Gavin-Zhang Thursday, May 20, 2010 3:03 AM
    Tuesday, May 18, 2010 2:37 AM

All replies

  • Hi

    Which version of Exchange are you talking about here?

    I found a link, maybe it's helpful for you if you're talking about Exchange 2003

    http://msexchangeguru.com/2009/09/04/event-id-9667/

    http://support.microsoft.com/default.aspx?scid=kb;en-us;820379&sd=ee


    Jonas Andersson MCTS: Microsoft Exchange Server 2010, Configuration | MCITP: EMA | MCSE/MCSA Blog: http://www.testlabs.se/blog
    • Proposed as answer by Gavin-Zhang Thursday, May 20, 2010 2:49 AM
    • Marked as answer by Gavin-Zhang Thursday, May 20, 2010 3:03 AM
    Sunday, May 16, 2010 10:55 AM
  • Hi

    first of all thanx for your reply. my exchange server is 2003 sp2 and i'm reading your links.

    Sunday, May 16, 2010 12:16 PM
  • Hi,

    Go with the following link and it would be helpful for you.

    http://support.microsoft.com/kb/820379

     

     

     


    Ashwin Raj
    • Proposed as answer by Gavin-Zhang Thursday, May 20, 2010 2:49 AM
    • Marked as answer by Gavin-Zhang Thursday, May 20, 2010 3:03 AM
    Sunday, May 16, 2010 1:09 PM
  • all links describe how to change on the registery but as i understand its not a permenant solution the other solution to create another DB and move some uers to it. but i want to ask if i did an offline defrag to reduce the DB size is this will be a good solution
    Monday, May 17, 2010 5:36 AM
  • On Mon, 17 May 2010 05:36:19 +0000, Mohammed_Omar wrote:
     
    >all links describe how to change on the registery but as i understand its not a permenant solution the other solution to create another DB and move some uers to it. but i want to ask if i did an offline defrag to reduce the DB size is this will be a good solution
     
    The original post refers to a problem where the number of named
    properties has exceeded the maximm number allowed. Defragging the
    database won't help even if you reduced its size to zero.
     
    Moving ALL the mailboxes to another database will halp -- temporarily.
    The only way to stop the increase in tne number of named properties is
    to remove the unwanted X-Headers from the messages before they arrive
    at the information store.
     
    Exchange 2007 SP1 RU9 can do that. There's also a transport agent that
    can be used to remove the headers. Exchange 2003, sadly, has no such
    ability unless you write your own code.
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    • Proposed as answer by Gavin-Zhang Thursday, May 20, 2010 2:48 AM
    • Marked as answer by Gavin-Zhang Thursday, May 20, 2010 3:03 AM
    Tuesday, May 18, 2010 2:37 AM
  • For Exchange 2003, we have a hot fix for Service Pack 2 that enables the control for the creation of x-headers for named properties using a Registry Editor entry:

    972077 "Outlook cannot display this view. Unknown Error" error message is generated in Outlook client and Event ID 9667 is logged on an Exchange Server 2003 server
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;972077

    After you apply this fix, you may follow these steps to set a registry entry to control the promotion of X-headers for named properties:

    1. Click Start , click Run , type regedit , and then click OK .

    2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS

    \ParametersSystem\InternetContent

    3. On the Edit menu, point to New , and then click DWORD Value .

    4. Type GenerateNamedProperties , and then press ENTER .

    5. Quit Registry Editor.

    A 0 value of the GenerateNamedProperties attribute will not generate new named properties.

    The default behavior (of the promotion of X-headers for named properties) is true when this registry entry is not found or set to 1.

    Tuesday, January 22, 2013 9:00 PM