none
Schedule Script through GPO is not running

    Question

  • Hi expert

    I have scheduled a powershell script through GPO in computer preference mode. The script is pushed on machines but it does not run and gives a error as below.

    ERROR MSG : -

    Task Scheduler failed to start "\Sercvices check" task for user "BUILTIN\BUILTIN". Additional Data: Error Value: 2147943645.

    One more message it gives on machines task scheduler is

    The task could not be run because there was no user logged on.

    Below are the details about schedule task on GPO

    1. The Task is schedule in computer mode. So it should not ask for any user login or user details

    2. Action to Take - Run a Programme - Path - \\servername\Script.ps1

    Friday, February 13, 2015 1:42 PM

Answers

  • Hi,

    Before going further, to allow PowerShell script to be executed, we can try to navigate to the following setting:

    Computer Configuration \ Administrative Templates \Windows Components \Windows PowerShell\Turn On Script Execution

    After enabling the above, we can choose the option which is suitable for our environment to allow what kind of PowerShell script to be run.

    If the issue persists, please try to run the script with NT Authority\System account.

    Best regards,

    Frank Shen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 16, 2015 7:31 AM
    Moderator

All replies

  • Hi,

    Before going further, to allow PowerShell script to be executed, we can try to navigate to the following setting:

    Computer Configuration \ Administrative Templates \Windows Components \Windows PowerShell\Turn On Script Execution

    After enabling the above, we can choose the option which is suitable for our environment to allow what kind of PowerShell script to be run.

    If the issue persists, please try to run the script with NT Authority\System account.

    Best regards,

    Frank Shen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 16, 2015 7:31 AM
    Moderator
  • Thanks Frank

    Let me give a try and update the thread

    Monday, February 16, 2015 1:35 PM
  • Hi Frank

    NT Authority\System is not found in domain. please check the account. this kind of message is displayed while adding the account.

    Please suggest

    Wednesday, February 18, 2015 5:36 AM
  • hi

    Yes its working. I have to select run if user not logon also option.

    Thanks

    marking as answer.

    Wednesday, February 25, 2015 1:36 PM
  • Sorry for the delayed response and I'm glad that it's working.

    Best regards,
    Frank Shen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, March 02, 2015 1:01 AM
    Moderator