locked
RegTask: Failed to send registration request message. Error: 0x87d00231 RRS feed

  • Question

  • Ho All,

    I am testing IBCM functionality in ConfigMgr 2012. I have successfully tested this functionality on Domain-joined Laptops. But I am facing issue with Workgroup Laptops.
    I have deployed ConfigMgr 2012 Client on the Workgroup machine successfully with following commandline:

    ccmsetup.exe /SOURCE:"C:\ConfigMgr2012-Client-Workgroup-Laptop" /Logon /UsePKICert /NoCRLCheck CCMALWAYSINF=1 CCMHOSTNAME="KBMG.XXX.com" CCMFIRSTCERT=1 SMSSITECODE=BS2 SMSSIGNCERT="C:\ConfigMgr2012-Client-Workgroup-Laptop\SiteServerSigningCertificate\SiteServerSigningCertificate-BS2.CER"

    But I am getting the following error:

    ClientIDManagerStartup.log:

    RegTask: Failed to send registration request message. Error: 0x87d00231 ClientIDManagerStartup 20-07-2012 04:52:03 5592 (0x15D8)
    RegTask: Failed to send registration request. Error: 0x87d00231 ClientIDManagerStartup 20-07-2012 04:52:03 5592 (0x15D8)

    LocationServices.log

    Failed to send management point list Location Request Message to KBMG.XXX.com LocationServices 20-07-2012 04:50:00 5592 (0x15D8)
    LSUpdateInternetManagementPoints: No internet MPs were retrieved from internet MP, retaining previous list. LocationServices 20-07-2012 04:50:00 5592 (0x15D8)

    CcmMessaging.log

    Begin to select client certificate CcmMessaging 20-07-2012 04:49:59 5592 (0x15D8)
    Begin validation of Certificate [Thumbprint A5BFED02614F702FC9DB061BA8F09C0E405D6EC8] issued to 'Home' CcmMessaging 20-07-2012 04:49:59 5592 (0x15D8)
    Completed validation of Certificate [Thumbprint A5BFED02614F702FC9DB061BA8F09C0E405D6EC8] issued to 'Home' CcmMessaging 20-07-2012 04:49:59 5592 (0x15D8)
    >>> Client selected the PKI Certificate [Thumbprint A5BFED02614F702FC9DB061BA8F09C0E405D6EC8] issued to 'Home' CcmMessaging 20-07-2012 04:49:59 5592 (0x15D8)
    Raising event:

    instance of CCM_ServiceHost_CertRetrieval_Status
    {
    ClientID = "GUID:916DD823-BD27-4D64-B8D9-8AE130D7B642";
    DateTime = "20120720111959.993000+000";
    HRESULT = "0x00000000";
    ProcessID = 5144;
    ThreadID = 5592;
    };
    CcmMessaging 20-07-2012 04:49:59 5592 (0x15D8)
    [CCMHTTP] AsyncCallback(): ----------------------------------------------------------------- CcmMessaging 20-07-2012 04:50:00 5592 (0x15D8)
    [CCMHTTP] AsyncCallback(): WINHTTP_CALLBACK_STATUS_SECURE_FAILURE Encountered CcmMessaging 20-07-2012 04:50:00 5592 (0x15D8)
    [CCMHTTP]                : dwStatusInformationLength is 4
    CcmMessaging 20-07-2012 04:50:00 5592 (0x15D8)
    [CCMHTTP]                : *lpvStatusInformation is 0x1
    CcmMessaging 20-07-2012 04:50:00 5592 (0x15D8)
    [CCMHTTP]            : WINHTTP_CALLBACK_STATUS_FLAG_CERT_REV_FAILED is set
    CcmMessaging 20-07-2012 04:50:00 5592 (0x15D8)
    [CCMHTTP] AsyncCallback(): ----------------------------------------------------------------- CcmMessaging 20-07-2012 04:50:00 5592 (0x15D8)
    Raising event:

    instance of CCM_CcmHttp_Status
    {
    ClientID = "GUID:916DD823-BD27-4D64-B8D9-8AE130D7B642";
    DateTime = "20120720112000.832000+000";
    HostName = "KBMG.XXX.com";
    HRESULT = "0x80072f8f";
    ProcessID = 5144;
    StatusCode = 1;
    ThreadID = 5592;
    };
    CcmMessaging 20-07-2012 04:50:00 5592 (0x15D8)
    Failed in WinHttpSendRequest API, ErrorCode = 0x2f8f CcmMessaging 20-07-2012 04:50:00 5592 (0x15D8)
    [CCMHTTP] ERROR: URL=https://KBMG.XXX.com/ccm_system/request, Port=443, Options=480, Code=12175, Text=ERROR_WINHTTP_SECURE_FAILURE CcmMessaging 20-07-2012 04:50:00 5592 (0x15D8)
    Successfully sent location services HTTPS failure message. CcmMessaging 20-07-2012 04:50:00 5592 (0x15D8)
    Post to https://KBMG.XXX.com/ccm_system/request failed with 0x87d00231. CcmMessaging 20-07-2012 04:50:00 5592 (0x15D8)
    [CCMHTTP] AsyncCallback(): ----------------------------------------------------------------- CcmMessaging 20-07-2012 04:50:01 5592 (0x15D8)
    [CCMHTTP] AsyncCallback(): WINHTTP_CALLBACK_STATUS_SECURE_FAILURE Encountered CcmMessaging 20-07-2012 04:50:01 5592 (0x15D8)
    [CCMHTTP]                : dwStatusInformationLength is 4
    CcmMessaging 20-07-2012 04:50:01 5592 (0x15D8)
    [CCMHTTP]                : *lpvStatusInformation is 0x1
    CcmMessaging 20-07-2012 04:50:01 5592 (0x15D8)
    [CCMHTTP]            : WINHTTP_CALLBACK_STATUS_FLAG_CERT_REV_FAILED is set
    CcmMessaging 20-07-2012 04:50:01 5592 (0x15D8)
    [CCMHTTP] AsyncCallback(): ----------------------------------------------------------------- CcmMessaging 20-07-2012 04:50:01 5592 (0x15D8)
    Raising event:

    instance of CCM_CcmHttp_Status
    {
    ClientID = "GUID:916DD823-BD27-4D64-B8D9-8AE130D7B642";
    DateTime = "20120720112001.678000+000";
    HostName = "KBMG.XXX.com";
    HRESULT = "0x80072f8f";
    ProcessID = 5144;
    StatusCode = 1;
    ThreadID = 5592;
    };
    CcmMessaging 20-07-2012 04:50:01 5592 (0x15D8)
    Failed in WinHttpSendRequest API, ErrorCode = 0x2f8f CcmMessaging 20-07-2012 04:50:01 5592 (0x15D8)
    [CCMHTTP] ERROR: URL=https://KBMG.XXX.com/ccm_system/request, Port=443, Options=480, Code=12175, Text=ERROR_WINHTTP_SECURE_FAILURE CcmMessaging 20-07-2012 04:50:01 5592 (0x15D8)
    Successfully sent location services HTTPS failure message. CcmMessaging 20-07-2012 04:50:01 5592 (0x15D8)
    Post to https://KBMG.XXX.com/ccm_system/request failed with 0x87d00231. CcmMessaging 20-07-2012 04:50:01 5592 (0x15D8)

    What could be the reason?

    Thanks & Regards, Kedar

    Friday, July 20, 2012 11:33 AM

Answers

  • Hello kedar,

    I also faced same issue  (Failed to send registration request message. Error: 0x87d00231ClientIDManagerStartup) while deploying ConfigMgr 2012 internet Client on the Workgroup machine.

    I uncheck the check box from Site Properties which disable CRL check and reinstalled client with /NoCRLCheck CCMHOSTNAME=InternetFQDN with SMSSite code switches and Client is now appearing in the Console as Active

    Internet Management Point is IBCM.abc.com (internetMp FQDN) with Version 0 à is right behaviour and for intranet MP version should be 7711


    BR// Praveen Sharma B.Tech (E&C), MCSE,MCTS (Exchange)

    Sunday, August 12, 2012 9:43 AM

All replies

  • Hi All,

    I have gone through the following links and understand that Client is trying to access the CRL.

    http://blogs.msdn.com/b/ameltzer/archive/2008/04/14/common-native-mode-client-mp-error-messages-and-what-to-do-about-them.aspx

    http://msdn.microsoft.com/en-us/library/windows/desktop/aa383917(v=vs.85).aspx

    I did not understand that I have installed the Client with /NoCRLCheck switch; so why its checking for CRL?

    If I want to disable the CRL check from the Server side; then where is the setting in CM2012? I could not find it in CM2012?

    Or If I want to allow CRL check then what ports are require from IBCM Server (which is in DMZ) and CA Server (which is in Intranet)?

    Please help on this.


    Thanks & Regards, Kedar

    Sunday, July 22, 2012 3:23 PM
  • Hi All,

    I uncheck the check box from Site Properties which disable CRL check. I reinstalled client with SMSMP and /NoCRLCheck switches and Client is now appearing in the Console as Active. But ClientLocation.log shows the following:

    Current Internet Management Point is KBMG.XXX.com with Version 0 and Capabilities: <Capabilities SchemaVersion ="1.0"><Property Name="SSL" Version="1" /></Capabilities>

    Why its not showing version as 7711? Is it OK behaviour of the client?


    Thanks & Regards, Kedar

    Monday, July 23, 2012 5:15 PM
  • Hi All,

    Any update on this?


    Thanks & Regards, Kedar

    Thursday, August 2, 2012 2:52 PM
  • Hello kedar,

    I also faced same issue  (Failed to send registration request message. Error: 0x87d00231ClientIDManagerStartup) while deploying ConfigMgr 2012 internet Client on the Workgroup machine.

    I uncheck the check box from Site Properties which disable CRL check and reinstalled client with /NoCRLCheck CCMHOSTNAME=InternetFQDN with SMSSite code switches and Client is now appearing in the Console as Active

    Internet Management Point is IBCM.abc.com (internetMp FQDN) with Version 0 à is right behaviour and for intranet MP version should be 7711


    BR// Praveen Sharma B.Tech (E&C), MCSE,MCTS (Exchange)

    Sunday, August 12, 2012 9:43 AM
  • I wouldn't feel too dumb.  I had the same error and this article actually gave me the brilliant idea to check connectivity from the client back to the host and hence fix the problem.  So, with that in mind, thanks for posting this!
    Thursday, July 11, 2013 6:46 PM
  • I have faced the same issue and i have trying mentioned article.

    http://ramzibot.wordpress.com/2012/11/15/resolving-regtask-failed-to-send-registration-request-message-error-0x87d00231-by-repairing-the-management-point/

    it worked for me

    Set MP role to HTTPS and check mpcontrol.log for 443 , 200 ok

    again set MP role to HTTP and check mpcontol.log for 80, 200 ok

    Note: My sccm 2012 sp1 server configured with HTTP

    after 960 sec, means 16 min, ClientIDManagerStartup.log becomes ok in Client machines, SCCM client becomes Active in SCCM Console, i hope this trick will help you.


    Kirpal Singh



    Wednesday, November 6, 2013 12:31 PM
  • no need to do that at all, instead check your command line install switch and verify that it's using the FQDN of the MP instead of just the netbios name

    eg:

    below is incorrect !

    CCMSetup.exe SMSMP=sccm /logon SMSSITECODE=P01 /source:z:

    below is correct !

    CCMSetup.exe SMSMP=sccm.server2008r2.lab.local /logon SMSSITECODE=P01 /source:z:

    also to note it may use another MP when it tries to register, (it may have retrieved the list of mp's from AD) check which one it's trying against in locationservices.log or in the gui of the unregistered client itself.

    Step by Step Configuration Manager Guides > 2012 Guides | 2007 Guides | I'm on Twitter > ncbrady



    Friday, December 6, 2013 8:33 AM