none
ActiveX controls not downloaded when using Internet Explorer 10 RRS feed

  • Question

  • We have many legacy applications developed using ASP and VB(InterDev). Our organization is moving to use Internet Explorer 10 in the near future.

    We had a IE10 compatibility testing for our legacy applications and we observed that the applications using ActiveX controls are not working. Applications works perfectly fine with the older version of Internet Explorer.

    We looked for the various workarounds but we did not find any.

    Some application does nothing when we click on a button to generate the report but some applications throws the below error:

    <div id="x_x_imcontent"> <div style="font-size: 9pt; direction: ltr;">"ActiveX control failed to load! -- This control is required to use the Address Book and Attachment features.  Please check your browser security settings and/or contact PC Support to install the digitally signed control."</div> </div>

    We will be glad if we get any assistance on this issue.

    Monday, July 14, 2014 4:06 PM

Answers

  • Hi,

    Please post your ActiveX feature testing scripts to the IE Web Developer forum.

    (f12>Debug tab, search for ActiveX.... you should be able to find code blocks where you are feature testing for your ActiveX controls eg var ourcontrol=new ActiveX('foobar');

    these code blocks will be the origin of the error messages that are injected into the page. (you can also search for where the "ActiveX control failed to load" string is in your code.)

    http://social.msdn.microsoft.com/Forums/ie/en-US/home?forum=iewebdevelopment

    IE10 has ActiveX filtering.... a blue circle with a line through it appears in the Address bar if any ActiveX content is blocked by Tools>ActiveX filtering.

    IE10 has Enhanced protected Mode turned on by default in the Internet and Restricted Zones. I assume that you are mapping your test domain to the Intranet zone (where EPM is turned off by default and x32 bit controls are used.... if not you should see information bars asking for permission to run the 32bit activeX controls)

    Ensure you are using the Default IE security settings, (and also that you have applied the new admx files to your GPO and GPEdit control panels....)

    Tools>Internet Options>Security tab, click "Reset all zones to default".

    Ensure your test environment maps to the Intranet Zone (File>Properties) and that Enhanced Protected Mode is turned off for that zone (Security tab of Internet Options)

    Ensure that your ActiveX controls are enabled (Tools>Manage Addons>Show all Addons) and that they have the correct permissions..... find them in the Addons manager and then click the item in the list to display their properties and permissions... at the bottom of the Addons Properties there is a textarea with "You have approved this addon to run in the follow websites"... you testing and production domains should be listed.

    For the best solutions/answers you should probably open a support ticket at support.microsoft.com so a support engineer can access your testing environment and do some tests.

    Regards.


    Rob^_^

    Wednesday, July 16, 2014 6:22 PM

All replies

  • Hi,

    As for this situation, I suggest to launch the Internet Explorer in compatible mode, To turn on Compatibility View in this way:

    1.See if the Compatibility View button Compatibility View button appears in the Address bar.

    2.Tap or click the Compatibility View button Compatibility View button to display the site in Compatibility View.

    More details about compatible view, you can see this :

    http://windows.microsoft.com/en-us/internet-explorer/use-compatibility-view#ie=ie-10

    Another thing I have to point out is, if this situation happens just when you debug the ASP or VB program, this issue should be related to the form or the code, I suggest to post it at the MSDN forum:

    http://social.msdn.microsoft.com/Forums/en-US/home

    Regards

     


    Wade Liu
    TechNet Community Support

    Wednesday, July 16, 2014 10:13 AM
  • Hi,

    Please post your ActiveX feature testing scripts to the IE Web Developer forum.

    (f12>Debug tab, search for ActiveX.... you should be able to find code blocks where you are feature testing for your ActiveX controls eg var ourcontrol=new ActiveX('foobar');

    these code blocks will be the origin of the error messages that are injected into the page. (you can also search for where the "ActiveX control failed to load" string is in your code.)

    http://social.msdn.microsoft.com/Forums/ie/en-US/home?forum=iewebdevelopment

    IE10 has ActiveX filtering.... a blue circle with a line through it appears in the Address bar if any ActiveX content is blocked by Tools>ActiveX filtering.

    IE10 has Enhanced protected Mode turned on by default in the Internet and Restricted Zones. I assume that you are mapping your test domain to the Intranet zone (where EPM is turned off by default and x32 bit controls are used.... if not you should see information bars asking for permission to run the 32bit activeX controls)

    Ensure you are using the Default IE security settings, (and also that you have applied the new admx files to your GPO and GPEdit control panels....)

    Tools>Internet Options>Security tab, click "Reset all zones to default".

    Ensure your test environment maps to the Intranet Zone (File>Properties) and that Enhanced Protected Mode is turned off for that zone (Security tab of Internet Options)

    Ensure that your ActiveX controls are enabled (Tools>Manage Addons>Show all Addons) and that they have the correct permissions..... find them in the Addons manager and then click the item in the list to display their properties and permissions... at the bottom of the Addons Properties there is a textarea with "You have approved this addon to run in the follow websites"... you testing and production domains should be listed.

    For the best solutions/answers you should probably open a support ticket at support.microsoft.com so a support engineer can access your testing environment and do some tests.

    Regards.


    Rob^_^

    Wednesday, July 16, 2014 6:22 PM