none
Using PPS Model dimensions in Designer RRS feed

  • Question

  •  

    Hi - I've created a simple model using PPS Modeller and when I use the resulting cube in PPS Designer it gets very confusing.

    The model uses the Entity dimension to hold  a company organisation hierarchy, the scenario dimension for actuals & budgets, and a custom dimension called perspectives to hold a list of measures... oh.. and the Time dimension with a member-set/hierarchy to Monthly level.

    I used the PerformancePoint Excel forms and a business rule to populate it with some data, then eagerly loaded PPS Designer to test out some charts and scorecards.

    I created the data source - first thing I noticed was there is no default Reader role, so I had to load SSAS and create a Reader role and assign 'Everybody' with access to the model/cube - which I called Scorecard. - is this normal, or should I set this role in the modeler somewhere?

     

    Now the really confusing thing was all the dimensions displayed for selection. Each dimension has a membername, memberid, memberdescription, then each memberset has a dimension, and the company (Entity) and Time dimensions have loads of extraneuos dimensions, and the hierarchies only use the LABEL texts, which is a pain if you used abbreviations or codes in the Labels and have used the Name and Description columns for the human-readable texts.

    Is there any way for me to hide all these extra dimensions so as to make the Designer options easier to navigate?

    Can I change the dimensions to use the descriptions instead of label names without screwing up the model?

    I am concerned that if I edit the cube in Visual studio, it will stop working with PPS Modeller.

    Wednesday, April 16, 2008 5:34 PM

Answers

All replies

  • Hi Mark,

     

    Please take a look into The Microsoft PerformancePoint Team Blog - Integrating M&A with Planning - Best Practices  http://blogs.msdn.com/performancepoint/archive/2007/07/02/integrating-m-a-with-planning-best-practices.aspx

     

     

    Can I change the dimensions to use the descriptions instead of label names without screwing up the model?

    I am concerned that if I edit the cube in Visual studio, it will stop working with PPS Modeller.

     

    Planning cube customization will be overwritten by Deploy Model process initiated from planning business modeler.

     

     

    Thank you,

    Sundar - MSFT

     

    Wednesday, April 16, 2008 7:13 PM
  • Thanks Sundar

     

    Yes..well the blog entry does provide a salutary warning that dashboards are locked into their original planning cubes data sources. But I want to know more about tailoring the excessive list of dimensions produced by planning. I know I can hide dimensions and members in SSAS, and tweak other stuff to make the presentation in Designer less confusing, but there is no point if as you say all changes get blitzed by the deploy process.

    I only need 4 dimensions to make my grids, scorecard KPI's and filters, but the planning cube gives me 45!!!

    I want the client's BI analysts to maintain and create charts & KPI's, so the cleaner the list of available items the better.

    Can I set somekind of property on each dimension to hide / Read by userid - like you can with the other objects in Designer.

     

    I suppose I could lock down the model and tweak the cube, but that would prevent additions to dimension members.

     

    Thursday, April 17, 2008 9:48 AM
  • I've decided to make a new organisation dimension instead of using the template Entity dimension in the model, then I can avoid unwanted member properties - and therefore avoid getting 'some' of the unwanted cube dimensions. I will also play around with member views to see if I can get better use of names and descriptions in hierarchy format for use in Designer..
    Thursday, April 17, 2008 2:14 PM
  • Well...would you believe it? - you can hide the unsightly dimensions, and they will survive re-deployment.

     

    The doco says.."When you deploy a model site for the first time, the data cube is created and populated based on any dimensions, member sets, models, or other elements that you have created and specified. To build the data cube, initial deployment requires more time than subsequent deployments, which update only the modified sections of the cube."

     

    soo..

    Using Visual Studio, I opened the analysis services cube from the server, then fiddled around with the Attribute properties in the Cube Structure, Dimension attribute properties, and set the AttributeHeirachyVisible to False on all the unwanted dimensions (which I am v.unlikely to modify anyway).

    I saved and reprocessed the cube, then checked in SSAS cube browser to make sure I could still browse the data and that the unwanted stuff was hidden. Then to check continuity, I opened PPS Planning Business Modeller and for the relevant application/model site I ran:

    Reprocess Model Data

    Deploy Model Site

     

    Next - re-connected and checked browser on the cube in SQLServer Analysis Services - and the hidden stuff was still hidden - which was nice..

    Next - opened Dashboard Designer - refreshed the cube data source - and it failed to connect. The Reader role had lost the permission setting to Read the cube. The role was still there, but Visual Studio must have slightly different expectations. So I enabled read permissions for the cube in Visual studio, saved, then re-ran everything.

    This time the Reader role survived.

    Next - opened Dashboard Designer again, check data source and Time dimension, all ok, published, then created a KPI and the Dimension list now only shows what I want it to show in the list.

     

    BTW. - I also tried denying permissions for Reader role for specific dimensions - but this went very wrong, so I left everything on default.

     

    The Modeller creates read-only Roles on the SSAS cube for each user registered in the model Business Roles. So I guess the proper thing to do is make sure one of the user accounts is used as the connection account which access the cube.

     

    Tuesday, April 22, 2008 5:22 PM
  • Mark,

     

    But what if in future the cube has an error and we are required to delete the cube completely and re-deploy the model from BPM. In this case, the structure of the cube (changes made in Visual Studio) gets reverted back to default structure and we lose these changes.

    Any idea how these changes can also be automated in a production environment?

    Friday, September 5, 2008 10:00 AM
  • I guess if you have to remake the cube, then you have to re-apply the modifications, just as if it were a brand new cube.

    There may be ways to script the hidden property settings, but if the dimensions change you would have to do it manually anyway...

     

    Friday, September 5, 2008 10:53 AM
  • Ok! Thanks Mark

    Thursday, September 11, 2008 8:01 AM