locked
state migration point drives problem RRS feed

  • Question

  • Hello,

    i have problem with creating state migration point on primary site.

    Problem is that folders only work IF is set to local hard drive.

    Additional or mapped network drive have erros: https://i.imgur.com/ooFPL1E.png

    d: is local disk
    m: is additional
    z: mapped network drive

    i was found resolution to check registry key for wrong folders, but that was not the case (http://ihateyou1603.blogspot.com/2010/05/state-migration-point-failing-to-start.html)

    what i can do next?

    thank you

    Wednesday, January 23, 2019 1:42 PM

All replies

  • What exactly is the M volume? A volume residing on a local physical disk?

    Mapped network drives can never work as mapped drives are a per-user construct and not global to the system in any way.

    If you want to use a volume on another system, make that system a site system and install the SMP there.


    Jason | https://home.configmgrftw.com | @jasonsandys

    Wednesday, January 23, 2019 2:40 PM
  • hi Jason, thank you on answer!
    well, M is other volume (partition) from local attached disk.

    Hm, i forget that part, u are right. But by which user sccm (SMP) should map that drive?

    I need to set that folder to be on network drive (need a lot of space).

    Wednesday, January 23, 2019 3:42 PM
  • Is M formatted with NTFS?

    But by which user sccm (SMP) should map that drive?

    None. It doesn't work that way and isn't meant to. Mapped drives are for users to use, not applications. (Note that technically, it may work if you map the drive as the local System account, but that's a really bad thing to do and wouldn't be supported.)

    I need to set that folder to be on network drive (need a lot of space).

    Then do as I suggested. Make the system hosting that space locally a site system with the SMP role. There's no reason that you have to install the role on your site server or an existing site system -- that doesn't make sense either (sorry, not trying to be mean, just trying to drive home the point that ConfigMgr is flexible).

    Alternatively, present that storage so that the system that you are installing the SMP on sees that storage as local storage. That can be done using NFS, iSCSI, or SMB Direct.


    Jason | https://home.configmgrftw.com | @jasonsandys

    Wednesday, January 23, 2019 3:51 PM
  • Is M formatted with NTFS? (yes)

    ok, i quit with mapped drive.

    Now i try to create folder with mlink and he created folder (sccm), but cannot set ACL on that new created folder: https://i.imgur.com/CIdJqZN.png

    Thursday, January 24, 2019 2:14 PM
  • I honestly don't know if symbolic links will work here either; however, the error in this snippet is "Access Denied". Does the local System account have full control on this folder?


    Jason | https://home.configmgrftw.com | @jasonsandys

    Thursday, January 24, 2019 3:26 PM
  • yes, he have, he created folder, so he have access to write, but seems that ACL issue is related to NTFS (symbolic link is to network share, which is on NAS-linux).

    But i give to him ntfs option on share, so that should be work...
    Is there other option to make that network share to be folder on C: ?

    Thursday, January 24, 2019 3:30 PM
  • Not the folder that ConfigMgr created, the d:\_usmt_ folder. Does the local SYSTEM account explicitlly have full control permissions on the folder and all child objects?

    > symbolic link is to network share, which is on NAS-linux

    This almost certainly won't work as this isn't an NTFS volume.

    And, as noted, symbolic links are special beasts to begin with and often cause issues if they are not accounted for by the product trying to use them.

    I understand that you have a space limitation and are trying to be creative to work-around it, but it's just not going to work with a non-local volume and won't be supported even if it somehow "seems" to work.

    Do you not have any other systems with drive space available?


    Jason | https://home.configmgrftw.com | @jasonsandys

    Thursday, January 24, 2019 4:10 PM