locked
Error: Service Check Data Source Module Failed Execution RRS feed

  • Question

  • I have just updated a few of the MP's from the versions that are packaged in SCE SP1 to the latest versions posted on Microsoft's website. Namely the Windows Client, Windows Servers, Windows IIS, SQL server, and the MPs listed in KB951979. This was done to resolve the Windows 2000 servers not getting reporting some data as the scripts are using WMI calls for properties that don't exist.

    Now I'm getting the above error on all my SQL 2005 Express Edition servers. The contents of the error is below.

    Error getting state of service Error: 0x8007007b Details: The filename, directory name, or volume label syntax is incorrect. One or more workflows were affected by this. Workflow name: Microsoft.SQLServer.2005.DBEngine.FullTextSearchServiceMonitor Instance name: BKUPEXEC Instance ID: {D2C4DB0E-A62D-0856-FB4F-A599A8AC04A5} Management group: SERVER_MG

    I'm getting this error on all 4 SQL 2005 Express Edition servers. This only starter after importing the new MP's. Also, if I am correct, SQL 2005 EE does not support Full-Text searching.

    How can I override this service check just for the affected servers?
    Friday, March 13, 2009 3:24 PM

Answers

  • Hi Hugh,

    Please try the following steps to disable this monitor:

    1. In SCE console, go to Authoring space.

    2. Expand "Management Pack Objects" - "Monitors" - "SQL 2005 DB Engine" - "Entity Health" - "Availability".

    3. Right click "SQL Server Full Text Search Service Monitor", choose "Overrides" - "Disable the Monitor" - "For all objects of type: SQL 2005 DB Engine"
    Monday, March 16, 2009 3:47 AM

All replies

  • Hi Hugh,

    Please try the following steps to disable this monitor:

    1. In SCE console, go to Authoring space.

    2. Expand "Management Pack Objects" - "Monitors" - "SQL 2005 DB Engine" - "Entity Health" - "Availability".

    3. Right click "SQL Server Full Text Search Service Monitor", choose "Overrides" - "Disable the Monitor" - "For all objects of type: SQL 2005 DB Engine"
    Monday, March 16, 2009 3:47 AM
  • Eric,

    I managed to disable the monitors for each individual instance that doesn't have Full Text Search enabled by overriding the monitor for each specific object. But my underlining question, is how comes the script is failing? Bad error handling in the code? It would appear the scripts are not tested very well before being put into production.

    Regards,
    Hugh
    Friday, March 20, 2009 3:09 PM
  • i overrode the monitor for all objects of type SQL 2005 DB Engine but i'm still getting this error.


    Error getting state of service


    Error: 0x8007007b

    Details: The filename, directory name, or volume label syntax is incorrect.



    One or more workflows were affected by this.


    Workflow name: Microsoft.SQLServer.2008.DBEngine.FullTextSearchServiceMonitor

    Instance name: MSSQLSERVER

    Instance ID: {2E0F01C1-9683-CE20-515F-825AD3B9EE5D}
    Wednesday, September 30, 2009 8:23 PM
  • That's easy, you disable the monitor for sql 2005.

    When you look to the Workflow name you can see it talks about SQL 2008.
    So you have to disable it for SQL 2008 DB Engine.

    Attention: only override it for the failing computers, not for all objects

    Wednesday, March 24, 2010 12:08 PM