locked
trouble changing column name used in calculated column RRS feed

  • Question

  • I have a calculated column in my list.  The calculation is based on a column "Status".  It worked fine.  But I recently had to do some work on the Status column and changed it to Status_OLD and replaced it with a new Status column.  The above mentioned calculated field is now using Status_OLD and thus not working because Status_OLD is no longer in use.  I went in the to calculation formula and tried to change it to Status, but Status does not appear in the Insert Column list, nor does it allow me to just type in Status into the formula without throwing an error.  Short of deleting the column and re-creating it, is there something I'm doing wrong or overlooking?

    There are no mistakes; every result tells you something of value about what you are trying to accomplish.

    Thursday, January 23, 2014 7:00 PM

Answers

  • I think I figured it out.  Status_OLD was a choice field (single choice).  The new Status field (I needed to change it to multi-select checkboxes) won't work in my calculated fields.  Is this by SP design, or is something wrong?

    There are no mistakes; every result tells you something of value about what you are trying to accomplish.

    • Marked as answer by run4it Friday, January 31, 2014 12:12 AM
    Thursday, January 30, 2014 6:29 PM

All replies

  • I went through your scenario in my dev environment and I am bit surprised that it did not show you the new Status column when you go to Calculated Column. 

    I was able to see the new Status column. Even if you rename your old column to Status_OLD its internal name still remains Status and hence your new Status column will be Status0 internally. You can try typing the internal name and see if it helps. In my environment it did not work but again I was able to see the new Status column. 


    Amit

    Thursday, January 23, 2014 8:03 PM
  • I could not see it, nor could I type it directly into the calculation  without throwing an error

    There are no mistakes; every result tells you something of value about what you are trying to accomplish.

    Thursday, January 23, 2014 8:15 PM
  • Hi run4it,

    I am trying to involve someone familiar with this topic to further look at this issue.

    Thanks,
    Daniel Yang
    Forum Support
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Daniel Yang
    TechNet Community Support

    Friday, January 24, 2014 8:24 AM
    Moderator
  • Hi run4it,

    when i tried, also result as the same with Amit V, i am able to change and add new column.

    if i may ask, can we have your steps also? who knows i miss some steps that could make different with your environment, and also, if should you have the formula so we can understand better.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, January 27, 2014 5:43 AM
  • Finally getting back to this issue.  I have two columns in my list "Status" and "Status_OLD".  "status" is a replacement for the previous one.  I have three calculated fields that use that field. I need to change their calculation to now use "Status" instead of "Status_OLD".  When I go to the settings for that column, "status" is not listed in the choice of columns that can be inserted.  Just typing it in won't work either.

    When I try to make a new cal as a test, "Status" isn't available there either.

    I really need to get this fixed as soon as possible now because some of these dates need to be acted upon.

     


    There are no mistakes; every result tells you something of value about what you are trying to accomplish.


    • Edited by run4it Thursday, January 30, 2014 12:24 AM
    Thursday, January 30, 2014 12:14 AM
  • Hi run4it,

    it makes me a little curious, because i cant reproduce the issue in my environment.

    when i create a new column, its always there, in the Insert Column box.

    perhaps i may need your suggestions how to re-produce it.

    for testing, please let me know if should the "allow management of content types" at the advance settings, in document library settings may help, if you select as YES.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, January 30, 2014 8:14 AM
  • I think I figured it out.  Status_OLD was a choice field (single choice).  The new Status field (I needed to change it to multi-select checkboxes) won't work in my calculated fields.  Is this by SP design, or is something wrong?

    There are no mistakes; every result tells you something of value about what you are trying to accomplish.

    • Marked as answer by run4it Friday, January 31, 2014 12:12 AM
    Thursday, January 30, 2014 6:29 PM