none
Cannot Enable Enterprise Mode of Internet Explorer 11 RRS feed

  • Question

  • Hi all,

    After installed Internet Explorer 11 on Windows 7 Professional (32-bit), I tried to enable the Enterprise Mode and failed by using Local Group Policy or Registry.

    When I started gpedit.msc after installed Internet Explorer 11, the following error message is prompted. After I click OK, the administrative template of Internet Explorer cannot be found.

    • Resource '$(string.Advanced_EnableSSL3Fallback)' referenced in attribute displayName could not be found.
    • File C:\Windows\PolicyDefinitions\inetres.admx, line 795, column 308

    I also tried to enable by modifying the registry (HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Main\EnterpriseMode). After modified, the EnterpriseMode still cannot be found under Tools tab.

    Any workaround, idea or resolution are welcome. Thank you !

    Regards,

    Tony


    • Edited by Tony Young 617 Wednesday, June 17, 2015 10:15 AM Better presentation
    Wednesday, June 17, 2015 10:10 AM

Answers

  • Hi Deason,

    Thanks for your reply! I've downloaded the template from (https://www.microsoft.com/en-hk/download/details.aspx?id=40905) and replaced the inetres.admx and inetres.adml in C:\windows\PolicyDefinitions. Then the gpedit.msc can be started without error. However, I still have some issue and cannot enable the Enterprise Mode.

    Issue: In gpedit.msc, after I configure Enabled in Let users turn on and use Enterprise Mode from the Tools menu, I start the Internet Explorer 11 and still cannot find the EnterpriseMode under Tools Menu.

    Also, I've tried again to enable Enterprise Mode by modifying registry, but still the same result.

    Any workaround, advice and option are welcome. Thanks a lot !

    Best regards,

    Tony




    This discussion may help:
    https://social.technet.microsoft.com/Forums/en-US/2fb656c3-8d0c-45f7-a363-6392674312df/ie11-enterprise-mode-xml-list?forum=ieitprocurrentver

    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Monday, June 22, 2015 10:12 PM

All replies

  • Hi,

    This error might occurs due to a inetres.admx error in template. So the template might be corrupted, please try to replace the C:\windows\PolicyDefinitions with a right copy from a clean Windows 7 Professional machine.

    Regards,

    D. Wu


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, June 22, 2015 1:52 AM
    Moderator
  • Hi Deason,

    Thanks for your reply! I've downloaded the template from (https://www.microsoft.com/en-hk/download/details.aspx?id=40905) and replaced the inetres.admx and inetres.adml in C:\windows\PolicyDefinitions. Then the gpedit.msc can be started without error. However, I still have some issue and cannot enable the Enterprise Mode.

    Issue: In gpedit.msc, after I configure Enabled in Let users turn on and use Enterprise Mode from the Tools menu, I start the Internet Explorer 11 and still cannot find the EnterpriseMode under Tools Menu.

    Also, I've tried again to enable Enterprise Mode by modifying registry, but still the same result.

    Any workaround, advice and option are welcome. Thanks a lot !

    Best regards,

    Tony



    Monday, June 22, 2015 3:54 PM
  • Hi Deason,

    Thanks for your reply! I've downloaded the template from (https://www.microsoft.com/en-hk/download/details.aspx?id=40905) and replaced the inetres.admx and inetres.adml in C:\windows\PolicyDefinitions. Then the gpedit.msc can be started without error. However, I still have some issue and cannot enable the Enterprise Mode.

    Issue: In gpedit.msc, after I configure Enabled in Let users turn on and use Enterprise Mode from the Tools menu, I start the Internet Explorer 11 and still cannot find the EnterpriseMode under Tools Menu.

    Also, I've tried again to enable Enterprise Mode by modifying registry, but still the same result.

    Any workaround, advice and option are welcome. Thanks a lot !

    Best regards,

    Tony




    This discussion may help:
    https://social.technet.microsoft.com/Forums/en-US/2fb656c3-8d0c-45f7-a363-6392674312df/ie11-enterprise-mode-xml-list?forum=ieitprocurrentver

    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Monday, June 22, 2015 10:12 PM
  • Hi Don,

    Thanks a lot for your help! With reference to your posted discussion, I apply patch 2929437 after installed Internet Explorer 11. After that, I can enable Enterprise Mode successfully by modifying registry.

    Regards,

    Tony

    Wednesday, June 24, 2015 3:25 PM