locked
How to get rid of the text (No Title) in a list where there is no data in that column? RRS feed

  • Question

  • We're using SharePoint 2007 Moss.  Thank you.

    Thank you

    Friday, April 13, 2012 9:34 PM

Answers

  • This is the default behavior in MOSS custom list items with empty titles (when the Title field is not required). Since the Title field is linked to the list forms it's best to use it in your list and not leave it empty. You should either make the Title field required or create a SPD workflow to populate the Title field with some value.

    MCPD, MCITP, MCTS

    • Marked as answer by laJasmine Tuesday, January 30, 2018 7:47 PM
    Saturday, April 14, 2012 3:50 AM
  • Hi,

    You may use content types, and then on the content type level, you can set the column to be hidden and in that way it won't show up in your forms and you can omit it from your views. Yet, if you still need it,  i think if you add a default value to your "title" column, it will work, or use a workflow on item added and update your title column.

    Cheers,

    • Marked as answer by laJasmine Tuesday, January 30, 2018 7:47 PM
    Saturday, April 14, 2012 8:08 PM
  • Hi laJasmine,

    The ootb Title field is used as a link to the context menu for the current item. It would be good if this link is having some informative data about the current list item. What you can try here is to use that ootb Title field for any other custom field that would have been added separately. 

    For Example: Consider a custom list (say Project List) containing 5 columns (Project Name, Project Manager, Department, Client, Contract Number). Then you can design you custom list so that the ootb Title field is used for the column "Project Name" and only 4 additional fields are added explicitly to the custom list. For this you need to override the display name of the ootb Title field. This can be done using List Definition / Content Types as follows :

    <Field ID="{fa564e0f-0c70-4ab9-b863-0177e6ddd247}" Type="Text" Name="Title" DisplayName="$Resources:YourResourceFile, ProjectName;" Required="TRUE" SourceID="http://schemas.microsoft.com/sharepoint/v3" StaticName="Title" FromBaseType="TRUE" Sealed="TRUE" ColName="nvarchar21" RowOrdinal="0" />

    <FieldRef ID="{fa564e0f-0c70-4ab9-b863-0177e6ddd247}" Name="Title" DisplayName="$Resources:YourResourceFile, ProjectName;" Required="TRUE" />

    The Guid {fa564e0f-0c70-4ab9-b863-0177e6ddd247} is the Id of the ootb Title field and it always remains the same.
    Hope this helps.

    Best Regards,
    Devang Bhavsar

    PS: You can use the ootb Title field interchangeably for any other custom column to be used in your custom list.


    • Edited by Devang Bhavsar Sunday, April 15, 2012 8:04 AM spell check
    • Marked as answer by Jack-GaoModerator Friday, April 27, 2012 9:57 AM
    • Unmarked as answer by laJasmine Tuesday, January 30, 2018 7:46 PM
    • Marked as answer by laJasmine Tuesday, January 30, 2018 7:47 PM
    Sunday, April 15, 2012 7:43 AM
  • Of course it's the answer. Change the field in the view to "title" and if it's empty (no title) doesn't show up. I thought I made that clear above, but I guess not.

    • Edited by webbrewer Thursday, July 21, 2016 1:59 AM
    • Marked as answer by laJasmine Tuesday, January 30, 2018 7:46 PM
    Thursday, July 21, 2016 1:56 AM

All replies

  • Hi,

    Could you please explain a bit more on this? What do you mean by "How to get rid of the text (No Title)"? Can you not edit the list item and change the value/data in that column?


    Pman
    http://www.pmansLab.com/

    Saturday, April 14, 2012 3:05 AM
  • This is the default behavior in MOSS custom list items with empty titles (when the Title field is not required). Since the Title field is linked to the list forms it's best to use it in your list and not leave it empty. You should either make the Title field required or create a SPD workflow to populate the Title field with some value.

    MCPD, MCITP, MCTS

    • Marked as answer by laJasmine Tuesday, January 30, 2018 7:47 PM
    Saturday, April 14, 2012 3:50 AM
  • Hi,

    You may use content types, and then on the content type level, you can set the column to be hidden and in that way it won't show up in your forms and you can omit it from your views. Yet, if you still need it,  i think if you add a default value to your "title" column, it will work, or use a workflow on item added and update your title column.

    Cheers,

    • Marked as answer by laJasmine Tuesday, January 30, 2018 7:47 PM
    Saturday, April 14, 2012 8:08 PM
  • Hi laJasmine,

    The ootb Title field is used as a link to the context menu for the current item. It would be good if this link is having some informative data about the current list item. What you can try here is to use that ootb Title field for any other custom field that would have been added separately. 

    For Example: Consider a custom list (say Project List) containing 5 columns (Project Name, Project Manager, Department, Client, Contract Number). Then you can design you custom list so that the ootb Title field is used for the column "Project Name" and only 4 additional fields are added explicitly to the custom list. For this you need to override the display name of the ootb Title field. This can be done using List Definition / Content Types as follows :

    <Field ID="{fa564e0f-0c70-4ab9-b863-0177e6ddd247}" Type="Text" Name="Title" DisplayName="$Resources:YourResourceFile, ProjectName;" Required="TRUE" SourceID="http://schemas.microsoft.com/sharepoint/v3" StaticName="Title" FromBaseType="TRUE" Sealed="TRUE" ColName="nvarchar21" RowOrdinal="0" />

    <FieldRef ID="{fa564e0f-0c70-4ab9-b863-0177e6ddd247}" Name="Title" DisplayName="$Resources:YourResourceFile, ProjectName;" Required="TRUE" />

    The Guid {fa564e0f-0c70-4ab9-b863-0177e6ddd247} is the Id of the ootb Title field and it always remains the same.
    Hope this helps.

    Best Regards,
    Devang Bhavsar

    PS: You can use the ootb Title field interchangeably for any other custom column to be used in your custom list.


    • Edited by Devang Bhavsar Sunday, April 15, 2012 8:04 AM spell check
    • Marked as answer by Jack-GaoModerator Friday, April 27, 2012 9:57 AM
    • Unmarked as answer by laJasmine Tuesday, January 30, 2018 7:46 PM
    • Marked as answer by laJasmine Tuesday, January 30, 2018 7:47 PM
    Sunday, April 15, 2012 7:43 AM
  • 4 years late with the simple answer: remove the "linked" field from the view and use "for use in forms". If empty it will then appear as empty.
    Monday, May 9, 2016 6:51 PM
  • This is not the answer.  Please read the question.  This is information about the Title field, but does not at all explain how to get rid of or change the default text added when the field is left empty.
    Wednesday, July 20, 2016 9:54 PM
  • Of course it's the answer. Change the field in the view to "title" and if it's empty (no title) doesn't show up. I thought I made that clear above, but I guess not.

    • Edited by webbrewer Thursday, July 21, 2016 1:59 AM
    • Marked as answer by laJasmine Tuesday, January 30, 2018 7:46 PM
    Thursday, July 21, 2016 1:56 AM
  • This is what I want to do but the instructions aren't clear.  What do you mean change the field in view to "title".  It is the title column already.

    ShaunP

    Tuesday, January 30, 2018 7:20 PM
  • There are 3 flavors of the title column in the view settings. Select "title" not "title linked to...."

    Go to the list settings > views > select any view

    (I couldn't reply under original profile name because Msft's account verification process is completely broken)

    Wednesday, January 31, 2018 1:56 AM