locked
Font on app + is bold or italic RRS feed

  • Question

  • For some reason my W7 change some fonts to bold or  italic  on programs ( FF, skype Video pl. and more even on some gadgets )

    I think it's from game L4D ( when i uninstalled there were some fonts in one folder ) but i am not sure.

    Any help how to restore default ?
    Saturday, January 23, 2010 2:50 PM

Answers

  • I just replace "reinstall" all fonts from new installed W7 on other pc.  And every program is now ok :) that was easy more easy that to write this post.
    • Marked as answer by Bazikcho Sunday, January 31, 2010 6:00 PM
    Sunday, January 31, 2010 5:59 PM

All replies

  • Selecting a theme, e.g., Windows 7 Aero, should do it.

    1.  Right click on the desktop.
    2.  Choose Personalize.
    3.  Click on a theme, e.g., Windows 7 under Aero Themes.

    If this still does not change the fonts to be the way you like them:

    1.  Right click on the desktop.
    2.  Choose Personalize.
    3.  Click on the Window Color icon near the bottom. 
    4.  If you see a palette of color choices, click the Advanced appearance settings... link near the bottom.
    5.  The Window Color and Appearance dialog should appear.
    6.  Click the arrow in the Item: field and choose each item such as Active Title Bar that has a font associated. 
    7.  You will see the font being used in the Font: field.  The default font for all the items with a font associated is Segoe UI.

    Hope this helps.

    -Noel
    • Proposed as answer by Noel Carboni Saturday, January 23, 2010 11:06 PM
    • Marked as answer by Linda Yan Monday, January 25, 2010 7:41 AM
    • Edited by Noel Carboni Monday, January 25, 2010 12:12 PM
    • Unmarked as answer by Bazikcho Tuesday, January 26, 2010 1:19 PM
    Saturday, January 23, 2010 11:05 PM
  • Modify Noel's suggestion, the font setting should be under Personalize -> Windows Color -> Advanced appearance settings...  ;-)

    If the issue persists after changing the appearance settings, could you please let us know when the issue first occurred? Did it occur after installing some software?

    Also, access Clean Boot to check the issue. If the issue disappears in the Clean Boot environment, we continue to narrow down which entry is causing the issue.

     

     

    Monday, January 25, 2010 7:40 AM
  • Thanks.  Indeed, I missed a step in the general case where Aero is enabled; thanks for pointing that out.  I've edited the procedure above.

    I tested while accessing the Windows 7 desktop with Aero turned off, and in that case the Window Color link brings up the (advanced) Window Color and Appearance dialog directly.

    -Noel
    Monday, January 25, 2010 12:10 PM
  • I try with change themes with Windows 7 Aero and without, "Clean Boot" also. Not any change on fonts on programs. Windows of  windows are fine more of other program windows are fine to, Firefox fonts on forums is "Bold" (even when i write this on gmail are not ), some menus of skype are italic, not window titles inside of program. 

    I think the problem is from some font who used some programs  and one gadget :)   How to reinstall default fonts or how to remove bold & italic  from them ?


    Linda Yan i write in first post when problem start, i think i am not  installing some software after that. Only L4D2 but the problem was before that.
    Tuesday, January 26, 2010 1:19 PM
  • Hi Bazikcho,

     

    According to your description, this issue should be related to the application settings.

     

    Please open Firefox and see if there is any setting to change the font and color. Also, check the box for "allow page to use own font". If the issue persists, please install the latest version of Firefox and see if the issue can be resolved. For more information, please refer to: Firefox Support Forum.

     

    Once the issue in Firefox is resolved, please check similar settings in Skype.

     

    Also, you can contact the software support directly for assistance.

     

    Regards,

    Linda

     

    Wednesday, January 27, 2010 2:17 AM
  • I am  sure that problem is not from firefox, I use FF from 6 years and don't have problems like this.

     Do you see in this pic bold font ?
    http://uploadpic.org/showpic-42440/firefoxfont.jpg

    In skype menus where font is italic are also  not changeable, the place where write for chat font is changed and there is no problem.


    Why not answer me for this or it's not possible  ? "How to reinstall default fonts or how to remove bold & italic  from them ?"
    Wednesday, January 27, 2010 11:57 AM
  • Hi Bazikcho,

    I should have asked you to upload a screenshot before.  Is it possible you have a problem with font smoothing being enabled?

    Font smoothing paints around the edges of fonts in order to make them appear less "jaggy" and look more smooth on the screen.  For some people with some monitors this makes all the text look and feel better, but for others it can look excessively heavy or fuzzy and they don't like it.

    The good news is that font smoothing can be tuned, or even disabled entirely.

    To tune font smoothing with Clear Type:

    1.  Click the Start orb, and type in the word font.
    2.  When Manage Clear Type appears, click it.

    With this function you can adjust how font smoothing is applied to your fonts.

    There is also a setting for disabling all font smoothing entirely in one step:

    1.  Click the Start orb, and type in the word advanced.
    2.  When View advanced system settings appears, click it.
    3.  In the Performance section, click the [ Settings...] button.
    4.  Uncheck or check Smooth edges of screen fonts.


    However, if font smoothing is not the problem, and as you say one or more of your computer's fonts have been actually overwritten by a poorly behaved application / game, the way to restore the system default fonts is to either copy them manually from a good copy of Windows 7 or to do an "in place upgrade", which is basically a reinstall of the system from your Windows CD without wiping out your settings.  The names of the fonts being used to display various portions of your Windows dialogs are listed in the configuration dialog I noted in my first response above.

    -Noel
    Wednesday, January 27, 2010 1:15 PM
  • I use Clear Type ( LCD need it )  it turn  one of these two all fonts go to worse.  I will try with replace or Windows cd.
    Wednesday, January 27, 2010 9:14 PM
  • I just replace "reinstall" all fonts from new installed W7 on other pc.  And every program is now ok :) that was easy more easy that to write this post.
    • Marked as answer by Bazikcho Sunday, January 31, 2010 6:00 PM
    Sunday, January 31, 2010 5:59 PM