locked
error with Search-CsClsLogging RRS feed

  • Question

  • Hi guys 

    When issuing search-csclslogging I receive the below error

    Search-CsClsLogging -Computers pcname -OutputFilePath C:\1.txt
    Search-CsClsLogging : User ..... is not authorized to view or change logging OR this pool and computers are not valid. Pools or Computers - pcname 
    At line:1 char:1
    + Search-CsClsLogging -Computers pcname  -OutputFilePath C:\1.txt
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Search-CsClsLogging], Argumen
       tException
        + FullyQualifiedErrorId : System.ArgumentException,Microsoft.Rtc.Managemen
       t.Cls.SearchOcsLoggingCmdlet

    Anyone knows why?

    Monday, July 3, 2017 1:50 PM

All replies

  • Hi Ion Vlad Orascu,

    Are there any event IDs in SFB server application log ?

    Please also check that the directory C:\LogFiles exists and that you have permissions to Read and Write (NTFS permission Modify) files in the folder. The output is appended to and is not overwritten. If you need separate files, define a distinct file name for each search.

    Moreover, I have seen the similar case with the same error message, the issue resolved by installing the latest update, so we suggest you install the latest update for your SFB server then test again.

    Here is a document for your reference
    https://technet.microsoft.com/en-us/library/jj687982.aspx


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, July 5, 2017 9:01 AM
  • Are you running the SfB management shell with "Admin permission"


    http://thamaraw.com

    Thursday, July 6, 2017 1:16 AM
  • Hello Alice

    I ran Get-CsAdminRole | Where-Object {$_.Cmdlets -match "Set-CsClsConfiguration"} to see what is required

    It says I should be part of CSAdministrator and CSServerAdministrator, Which I am.

    There is no C:\LogFiles, the command stops at "is not authorized to view or change logg...."

    I am running as Admin

    Thursday, July 6, 2017 6:39 AM
  • I meant, right click and open sfb management shell as admin

    http://thamaraw.com

    Thursday, July 6, 2017 7:02 AM
  • Hello Thamara 

    I understood, the shell is running as Administrator, right click and opened sfb management shell as admin

    Thursday, July 6, 2017 8:25 AM
  • First please check that PCName is acutally machine FQDN. 

    Next with Windows 7 and higher, access to the drive root is typically prevented by UAC, which CLS logging may not show. Try writing to C:\Windows\Temp\1.txt

    Saturday, July 8, 2017 5:08 AM
  • Hello

    I have noticed one thing.

    If I run the search 

    Start-CsClsLogging -scenario meetingjoin -Pools server.domain.com -Duration 00:01 it works

    if however I try to add -computer it gives me that error .... "is not authorized to view or change logging OR this pool and computers are not valid".

    The computername contains fqdn

    Tuesday, July 11, 2017 6:47 PM
  • Do you check your permission?
    Tuesday, July 25, 2017 6:44 AM
  • Hi

    Check if you have an extra Space character somewhere, i had the same problem ended up being a Space too much.

    Also, try with brackets " or '

    br

    Steffen

    Monday, December 18, 2017 10:03 AM