none
FIM Error 25009 Compatibility Level Database RRS feed

  • Question

  • Hello,

    We have an issue while trying to install FIM 2010 4.0.2592 about the database compatibility (error 25009).

    We need to install this specific version because we have to duplicate our production environment which is this version.

    When the installer is setting up the database, a popup appeared with the error 25009 about the compatibility level which need to be between 100 to 130. But our FIM database is already under compatibility level 100. The SQL Server is under 2016 SP2 (KB4052908) 13.0.5026.

    FIM 2010 is incompatible with SQL Server 2016 even if the compatibility level is modified or it is a generic error maybe?

    Thanks for you help !

    Monday, July 23, 2018 9:21 AM

Answers

All replies

  • Hi Steve-

    SQL Server 2016 support definitely didn't exist when that build was released so it's likely you're going to run into problems. 


    Thanks,
    Brian

    Consulting | Blog | AD Book

    Monday, July 23, 2018 11:10 PM
    Moderator
  • Hello Brian,
    Thank you, that was what I was thinking about ... I was hoping modifying the compatibility level would be enough but it seems not for this build(fyi, with 2010R2 its working but it's too far enough from our production :()

    Tuesday, July 24, 2018 7:40 AM