none
SBS2003: OWA suddenly giving 404 errors after login.

    Question

  • SBS2003 premium, been working fine for years, no recent changes made.  Suddenly, for all users, OWA will display the login page, but will give a 404 error after login details are entered.  Have tried 2 existing users and a brand new user, locally on the server, from outside the network, and from another internal machine, all give the same error.  Excerpt from the IIS logs below.

    2012-05-17 23:33:04 W3SVC1 127.0.0.1 GET /exchange/ - 443 - 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.2;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+.NET+CLR+3.0.04506.648;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+.NET4.0C;+.NET4.0E) 401 2 2148074254 353 546
    2012-05-17 23:33:04 W3SVC1 127.0.0.1 GET /exchweb/bin/auth/owalogon.asp url=https://localhost/exchange/eurl.axd/68764a94bb74c54c97e70afcd6bb87f6/&reason=0 443 - 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.2;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+.NET+CLR+3.0.04506.648;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+.NET4.0C;+.NET4.0E) 200 0 0 12982 649
    2012-05-17 23:33:08 W3SVC1 127.0.0.1 POST /exchweb/bin/auth/owaauth.dll - 443 - 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.2;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+.NET+CLR+3.0.04506.648;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+.NET4.0C;+.NET4.0E) 302 0 0 458 976
    2012-05-17 23:33:08 W3SVC1 127.0.0.1 GET /exchange/ - 443 peter 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.2;+Trident/4.0;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+.NET+CLR+3.0.04506.648;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+.NET4.0C;+.NET4.0E) 404 0 0 1883 875

    I've tried : removing the virtual directories and the ds2mb, and having them recreated by restarting the Exchange SA, as per the KB article.  I've confirmed all authentication and SSL settings are as they should be, on all Exchange virtual directories.  I've confirmed activesync is working, it's only OWA that's misbehaving.  I've confirmed NTFS permissions on the appropriate folders are set to give Authenticated users read/list/execute, and system has Full Control.  I've compared the settings and permissions to other working servers, and can't see any differences, other than the problem server using asp.net 4 for the exchange virtual directories.  The setting is greyed out, so I cannot change it to test if it's part of the problem.

    Would appreciate any insight, client is out of town and trying to use web access, and grumpy.


    Nigel Benfell B.Sc. MCSA

    Thursday, May 17, 2012 11:48 PM

Answers

  •  I've compared the settings and permissions to other working servers, and can't see any differences, other than the problem server using asp.net 4 for the exchange virtual directories.  The setting is greyed out, so I cannot change it to test if it's part of the problem.

    Would appreciate any insight, client is out of town and trying to use web access, and grumpy.


    Nigel Benfell B.Sc. MCSA

    Hi,
    The Exchange virtualdirectory will inherit the ASP.net setting that the Default Web Site has (or whatever it's called in SBS)
    Have you tried changing it there?




    Martina Miskovic

    Friday, May 18, 2012 4:43 AM

All replies

  • Check your Microsoft Exchange Form Based Authenitcation service is in running state..May what version of exchnage server are you using it...Check any updates have got downloaded in the server and it has installed...since recently MS launched few updates on the same...

    Exchange Queries

    Friday, May 18, 2012 4:28 AM
  •  I've compared the settings and permissions to other working servers, and can't see any differences, other than the problem server using asp.net 4 for the exchange virtual directories.  The setting is greyed out, so I cannot change it to test if it's part of the problem.

    Would appreciate any insight, client is out of town and trying to use web access, and grumpy.


    Nigel Benfell B.Sc. MCSA

    Hi,
    The Exchange virtualdirectory will inherit the ASP.net setting that the Default Web Site has (or whatever it's called in SBS)
    Have you tried changing it there?




    Martina Miskovic

    Friday, May 18, 2012 4:43 AM
  • Thanks Martina, that was what I was missing, set it back to 2.0 (was trying to use 4.0), and now it's working happily.  Now I can enjoy my weekend without worrying about this :)

    Nigel Benfell B.Sc. MCSA

    Friday, May 18, 2012 5:25 AM
  • Actually for SBS 2003 it should be 1.1 I believe.
    If you find issues with the .net 2...set it back to 1.1

    --
    Cris Hanna [SBS - MVP] (since 1997)
    Co-Contributor, Windows Small Business Server 2008 Unleashed
    http://www.amazon.com/Windows-Small-Business-Server-Unleashed/dp/0672329573/ref=pd_bbs_sr_1?ie=UTF8&s=books&qid=1217269967&sr=8-1
    Owner, CPU Services, Belleville, IL
    A Microsoft Registered Partner
    ------------------------------------
    MVPs do not work for Microsoft
    Please do not submit questions directly to me.
     
     
    Thanks Martina, that was what I was missing, set it back to 2.0 (was trying to use 4.0), and now it's working happily.  Now I can enjoy my weekend without worrying about this :)

    Nigel Benfell B.Sc. MCSA


    Cris Hanna, Microsoft SBS MVP, Owner-CPU Services, Belleville, IL
    Friday, May 18, 2012 2:44 PM
    Moderator