locked
WSUS updates not downloading after standalone server import RRS feed

  • Question

  • I have one online WSUS server and one offline WSUS Server. I exported the updates from the online server with the following:

    WsusUtil.exe export export.xml.gz export.log

    (I tried to do export.cab, but it said the export was too large)

    I then moved over to the offline server and copied the new WsusContent into the WSUS folder on the offline server. The WsusContent folders merged. I moved the export.xml.gz and export.log files over to the C:\Program Files\Update Services\Tools location. I then executed this:

    WsusUtil.exe import export.xml.gz import.log

    It looks like the import worked correctly as a bunch of updates were added in my WSUS GUI on the offline server. I have Approved all of them. My problem is that the download status is showing:

    Updates needing files: 1,200

    Downloaded: 103.6 MB of 405,611 MB

    How do I get these files downloaded when it is an offline WSUS Server?


    JT


    • Edited by Jtkeeper Thursday, November 9, 2017 8:05 PM
    Thursday, November 9, 2017 8:04 PM

All replies

  • Hello,

    What is your WSUS version? It seems like when you try to export files, there is limitation. I suggest you go through the article below regarding to this issue:


    https://blogs.technet.microsoft.com/wsus/2013/04/09/problem-solved-the-wsus-export-bug/

    If you are running .NET 4.0, there should be no limitation for gzipstream. 

    Please make sure proper hotfix is installed:


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 10, 2017 6:36 AM
  • WSUS version is 6.3.9600.16384

    I do have .NET 4.0 running


    JT

    Friday, November 10, 2017 9:38 PM
  • Then do you have KB2819484 installed on your server?

    Regards,

    Yan


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 13, 2017 1:37 AM
  • Yan,

    It appears KB2819484 is for Windows Server 2012. I am running Windows Server 2012 R2


    JT

    Monday, November 13, 2017 3:46 PM
  • Hello,

    The online WSUS server is running on Windows Server 2012? 

    Did you see the below error message:

    "Export failed to export updates. Please look at the log file for error details. Fatal Error: The gzip stream can't contain more than 4GB data."

    If you saw above error message, we have a following workaround for this issue:

    1. Run "WSUS server clean up wizard" which can help in bringing the size less than 4GB.

    2. You can move to WSUS server on 2012 which uses .NET 4 by default.

    3. Only follow the below plan if clean up doesn't help and you will not be able to move to WSUS on 2012.

    ==========

    ==> Install .Net 4 on the WSUS server from http://www.microsoft.com/en-us/download/details.aspx?id=17851

    ==> Create a file named wsusutil.exe.config under "C:\Program Files\Update Services\Tools" folder.

    ==> Copy the following code in to the file

    ********

    <configuration>
       <startup>
          <supportedRuntime version="v4.0.30319"/>
       </startup>
    </configuration>

    ********

    ==> Run the export and it will complete even if the size is bigger than 4GB.

    ==> Once the export is done, remove the wsusutil.exe.config file. 


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, November 14, 2017 7:28 AM
  • Both the online and the offline WSUS Servers are running Windows Server 2012 R2.

    I do not receive that error message or any error message. I have previously tried what you suggested with no improvement. When I perform the import command on the offline WSUS Server, the import is completed with no errors.

    When I look at the updates in WSUS, it looks like all of the new updates are listed. I have approved all of them, but next to each one it says,"This update still needs to be downloaded".

    So after the import, the updates just aren't getting downloaded/validated in WSUS.


    JT

    Tuesday, November 14, 2017 3:55 PM
  • I've been following this thread since the start but refrained from posting since I wanted to see what the others thought.

    I doubt this will fix your issue, but it may be worth a try. Try running my script on both servers and before the export on the upstream server. Worst case - you have faster, leaner, and optimized upstream and downstream servers... Best case - it fixes your issues (it's known to fix weird issues)

    Have a peek at my Adamj Clean-WSUS script. It is the last WSUS Script you will ever need!

    http://community.spiceworks.com/scripts/show/2998-adamj-clean-wsus

    What it does:

    1. Add WSUS Index Optimization to the database to increase the speed of many database operations in WSUS by approximately 1000-1500 times faster.
    2. Remove all Drivers from the WSUS Database (Default; Optional).
    3. Shrink your WSUSContent folder's size by declining multiple types of updates including by default any superseded updates, preview updates, expired updates, Itanium updates, and beta updates. Optional extras: Language Packs, IE7, IE8, IE9, IE10, Embedded, NonEnglishUpdates, ComputerUpdates32bit, WinXP.
    4. Remove declined updates from the WSUS Database.
    5. Clean out all the synchronization logs that have built up over time (configurable, with the default keeping the last 14 days of logs).
    6. Compress Update Revisions.
    7. Remove Obsolete Updates.
    8. Computer Object Cleanup (configurable, with the default of deleting computer objects that have not synced within 30 days).
    9. Application Pool Memory Configuration to display the current private memory limit and easily set it to any configurable amount including 0 for unlimited. This is a manual execution only.
    10. Checks to see if you have a dirty database, and if you do, fixes it. This is primarily for Server 2012 WSUS, and is a manual execution only.
    11. Run the Recommended SQL database Maintenance script on the actual SQL database.
    12. Run the Server Cleanup Wizard.

    It will email the report out to you or save it to a file, or both.

    Although the script is lengthy, it has been made to be super easy to setup and use so don't over think it. There are some prerequisites and instructions at the top of the script. After installing the prerequisites and configuring the variables for your environment (email settings only if you are accepting all the defaults), simply run:

    .\Clean-WSUS.ps1 -FirstRun

    If you wish to view or increase the Application Pool Memory Configuration, or run the Dirty Database Check, you must run it with the required switch. See Get-Help .\Clean-WSUS.ps1 -Examples

    If you're having trouble, there's also a -HelpMe option that will create a log so you can send it to me for support.


    Adam Marshall, MCSE: Security
    http://www.adamj.org

    Wednesday, November 15, 2017 1:26 AM