none
How to set 10 Home for WSUS? 7 Home, 8.1 Core are good.

    Question

  • How can we configure Windows 10 Home to use our WSUS ver 3.2.7600.274, which runs on Windows 2008R2 on our Domain?

    10 Pro is using WSUS fine. And we set all 7 Home & 8.1 Core laptops to use WSUS, with the WSUS Workgroup Client Setting Manager v1.1 tool (wsusworkgroup.codeplex.com); it seems to set the same keys:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]
    "WUServer"="http://<WSUSserver>"
    "WUStatusServer"="http://<WSUSserver>"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
    "UseWUServer"=dword:00000001

    But 10 Home seems to ignore them. The WSUS server shows no connection by the 10 Home machine since its upgrade from 8.1; the server still shows it as 8.1.

    We have very limited Internet bandwidth so it's a critical bandwidth saving for us ongoing. (we are a non-profit in a remote "third world" location). We have stopped 10 Home upgrades for now.

    Here's another post, same issue
    http://www.tenforums.com/windows-updates-activation/10932-windows-10-home-not-connecting-intranet-wsus.htm

    Thank you
    Chris

    Thursday, August 20, 2015 11:52 PM

All replies

  • not sure about this, I haven't tried it. I would think if you purge out the custom registry keys and instead configure it via gpedit.msc, then reboot, it should show up in WSUS console after a few hours
    Monday, August 24, 2015 7:36 PM
  • oops, my "Here's another post, same issue" link dropped the last letter, its  .html

    http://www.tenforums.com/windows-updates-activation/10932-windows-10-home-not-connecting-intranet-wsus.html     It's other users reporting the same problem.

    armin19, "I would think if you purge out the custom registry keys and instead configure it via gpedit.msc..."

    After the upgrade to 10 Home and no WSUS the owner did a clean install, same. I don't currently have access to that laptop, but I understand Home doesn't have gpedit.msc. (I believe there was a workaround to add it to 7 Home, dont know about 8.1. Neither needed gpedit.msc for WSUS to work). 

    Everyone here brings a laptop and most are Home, we have a ton of them. Non-profit, remote location, low bandwidth .. This is a hot issue for us.

    Thanks

    Chris


    • Edited by chris733 Monday, August 24, 2015 10:00 PM
    Monday, August 24, 2015 9:58 PM
  • Hi Chris,

    I test it in my lab and get the same result with you.

    According to the Windowsupdate.log, Windows 10 home edition doesn't read the registry settings of WSUS.

    Unfortunately, I can't find any official document about how to configure WSUS on Windows 10 home edition.

    Best Regards.


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, August 25, 2015 2:02 AM
    Moderator
  • I guess since they don't let you join a domain they don't let you access any domain resources either.

    what if you do something crazy like using the hosts file to redirect the windows update paths to the WSUS server instead of the default Microsoft update servers?

    I'm now curious if the Windows 10 product option in WSUS will even have patches which will distribute to the home edition version of the OS.  it might be worth finding that out first rather than wasting your time getting them to talk to each other

    Tuesday, August 25, 2015 12:52 PM
  • Microsoft have said that you cannot connect Windows 10 Home to a WSUS server. Windows 10 is Windows-as-a-service and the updates are frequent and often to reflect that it will be constantly upgraded.

    If you want control over updates you need to buy the Pro version.

    Tuesday, August 25, 2015 4:13 PM
  • Hello Chris

    I understand your problem entirely. Unfortunately, it sounds as if Microsoft doesn't know or doesn't care that a number of organisations use WSUS to update computers, including Home versions, just so that they can save bandwidth but also so they can control the updates - because there has never been an update that has caused a problem, has there?

    From what I can see, Windows 10 Home does not honour the WSUS registry settings but Microsoft does have a strategy that might/should work.

    Start/Settings/Update&Security/Advanced Options/Choose How Updates Are Delivered.

    Leave the first switch set to ON and select the option for "Get updates from Microsoft, and get updates from and send  updates to" to be "PCs on my local network".  

    This way, the first computer to check for and download updates *should* provide the updates to the other computers on your network.  Of course, if they're all turned on at the same time, they may all try to access Microsoft at once but maybe you can designate one the 'downloader', leave it on all the time and hope that it does the majority of downloading.

    I guess Microsoft expects that Home users might have multiple devices on their networks and they want to lighten the load on their update servers by letting them act as kind of 'mutual wsus servers'.  That's quite reasonable.  It's *unreasonable* of Microsoft to prevent users from configuring things they way they want to, especially since it means that Microsoft is removing something that has been used for quite some time.  It's also unreasonable for Microsoft to enable downloads from "PCs on the Internet".  Imagine what would happen if someone starting poisoning updates?

    Hope this helps.

    Regards

    DAS

    Tuesday, August 25, 2015 11:44 PM
  • DAS,  

    Yes. The primary matter is our low bandwidth. It is Very expensive out here.

    (controlling Updates is also a concern, we wait for Susan Bradley MVP of Windows Secrets to OK updates before we approve them.)

    Our end users - unpaid long-term volunteers - dont pay for the bandwidth taken by eg Home WAN updating from their personal laptop, but they do have to pay the extra for Pro. Few do. I cant see this changing.

    WUDO. Of our two (so far) Win10 PCs, both have WUDO on for LAN only (as you describe), the Pro is fully patched, the Home was missing 3081444. So Im waiting to see that the Home updated, and hopefully its windowsupdate.log will tell me that it did so over the LAN. Im expecting to get my hands on that Home laptop end of today.

    We dont know how WUDO on LAN works exactly: https://answers.microsoft.com/en-us/windows/forum/windows_10-networking/windows-update-delivery-optimization/7a0107be-7a49-48fc-8d14-5c75d9ee7ea2?auth=1

    Im looking to read wonderfull reports of WUDO LAN-only working well out there in the world. I'm not finding this so far; still early days? Does it work?

    Thanks

    Chris


    • Edited by chris733 Wednesday, August 26, 2015 11:35 PM
    Wednesday, August 26, 2015 11:33 PM
  • Watched the 10 Home update, with its WUDO set to Lan-only, and with a 10 Pro on the LAN (in fact, in my office on the same LAN switch) with its WUDO set to LAN-only, & with updates already installed that the Home didnt have.

    It installed approx 40 updates. Burnt up lots of internet bandwidth. Lots of Office 2007 ones that the Pro didnt have. (WSUS has all of them, FFS). Not impressed with WUDO so far, though its hard to tell:

    WindowsUpdate.log of the Home:

    lots of older entries mentioning BITS, no mention of P2P (presumably WUDO) till after WUDO set to on-for-LAN today (it was actually turned off), then its both P2P & BITS entries.

    here's one job in it, B6BBA68F-0B0A-460D-A445-F04ACDBD72F2

    2015/08/27 16:24:47.1554060 732   7788  DownloadManager P2P job initialized, JobId = {B6BBA68F-0B0A-460D-A445-F04ACDBD72F2}           (first mention)
    2015/08/27 16:24:47.1558497 732   7788  DownloadManager Downloading from http://fg.v4.download.windowsupdate.com/msdownload/update/software/secu/2011/03/vcredist_x86_f5420aa2ac335ce211623a1aa8e16fcf547cfe9a.exe to C:\WINDOWS\SoftwareDistribution\Download\cbcd333529a22e15d8360316385964f8\f5420aa2ac335ce211623a1aa8e16fcf547cfe9a (full file)
    2015/08/27 16:24:47.1599281 732   7788  DownloadManager Proxy settings for P2P job B6BBA68F-0B0A-460D-A445-F04ACDBD72F2 will not be overridden. [Proxy resolution returned 0]
    2015/08/27 16:24:47.1636576 732   7788  DownloadManager CUpdateDownloadJob::GetNetworkCostSwitch() Neither unrestricted or restricted network cost used, so using current cost
    2015/08/27 16:24:47.1660369 732   7788  DownloadManager * END * Begin Downloading Updates CallerId = UpdateOrchestrator
    2015/08/27 16:24:47.1678774 732   7204  ComApi          *QUEUED* Download ClientId = UpdateOrchestrator
    2015/08/27 16:24:47.1680234 732   7204  ComApi          * START *   Download ClientId = UpdateOrchestrator
    2015/08/27 16:24:47.1680238 732   7204  ComApi          Flags: 0X10008; Download priority: 3; Network Cost Policy: 0
    2015/08/27 16:24:47.1680238 732   7204  ComApi          Updates in request: 1
    2015/08/27 16:24:47.1680308 732   7204  ComApi          ServiceID = {7971F918-A847-4430-9279-4A52D1EFE18D} Third party service

    ...

    2015/08/27 16:24:51.2692010 732   7788  DownloadManager Resuming download job B6BBA68F-0B0A-460D-A445-F04ACDBD72F2 failed with 0x80070032.

    2015/08/27 16:24:51.4568546 732   7788  DownloadManager Resuming download job B6BBA68F-0B0A-460D-A445-F04ACDBD72F2 failed with 0x80070032.      (more of these)

    2015/08/27 16:24:51.9525151 732   7788  DownloadManager Suspending download job B6BBA68F-0B0A-460D-A445-F04ACDBD72F2 failed with 0x80070490.  Continuing.

    2015/08/27 16:31:50.4473364 8     6500  DownloadManager Restoring download no. 8
    2015/08/27 16:31:50.4473397 8     6500  DownloadManager JobId = {B6BBA68F-0B0A-460D-A445-F04ACDBD72F2}
    2015/08/27 16:31:50.4473420 8     6500  DownloadManager ServiceId = {7971F918-A847-4430-9279-4A52D1EFE18D}
    2015/08/27 16:31:50.4485410 8     6500  DownloadManager UpdateId = {B11D5453-0D3B-46A0-8031-50B475F25528}.107
    2015/08/27 16:31:50.4493948 8     6500  DownloadManager Exit code = 0x80200001
    2015/08/27 16:31:50.4512292 8     6500  DownloadManager Error 0x80200001 occurred while downloading update; notifying dependent calls.
    2015/08/27 16:31:50.4518865 8     6500  DownloadManager Restoring download no. 9

    no further mention of that job.

    Lots of messages like this : 

    2015/08/27 16:33:58.3178072 8     3596  DownloadManager P2P Download job 69BBB229-9D88-4594-AF87-0B8032127BDE failed to resume, queueing redownload.
    2015/08/27 16:33:58.3210412 8     3596  DownloadManager Resuming download job A5933125-B209-47BF-B303-EE92379B328B failed with 0x80070032.

    2015/08/27 16:33:58.6540767 8     3596  DownloadManager Updating download job 541792E6-72F8-4193-83C3-AF83C1E1A159 failed with 0x80240fff. Continuing.
    2015/08/27 16:33:58.6863131 8     3596  DownloadManager P2P download failed, falling back on BITS and retrying with new Download Job.
    2015/08/27 16:33:58.6866611 8     3596  DownloadManager CUpdateDownloadJob::GetNetworkCostSwitch() Neither unrestricted or restricted network cost used, so using current cost

    2015/08/27 16:33:59.5012899 8     3596  DownloadManager P2P download failed, falling back on BITS and retrying with new Download Job. 

    There are no relevant entries in the 10 Pro log at the corresponding times.

    I dont know how to track one update, eg KB3081444, in the log, and see if it uses P2P (guessing this is WUDO) or BITS (from http://au.v4.download.windowsupdate.com/msdownload/update/software/secu/...etc..). (I understand WUDO uses pieces from both.)

    Or what proportion of the update was from our LAN vs from windowsupdate.com

    Well...

    Chris


    • Edited by chris733 Thursday, August 27, 2015 7:02 AM
    Thursday, August 27, 2015 6:59 AM