none
how to inject usb 3.0 drivers in to Boot image? RRS feed

  • Question

  • Hi guys,



    in my organization they are not using SCCM and not using WDS, i was able to implement only the MDT ( there is no much resources), and it worked fine (this was my first time that i've installed and configured it)

    all my last work places always had this thing working in combination of WDS so i never needed to do any imaging, only booting from PXE and all the rest were working without any problems (we had a department that made all the images).

    i was able to deploy windows 7 pc's without any problem, booting from a flash drive and then choosing a TS and it worked grate.

    until I got a "tiny Lenovo M700", I downloaded all the drivers from the Lenovo SCCM pack website and configured the correct TS but when the winpe loads into the wizard, the mouse and the keyboard not responding.

    I did some research about that and tried to use DISM and all but without any success...

    thanks alot for your help,

    Lev.

    Wednesday, January 18, 2017 2:27 PM

All replies

  • Hi Lev,

    I'd strongly suggest following the Total Control method listed here - http://deploymentresearch.com/Research/Post/325/MDT-2013-Lite-Touch-Driver-Management

    Remember when adding new PE drivers you must generate a new boot image to include those drivers.


    If this post is helpful please vote it as Helpful or click Mark for answer.

    • Proposed as answer by Dan_Vega Thursday, January 19, 2017 2:37 PM
    Wednesday, January 18, 2017 2:35 PM
  • Hi Dan and thanks a lot for your replay,

    I was wondering, the WinPE drivers in the first section are only for the NIC and he don't have there any USB drivers, how can it be?

    the WinPE does not use any keyboard or mouse? it's impossible

    Thanks,

    Lev


    Wednesday, January 18, 2017 5:16 PM
  • If you're using the latest PE (installed the latest ADK on the machine with MDT) it will have native support for standard USB, however you would need to add drivers to PE for NIC and Storage which would include adding USB 3 drivers for people who boot from a flash drive/media based deployment.

    For example these are drivers I have added to PE x64


    If this post is helpful please vote it as Helpful or click Mark for answer.


    • Edited by Dan_Vega Wednesday, January 18, 2017 5:37 PM
    Wednesday, January 18, 2017 5:36 PM
  • ok,

    thanks a lot for your help my friend !

    you don't know what i did today to be able to deploy the PC that i need,

    i had some pc who stopped the deployment in the middle and i didn't had time to do much things, so I've booted into the WinPE did "exit to command promt" and then copied the folder from my Flash driver to the C: drive used the Virtual keyboard from the BIOS, and then i installed all the drivers 

    loool

    Wednesday, January 18, 2017 6:03 PM
  • The M700 tiny should not have USB driver problems with the Windows 10 ADK (any version). I have not had problems on my M800. Do you have a strange USB 3.0 keyboard?

    Try plugging the USB Keyboard into a different port (do you have a USB 2.0 only port).

    Otherwise try using a USB 2.0 only hub between the machine and your keyboard.

    If the problem were in fact a missing USB 3.0 driver, the recomendtation would be to add the driver to WinPE folder in MDT, add the folder to a selection profile, and add the selection profile to the WinPE Settings.

    https://social.technet.microsoft.com/Forums/en-US/3e083173-f5db-48e9-b744-f71b9ca6541c/how-to-debug-missing-drivers-in-mdt?forum=mdt

    But my experience says it's not a missing driver, something else.


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Wednesday, January 18, 2017 11:37 PM
    Moderator
  • Hi Keith, i did some "trick" to install it (as i write above)

    but i'll use your trick in the next time if i'll have this kind of problem :)

    thanks a lot

    Thursday, January 19, 2017 1:43 PM