locked
How to RDC Outbound on a Special Port in Windows 10 Home? RRS feed

  • Question

  • What do I need to configure to allow a remote desktop connection (RDC) out using a non-3389 port from Windows 10 Home? The firewall? It doesn't even show RDC as an app as compare to Windows 10 Pro/Enterprise?

    Thanks. Marc

    Monday, January 4, 2016 9:43 PM

Answers

  • Well no outbound Remote-Desktop rules on a Pro machine I can see. Perhaps in the first instance turn off the firewall as test see if it works. If so on Windows Firewall with Advance Security, select Outbound Rules right click Outbound Rules New Rule... either select a port and put the port number you are trying to use, allowed all domains. Or a program C:\Windows\System32\mstsc.exe and allow all domains.

    Monday, January 4, 2016 10:36 PM
  • I wasn't sure given your description.
     
    It could be a firewall issue on the local PC, but that isn't the usual
    way Windows Firewall is configured, do you have a third party firewall or
    a rule blocking outgoing connections in Windows firewall?
     
    It could also be your local router, but that to isn't a usual
    configuration.  It's something to check though...
     
    Tuesday, January 5, 2016 1:26 AM

All replies

  • Open the start menu and type mstsc, then click on Remote Desktop
    Connection.
     
    Put the host name in the box, then a colon, then the port number.
     
    Like this
     
    test.com:3398
     
    where test.com is the host name or IP address, and 3398 is the remote port
    number, whatever that is in your case.
     
     
    Monday, January 4, 2016 9:57 PM
  • Thanks Bob.

    Known how to use RDC to make a connection to a special port for years. But for some reason, the connection is being blocked and only from this machine; tested accessibility from other machine outside our firewall. Hence the configuration questions.

    Monday, January 4, 2016 10:18 PM
  • Well no outbound Remote-Desktop rules on a Pro machine I can see. Perhaps in the first instance turn off the firewall as test see if it works. If so on Windows Firewall with Advance Security, select Outbound Rules right click Outbound Rules New Rule... either select a port and put the port number you are trying to use, allowed all domains. Or a program C:\Windows\System32\mstsc.exe and allow all domains.

    Monday, January 4, 2016 10:36 PM
  • I wasn't sure given your description.
     
    It could be a firewall issue on the local PC, but that isn't the usual
    way Windows Firewall is configured, do you have a third party firewall or
    a rule blocking outgoing connections in Windows firewall?
     
    It could also be your local router, but that to isn't a usual
    configuration.  It's something to check though...
     
    Tuesday, January 5, 2016 1:26 AM
  • Hi,

    How about the issue, is there anything to update?

    If the issue has been resolved by yourself, it would be much appreciated if you would share the troubleshoot experience here and mark the case. It would be much useful for the person who will come across the similar issue in the future.

    If the issue was resolved by the replies in this thread, please remember to click “Mark as Answer” on the post that helps you.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, January 14, 2016 1:30 AM