locked
Unable to Mount or remove Public Folder Databases RRS feed

  • Question

  • Hi,

    I have created a new public folder database and this failed to mount on creation. 

    When I try and mount the database I receive the below error. After checking the database file path I can see it has created the folder structure but it has not created the EDB file or log files. 

    Now I am unable to mount this database or remove it! 

    -----------------------

     

    --------------------------------------------------------

    Microsoft Exchange Error

    --------------------------------------------------------

    Failed to mount database 'Public Folder Database 4'.

     

    Public Folder Database 4

    Failed

    Error:

    Couldn't mount the database that you specified. Specified database: Public Folder Database 4; Error code: An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-1032)

    . [Database: Public Folder Database 4, Server: EXCH1.isofin.co.uk].

     

    An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-1032)

    . [Database: Public Folder Database 4, Server: EXCH1.isofin.co.uk]

     

    An Active Manager operation failed. Error: Operation failed with message: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-1032)

    . [Server: EXCHDR1.isofin.co.uk]

     

    MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-1032)

     

     

     

     

     

    --------------------------------------------------------

    OK

    --------------------------------------------------------

    Thanks,

    Thursday, December 1, 2011 12:01 PM

Answers

All replies

  • try Remove-PublicFolderDatabase "MyServer\Public Folder Database"

    if its successful, create a public folder database using EMC and uncheck mount this database in new public folder database wizard. Wait for a couple of minutes before mounting the database.

    --------------------------------

     

    if Remove-PublicFolderDatabase "MyServer\Public Folder Database" does not work, then manually create a  text file and rename it to databse name.edb (where public folder database is pointing to) and then try removing the public folders.

     

     

    Thursday, December 1, 2011 1:50 PM
  • Check if below links helps

    http://support.microsoft.com/kb/925825

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/bc829df7-a178-470c-ae12-b1315e2fb2bc/


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by Terence Yu Friday, December 2, 2011 6:33 AM
    • Marked as answer by Terence Yu Friday, December 16, 2011 8:08 AM
    Friday, December 2, 2011 2:49 AM
  • If you have any data in the Public Folder DB, then it won't allow you to remove it.
    Friday, December 2, 2011 3:14 AM
  • Hi
        You can read this blog remove public folder and recreate it again.

    Terence Yu

    TechNet Community Support

    • Marked as answer by Terence Yu Friday, December 16, 2011 8:08 AM
    Sunday, December 4, 2011 11:44 AM
  • Hi,

    You shoud wait for AD to replicate. In 2008 R2 forest it should be almost immediate, but for me 5 minutes did the trick.

    Regards



    Zbyněk
    • Proposed as answer by Zbynek Salon Tuesday, January 24, 2012 7:23 PM
    Sunday, January 22, 2012 12:12 AM