locked
Microsoft Exchange Transport service automatic stop working when we install-AntispamAgents.ps1 RRS feed

  • Question

  • Hello,

    If we install install-AntispamAgents.ps1 then Microsoft Exchange Transport service automatic stop and its not working but if we uninstall "Content Filter Agent" then Microsoft Exchange Transport service working. As we know "Content Filter Agent" is very important for us for the reason what we can do now. Please give advice ASAP.

    Microsoft Exchange couldn't start transport agents. The Microsoft Exchange Transport service will be stopped. Exception details: Failed to create type 'Microsoft.Exchange.Transport.Agent.ContentFilter.ContentFilterAgentFactory' from assembly 'C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\agents\Hygiene\Microsoft.Exchange.Transport.Agent.Hygiene.dll' due to error 'Exception from HRESULT: 0xC0630005'. : Microsoft.Exchange.Data.ExchangeConfigurationException: Failed to create type 'Microsoft.Exchange.Transport.Agent.ContentFilter.ContentFilterAgentFactory' from assembly 'C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\agents\Hygiene\Microsoft.Exchange.Transport.Agent.Hygiene.dll' due to error 'Exception from HRESULT: 0xC0630005'. ---> Microsoft.Exchange.Data.ExchangeConfigurationException: Exception from HRESULT: 0xC0630005 ---> System.Runtime.InteropServices.COMException: Exception from HRESULT: 0xC0630005
       at Microsoft.Exchange.Data.Transport.Interop.IComInvoke.ComAsyncInvoke(IProxyCallback callback)
       at Microsoft.Exchange.Transport.Agent.ContentFilter.Util.InvokeExLapi(ComProxy comProxy, AsyncCompletionCallback callback, ComArguments comArguments, MailItem mailItem, Byte[] requestType)
       at Microsoft.Exchange.Transport.Agent.ContentFilter.ContentFilterAgentFactory.InitializeFilter()
       --- End of inner exception stack trace ---
       at Microsoft.Exchange.Transport.Agent.ContentFilter.ContentFilterAgentFactory.InitializeFilter()
       at Microsoft.Exchange.Transport.Agent.ContentFilter.ContentFilterAgentFactory.Configure(Boolean onStartup)
       at Microsoft.Exchange.Transport.Agent.ContentFilter.ContentFilterAgentFactory..ctor()
       --- End of inner exception stack trace ---
       at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable.CreateAgentFactory(AgentInfo agentInfo)
       at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.FactoryTable..ctor(IEnumerable agents, FactoryInitializer factoryInitializer)
       at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.RuntimeSettings..ctor(MExConfiguration config, String agentGroup, FactoryInitializer factoryInitializer, AgentGrayExceptionHandler agentGrayExceptionHandler, IExecutionStatisticsCollectorFactory statisticCollectorFactory, ITransportSettingsConfiguration settingsConfiguration)
       at Microsoft.Exchange.Data.Transport.Internal.MExRuntime.MExRuntime.Initialize(String configFile, String agentGroup, ProcessTransportRole processTransportRole, String installPath, AgentGrayExceptionHandler agentGrayExceptionHandler, IExecutionStatisticsCollectorFactory statisticCollectorFactory, FactoryInitializer factoryInitializer, ITransportSettingsConfiguration transportSettingsConfiguration)
       at Microsoft.Exchange.Transport.Extensibility.AgentComponent.Load()


    Md. Ramin Hossain

    Tuesday, May 30, 2017 8:44 PM

Answers

  • Hi,

    Is this issue occur on Exchange 2016 on Windows Server 2016?

    If so, it's a know issue. To fix it, we need :
    A: If you used the Install-AntiSpamAgents.ps1 to install content filtering on the Mailbox role:
        1. Find a suitable replacement for your email hygiene needs such as EOP or other 3rd party solution
        2. Run the Uninstall-AntiSpamAgents.ps1 from the \Scripts folder created by Setup during Exchange installation

    B: If you are running the Edge role on Windows Server 2016:
        1. Delay deploying KB4013429 to your Edge role or uninstall the update if required to restore service
        2. Deploy the Edge role on Windows Server 2012 or Windows Servers 2012R2 (Preferred)

    More details, for your reference:
    https://blogs.technet.microsoft.com/exchange/2017/03/23/exchange-server-edge-support-on-windows-server-2016-update/

    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, May 31, 2017 9:24 AM

All replies

  • Hello Md Ramin,

    uninstalled KB4013429 rebooted the server

    Wednesday, May 31, 2017 4:26 AM
  • Hi,

    Is this issue occur on Exchange 2016 on Windows Server 2016?

    If so, it's a know issue. To fix it, we need :
    A: If you used the Install-AntiSpamAgents.ps1 to install content filtering on the Mailbox role:
        1. Find a suitable replacement for your email hygiene needs such as EOP or other 3rd party solution
        2. Run the Uninstall-AntiSpamAgents.ps1 from the \Scripts folder created by Setup during Exchange installation

    B: If you are running the Edge role on Windows Server 2016:
        1. Delay deploying KB4013429 to your Edge role or uninstall the update if required to restore service
        2. Deploy the Edge role on Windows Server 2012 or Windows Servers 2012R2 (Preferred)

    More details, for your reference:
    https://blogs.technet.microsoft.com/exchange/2017/03/23/exchange-server-edge-support-on-windows-server-2016-update/

    Best Regards,

    Allen Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, May 31, 2017 9:24 AM