locked
Out of office problem (SBS2011, Outlook 2010) RRS feed

  • Question

  • Hey!

    First post so bare with me. We have problems with Out Of Office in Outlook, I have read a bunch of tips but haven't been able to solve it yet. I'm not an exchange expert so forgive me if I ask stupid or strange questions. I'll try to describe the setup.

    The problem is that when I press the Out-Of-Office-button in Outlook I get an error message saying that the server is unavailable.

    The server is a freshly installed SBS2011 with Exchange 2010. We are using a POP3-connector to retreive all users mail from our ISP to exchange. This means that we have no DNS records pointing to our exchange server. Also, the server will only be used from within our LAN and through VPN. We will NOT be using OWA over the internet. We only have the self signed certificate that was installed during setup, and I have fiddled with internal and external uri/l's so I'm not sure what they should be anymore.

    The users have workgroup-connected computers (I know, not optimal but nothing I can do about it right now) with Outlook 2010 and 2007. All users are created both locally and on the server with the same username and password.

    That's about it. I have no idea where to begin... All help appreciated!

    Saturday, February 11, 2012 8:36 PM

Answers

  • Loads of things wrong here.

    If the machines are members of workgroup that means they are basically external users - even though they are on the LAN. That is going to require DNS records in the domain and the clients MUST use the SBS server for their DNS server. If you are using a router for DNS and/or DHCP, switch it off.

    I would run the Fix My Network wizard in the SBS management console to see if that resolves anything, if not run the "Setup Your Internet Address" wizard again which should set things back correctly. This is SBS, it is designed to be configured using the wizards and trying to go against that is going to cause you problems.

    I would also be recommending a commercial certificate is put in place - again because the clients are effectively external. A suitable certificate costs US$60/year from certificatesforexchange.com.

    Out of the Office uses the availability service, which is delivered to the Outlook clients using autodiscover, which requires DNS records. You cannot avoid that process, that is how Exchange is designed to work. If you decide to go outside the way that Exchange is designed to work then things are not going to work - that may sound blunt, but that is the way things are.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.

    • Marked as answer by Sophia Xu Tuesday, March 6, 2012 6:34 AM
    Sunday, February 12, 2012 5:55 PM

All replies

  • Loads of things wrong here.

    If the machines are members of workgroup that means they are basically external users - even though they are on the LAN. That is going to require DNS records in the domain and the clients MUST use the SBS server for their DNS server. If you are using a router for DNS and/or DHCP, switch it off.

    I would run the Fix My Network wizard in the SBS management console to see if that resolves anything, if not run the "Setup Your Internet Address" wizard again which should set things back correctly. This is SBS, it is designed to be configured using the wizards and trying to go against that is going to cause you problems.

    I would also be recommending a commercial certificate is put in place - again because the clients are effectively external. A suitable certificate costs US$60/year from certificatesforexchange.com.

    Out of the Office uses the availability service, which is delivered to the Outlook clients using autodiscover, which requires DNS records. You cannot avoid that process, that is how Exchange is designed to work. If you decide to go outside the way that Exchange is designed to work then things are not going to work - that may sound blunt, but that is the way things are.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.

    • Marked as answer by Sophia Xu Tuesday, March 6, 2012 6:34 AM
    Sunday, February 12, 2012 5:55 PM
  • The clients use the SBS Server for DNS. DHCP is managed by the router though. What kind of record should I add to the SBS DNS? Just 'autodiscover' or 'autodiscover.mydomain.local' or 'autodiscover.mydomain.com'?

    I tried Fix My Network and Setup Your Internet Address wizard but the only ting that happened was that my smtp-settings got screwed... Took me half a day and all evening to fix that.

    I'll try the DNS trick and give you some feedback if it works or not.

    Thx for the help!

    Monday, February 13, 2012 9:25 PM